Bug 1251449 - posix_make_ancestryfromgfid doesn't set op_errno
posix_make_ancestryfromgfid doesn't set op_errno
Status: CLOSED CURRENTRELEASE
Product: GlusterFS
Classification: Community
Component: quota (Show other bugs)
mainline
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Vijaikumar Mallikarjuna
: Reopened, ZStream
Depends On: 1229621 1251447
Blocks: 1253260
  Show dependency treegraph
 
Reported: 2015-08-07 06:26 EDT by Vijaikumar Mallikarjuna
Modified: 2016-06-16 09:29 EDT (History)
5 users (show)

See Also:
Fixed In Version: glusterfs-3.8rc2
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 1251447
: 1253260 (view as bug list)
Environment:
Last Closed: 2016-06-16 09:29:42 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Comment 1 Anand Avati 2015-08-07 06:27:07 EDT
REVIEW: http://review.gluster.org/11861 (posix: posix_make_ancestryfromgfid shouldn't log ENOENT) posted (#1) for review on master by Vijaikumar Mallikarjuna (vmallika@redhat.com)
Comment 2 Anand Avati 2015-08-13 06:44:15 EDT
COMMIT: http://review.gluster.org/11861 committed in master by Raghavendra G (rgowdapp@redhat.com) 
------
commit fb4955b796ab2f3236e00686ecc99e792f9c0f8b
Author: vmallika <vmallika@redhat.com>
Date:   Fri Aug 7 15:51:53 2015 +0530

    posix: posix_make_ancestryfromgfid shouldn't log ENOENT
    
    posix_make_ancestryfromgfid shouldn't log ENOENT
    and it should set proper op_errno
    
    Change-Id: I8a87f30bc04d33cab06c91c74baa9563a1c7b45d
    BUG: 1251449
    Signed-off-by: vmallika <vmallika@redhat.com>
    Reviewed-on: http://review.gluster.org/11861
    Tested-by: NetBSD Build System <jenkins@build.gluster.org>
    Tested-by: Gluster Build System <jenkins@build.gluster.com>
    Reviewed-by: Manikandan Selvaganesh <mselvaga@redhat.com>
    Reviewed-by: Raghavendra G <rgowdapp@redhat.com>
Comment 3 Nagaprasad Sathyanarayana 2015-10-25 10:43:01 EDT
Fix for this BZ is already present in a GlusterFS release. You can find clone of this BZ, fixed in a GlusterFS release and closed. Hence closing this mainline BZ as well.
Comment 4 Niels de Vos 2016-06-16 09:29:42 EDT
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.8.0, please open a new bug report.

glusterfs-3.8.0 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] http://blog.gluster.org/2016/06/glusterfs-3-8-released/
[2] http://thread.gmane.org/gmane.comp.file-systems.gluster.user

Note You need to log in before you can comment on or make changes to this bug.