Bug 1251454 - marker: set loc.parent if NULL
marker: set loc.parent if NULL
Status: CLOSED CURRENTRELEASE
Product: GlusterFS
Classification: Community
Component: quota (Show other bugs)
mainline
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Vijaikumar Mallikarjuna
: Reopened
Depends On:
Blocks: 1251457 1257441
  Show dependency treegraph
 
Reported: 2015-08-07 06:50 EDT by Vijaikumar Mallikarjuna
Modified: 2016-06-16 09:29 EDT (History)
3 users (show)

See Also:
Fixed In Version: glusterfs-3.8rc2
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 1251457 1257441 (view as bug list)
Environment:
Last Closed: 2016-06-16 09:29:42 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Vijaikumar Mallikarjuna 2015-08-07 06:50:37 EDT
Lot of errors seen in the brick logs in one of the community user setup:

storage3__export-brick_home-brick1-data.log:[2015-08-04 22:33:46.346073] W [marker-quota.c:3379:_mq_initiate_quota_txn] 0-vol_home-marker: parent is NULL for <gfid:448efb74-5461-442c-9e2e-6009a01207db>, aborting updation txn
storage3__export-brick_home-brick1-data.log:[2015-08-04 22:33:46.346895] W [marker-quota.c:3379:_mq_initiate_quota_txn] 0-vol_home-marker: parent is NULL for <gfid:448efb74-5461-442c-9e2e-6009a01207db>, aborting updation txn
storage3__export-brick_home-brick1-data.log:[2015-08-04 22:33:46.347586] W [marker-quota.c:3379:_mq_initiate_quota_txn] 0-vol_home-marker: parent is NULL for <gfid:448efb74-5461-442c-9e2e-6009a01207db>, aborting updation txn


if loc.parent is NULL, get it from inode table and remove the log is parent not found
Comment 1 Anand Avati 2015-08-07 06:55:41 EDT
REVIEW: http://review.gluster.org/11863 (marker: don't log warning in txn if parent is NULL) posted (#1) for review on master by Vijaikumar Mallikarjuna (vmallika@redhat.com)
Comment 2 Anand Avati 2015-08-07 07:44:28 EDT
REVIEW: http://review.gluster.org/11863 (marker: don't log warning in txn if parent is NULL) posted (#2) for review on master by Vijaikumar Mallikarjuna (vmallika@redhat.com)
Comment 3 Anand Avati 2015-08-10 02:19:58 EDT
REVIEW: http://review.gluster.org/11863 (marker: fix log when loc.parent and inode gfid is NULL) posted (#3) for review on master by Vijaikumar Mallikarjuna (vmallika@redhat.com)
Comment 4 Anand Avati 2015-08-13 20:53:36 EDT
REVIEW: http://review.gluster.org/11863 (marker: fix log when loc.parent and inode gfid is NULL) posted (#5) for review on master by Vijaikumar Mallikarjuna (vmallika@redhat.com)
Comment 5 Anand Avati 2015-08-20 23:53:05 EDT
REVIEW: http://review.gluster.org/11863 (marker: fix log when loc.parent and inode gfid is NULL) posted (#8) for review on master by Vijaikumar Mallikarjuna (vmallika@redhat.com)
Comment 6 Anand Avati 2015-08-24 04:43:07 EDT
REVIEW: http://review.gluster.org/11995 (posix: xattrop 'GF_XATTROP_GET_AND_SET' implementation) posted (#1) for review on master by Vijaikumar Mallikarjuna (vmallika@redhat.com)
Comment 7 Anand Avati 2015-08-24 06:22:33 EDT
REVIEW: http://review.gluster.org/11995 (posix: xattrop 'GF_XATTROP_GET_AND_SET' implementation) posted (#2) for review on master by Vijaikumar Mallikarjuna (vmallika@redhat.com)
Comment 8 Anand Avati 2015-08-26 04:06:59 EDT
REVIEW: http://review.gluster.org/11995 (posix: xattrop 'GF_XATTROP_GET_AND_SET' implementation) posted (#5) for review on master by Vijaikumar Mallikarjuna (vmallika@redhat.com)
Comment 9 Anand Avati 2015-08-27 09:44:31 EDT
COMMIT: http://review.gluster.org/11995 committed in master by Raghavendra G (rgowdapp@redhat.com) 
------
commit 6ad05cd4b7995a3791a9e45ce03dc31641e8d78f
Author: vmallika <vmallika@redhat.com>
Date:   Mon Aug 24 13:14:59 2015 +0530

    posix: xattrop 'GF_XATTROP_GET_AND_SET' implementation
    
    GF_XATTROP_GET_AND_SET stores the existing xattr
    value in xdata and sets the new value
    
    xattrop was reusing input xattr dict to set the results
    instead of creating new dict.
    This can be problem for server side xlators as the inout dict
    will have the value changed.
    
    Change-Id: I43369082e1d0090d211381181e9f3b9075b8e771
    BUG: 1251454
    Signed-off-by: vmallika <vmallika@redhat.com>
    Reviewed-on: http://review.gluster.org/11995
    Tested-by: Gluster Build System <jenkins@build.gluster.com>
    Tested-by: NetBSD Build System <jenkins@build.gluster.org>
    Reviewed-by: Raghavendra G <rgowdapp@redhat.com>
Comment 10 Anand Avati 2015-08-27 12:10:08 EDT
REVIEW: http://review.gluster.org/12032 (marker: preserve previous dirty flag during update txn) posted (#1) for review on master by Vijaikumar Mallikarjuna (vmallika@redhat.com)
Comment 11 Anand Avati 2015-08-27 12:12:02 EDT
REVIEW: http://review.gluster.org/12032 (marker: preserve previous dirty flag during update txn) posted (#2) for review on master by Vijaikumar Mallikarjuna (vmallika@redhat.com)
Comment 12 Anand Avati 2015-08-28 06:44:22 EDT
REVIEW: http://review.gluster.org/12032 (marker: preserve previous dirty flag during update txn) posted (#3) for review on master by Vijaikumar Mallikarjuna (vmallika@redhat.com)
Comment 13 Nagaprasad Sathyanarayana 2015-10-25 10:55:31 EDT
Fix for this BZ is already present in a GlusterFS release. You can find clone of this BZ, fixed in a GlusterFS release and closed. Hence closing this mainline BZ as well.
Comment 14 Niels de Vos 2016-06-16 09:29:42 EDT
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.8.0, please open a new bug report.

glusterfs-3.8.0 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] http://blog.gluster.org/2016/06/glusterfs-3-8-released/
[2] http://thread.gmane.org/gmane.comp.file-systems.gluster.user

Note You need to log in before you can comment on or make changes to this bug.