Bug 1257441 - marker: set loc.parent if NULL
marker: set loc.parent if NULL
Status: CLOSED CURRENTRELEASE
Product: GlusterFS
Classification: Community
Component: quota (Show other bugs)
3.7.3
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Vijaikumar Mallikarjuna
:
Depends On: 1251454
Blocks: 1251457
  Show dependency treegraph
 
Reported: 2015-08-27 01:53 EDT by Vijaikumar Mallikarjuna
Modified: 2016-05-11 18:48 EDT (History)
3 users (show)

See Also:
Fixed In Version: glusterfs-3.7.4
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 1251454
Environment:
Last Closed: 2015-09-09 05:41:02 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Vijaikumar Mallikarjuna 2015-08-27 01:53:03 EDT
+++ This bug was initially created as a clone of Bug #1251454 +++

Lot of errors seen in the brick logs in one of the community user setup:

storage3__export-brick_home-brick1-data.log:[2015-08-04 22:33:46.346073] W [marker-quota.c:3379:_mq_initiate_quota_txn] 0-vol_home-marker: parent is NULL for <gfid:448efb74-5461-442c-9e2e-6009a01207db>, aborting updation txn
storage3__export-brick_home-brick1-data.log:[2015-08-04 22:33:46.346895] W [marker-quota.c:3379:_mq_initiate_quota_txn] 0-vol_home-marker: parent is NULL for <gfid:448efb74-5461-442c-9e2e-6009a01207db>, aborting updation txn
storage3__export-brick_home-brick1-data.log:[2015-08-04 22:33:46.347586] W [marker-quota.c:3379:_mq_initiate_quota_txn] 0-vol_home-marker: parent is NULL for <gfid:448efb74-5461-442c-9e2e-6009a01207db>, aborting updation txn


if loc.parent is NULL, get it from inode table and remove the log is parent not found

--- Additional comment from Anand Avati on 2015-08-07 06:55:41 EDT ---

REVIEW: http://review.gluster.org/11863 (marker: don't log warning in txn if parent is NULL) posted (#1) for review on master by Vijaikumar Mallikarjuna (vmallika@redhat.com)

--- Additional comment from Anand Avati on 2015-08-07 07:44:28 EDT ---

REVIEW: http://review.gluster.org/11863 (marker: don't log warning in txn if parent is NULL) posted (#2) for review on master by Vijaikumar Mallikarjuna (vmallika@redhat.com)

--- Additional comment from Anand Avati on 2015-08-10 02:19:58 EDT ---

REVIEW: http://review.gluster.org/11863 (marker: fix log when loc.parent and inode gfid is NULL) posted (#3) for review on master by Vijaikumar Mallikarjuna (vmallika@redhat.com)

--- Additional comment from Anand Avati on 2015-08-13 20:53:36 EDT ---

REVIEW: http://review.gluster.org/11863 (marker: fix log when loc.parent and inode gfid is NULL) posted (#5) for review on master by Vijaikumar Mallikarjuna (vmallika@redhat.com)

--- Additional comment from Anand Avati on 2015-08-20 23:53:05 EDT ---

REVIEW: http://review.gluster.org/11863 (marker: fix log when loc.parent and inode gfid is NULL) posted (#8) for review on master by Vijaikumar Mallikarjuna (vmallika@redhat.com)

--- Additional comment from Anand Avati on 2015-08-24 04:43:07 EDT ---

REVIEW: http://review.gluster.org/11995 (posix: xattrop 'GF_XATTROP_GET_AND_SET' implementation) posted (#1) for review on master by Vijaikumar Mallikarjuna (vmallika@redhat.com)

--- Additional comment from Anand Avati on 2015-08-24 06:22:33 EDT ---

REVIEW: http://review.gluster.org/11995 (posix: xattrop 'GF_XATTROP_GET_AND_SET' implementation) posted (#2) for review on master by Vijaikumar Mallikarjuna (vmallika@redhat.com)

--- Additional comment from Anand Avati on 2015-08-26 04:06:59 EDT ---

REVIEW: http://review.gluster.org/11995 (posix: xattrop 'GF_XATTROP_GET_AND_SET' implementation) posted (#5) for review on master by Vijaikumar Mallikarjuna (vmallika@redhat.com)
Comment 1 Anand Avati 2015-08-27 02:02:55 EDT
REVIEW: http://review.gluster.org/12022 (posix: xattrop 'GF_XATTROP_GET_AND_SET' implementation) posted (#1) for review on release-3.7 by Vijaikumar Mallikarjuna (vmallika@redhat.com)
Comment 2 Anand Avati 2015-08-27 02:16:11 EDT
REVIEW: http://review.gluster.org/12023 (marker: fix log when loc.parent and inode gfid is NULL) posted (#1) for review on release-3.7 by Vijaikumar Mallikarjuna (vmallika@redhat.com)
Comment 3 Anand Avati 2015-08-27 09:46:14 EDT
COMMIT: http://review.gluster.org/12022 committed in release-3.7 by Raghavendra G (rgowdapp@redhat.com) 
------
commit 3481e42a5325ba8a53f9121005dca80419658ea8
Author: vmallika <vmallika@redhat.com>
Date:   Thu Aug 27 11:31:01 2015 +0530

    posix: xattrop 'GF_XATTROP_GET_AND_SET' implementation
    
    This is a backport of http://review.gluster.org/#/c/11995
    
    GF_XATTROP_GET_AND_SET stores the existing xattr
    value in xdata and sets the new value
    
    xattrop was reusing input xattr dict to set the results
    instead of creating new dict.
    This can be problem for server side xlators as the inout dict
    will have the value changed.
    
    > Change-Id: I43369082e1d0090d211381181e9f3b9075b8e771
    > BUG: 1251454
    > Signed-off-by: vmallika <vmallika@redhat.com>
    
    Change-Id: I7e0c27fd415131e9983a10d27067f63ed3a7701e
    BUG: 1257441
    Signed-off-by: vmallika <vmallika@redhat.com>
    Reviewed-on: http://review.gluster.org/12022
    Tested-by: NetBSD Build System <jenkins@build.gluster.org>
    Tested-by: Gluster Build System <jenkins@build.gluster.com>
    Reviewed-by: Raghavendra G <rgowdapp@redhat.com>
Comment 4 Anand Avati 2015-08-28 05:52:57 EDT
REVIEW: http://review.gluster.org/12037 (marker: preserve previous dirty flag during update txn) posted (#1) for review on release-3.7 by Vijaikumar Mallikarjuna (vmallika@redhat.com)
Comment 5 Anand Avati 2015-08-31 02:35:08 EDT
REVIEW: http://review.gluster.org/12037 (marker: preserve previous dirty flag during update txn) posted (#2) for review on release-3.7 by Vijay Bellur (vbellur@redhat.com)
Comment 6 Anand Avati 2015-08-31 07:14:47 EDT
COMMIT: http://review.gluster.org/12037 committed in release-3.7 by Kaushal M (kaushal@redhat.com) 
------
commit 06a9b9f7a911b75a09eb3cc1b5d44b2392ad141e
Author: vmallika <vmallika@redhat.com>
Date:   Thu Aug 27 21:11:53 2015 +0530

    marker: preserve previous dirty flag during update txn
    
    This is a backport of http://review.gluster.org/#/c/12032/
    
    In case if dir has become dirty because of crash,
    this dirty flag on disk was getting reset in the
    next update txn.
    
    This patch now gets the dirty flag before setting
    in the update txn and it the value is dirty, it keeps
    the flag dirty, so that inspect_directory can fix the
    dirty dir
    
    > Change-Id: Iab2c343dbe19bd3b291adbfeebe6d9785b6bb9e3
    > BUG: 1251454
    > Signed-off-by: vmallika <vmallika@redhat.com>
    
    Change-Id: I10b81e5c0d9ffa00082171e295199d924a81ee0e
    BUG: 1257441
    Signed-off-by: vmallika <vmallika@redhat.com>
    Reviewed-on: http://review.gluster.org/12037
    Tested-by: Gluster Build System <jenkins@build.gluster.com>
    Tested-by: NetBSD Build System <jenkins@build.gluster.org>
    Reviewed-by: Kaushal M <kaushal@redhat.com>
Comment 7 Kaushal 2015-09-09 05:41:02 EDT
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.7.4, please open a new bug report.

glusterfs-3.7.4 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] http://thread.gmane.org/gmane.comp.file-systems.gluster.devel/12496
[2] http://thread.gmane.org/gmane.comp.file-systems.gluster.user

Note You need to log in before you can comment on or make changes to this bug.