Bug 1251821 - /usr/lib/glusterfs/ganesha/ganesha_ha.sh is distro specific
/usr/lib/glusterfs/ganesha/ganesha_ha.sh is distro specific
Status: CLOSED CURRENTRELEASE
Product: GlusterFS
Classification: Community
Component: ganesha-nfs (Show other bugs)
3.7.4
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Kaleb KEITHLEY
: Reopened, Triaged
: 1259938 (view as bug list)
Depends On:
Blocks: 1259938
  Show dependency treegraph
 
Reported: 2015-08-10 00:43 EDT by Joe Julian
Modified: 2016-05-31 09:11 EDT (History)
2 users (show)

See Also:
Fixed In Version: glusterfs-3.7.11
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 1259938 (view as bug list)
Environment:
Last Closed: 2016-05-31 09:11:36 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Joe Julian 2015-08-10 00:43:42 EDT
References to configuration files are specific to RPM based distros and are incorrect on ubuntu/debian/arch.
Comment 1 Kaleb KEITHLEY 2015-08-19 00:17:13 EDT
Perhaps you could give me some specifics about what doesn't work or what's different on your distro?

Thanks
Comment 2 Joe Julian 2015-09-03 12:31:14 EDT
For example, https://github.com/gluster/glusterfs/blob/master/extras/ganesha/scripts/ganesha-ha.sh#L53

Only EL based distros use /etc/sysconfig others use /etc/defaults or /etc/conf.d
Comment 3 Vijay Bellur 2015-09-03 15:13:31 EDT
REVIEW: http://review.gluster.org/12102 (common-ha: distribution neutral location of config files) posted (#1) for review on master by Kaleb KEITHLEY (kkeithle@redhat.com)
Comment 4 Kaleb KEITHLEY 2015-09-03 19:07:15 EDT
*** Bug 1259938 has been marked as a duplicate of this bug. ***
Comment 5 Vijay Bellur 2015-09-03 19:20:37 EDT
REVIEW: http://review.gluster.org/12103 (common-ha: distribution neutral location of config files) posted (#1) for review on release-3.7 by Kaleb KEITHLEY (kkeithle@redhat.com)
Comment 6 Vijay Bellur 2015-09-08 21:14:44 EDT
REVIEW: http://review.gluster.org/12103 (common-ha: distribution neutral location of config files) posted (#2) for review on release-3.7 by Kaleb KEITHLEY (kkeithle@redhat.com)
Comment 7 Pranith Kumar K 2015-10-14 06:28:00 EDT
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-glusterfs-3.7.5, please open a new bug report.

glusterfs-glusterfs-3.7.5 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] http://www.gluster.org/pipermail/gluster-users/2015-October/023968.html
[2] http://thread.gmane.org/gmane.comp.file-systems.gluster.user
Comment 8 Pranith Kumar K 2015-10-14 06:37:35 EDT
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.7.5, please open a new bug report.

glusterfs-3.7.5 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] http://www.gluster.org/pipermail/gluster-users/2015-October/023968.html
[2] http://thread.gmane.org/gmane.comp.file-systems.gluster.user
Comment 9 Vijay Bellur 2016-03-14 07:45:37 EDT
REVIEW: http://review.gluster.org/13723 (common-ha: distribution neutral location of config files) posted (#1) for review on master by Kaleb KEITHLEY (kkeithle@redhat.com)
Comment 10 Vijay Bellur 2016-03-15 00:33:40 EDT
COMMIT: http://review.gluster.org/13723 committed in master by Kaleb KEITHLEY (kkeithle@redhat.com) 
------
commit 6d83559ea42644ed39e21c76cef8a1974f3dcab0
Author: Joe Julian <jjulian@io.com>
Date:   Tue Sep 8 09:53:54 2015 -0700

    common-ha: distribution neutral location of config files
    
    work on systems with config files in directories other than
    /etc/sysconfig.
    
    BUG: 1251821
    Change-Id: I009946623b508ba422a4881913455218d8846055
    Signed-off-by: Joe Julian <me@joejulian.name>
    Reviewed-on: http://review.gluster.org/12132
    Tested-by: NetBSD Build System <jenkins@build.gluster.org>
    Tested-by: Gluster Build System <jenkins@build.gluster.com>
    Reviewed-by: soumya k <skoduri@redhat.com>
    Reviewed-by: Kaleb KEITHLEY <kkeithle@redhat.com>
    Reviewed-on: http://review.gluster.org/13723
    Tested-by: Kaleb KEITHLEY <kkeithle@redhat.com>
    Smoke: Gluster Build System <jenkins@build.gluster.com>
    NetBSD-regression: NetBSD Build System <jenkins@build.gluster.org>
    CentOS-regression: Gluster Build System <jenkins@build.gluster.com>

Note You need to log in before you can comment on or make changes to this bug.