This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 1259938 - /usr/lib/glusterfs/ganesha/ganesha_ha.sh is distro specific
/usr/lib/glusterfs/ganesha/ganesha_ha.sh is distro specific
Status: CLOSED DUPLICATE of bug 1251821
Product: GlusterFS
Classification: Community
Component: ganesha-nfs (Show other bugs)
3.7.4
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Kaleb KEITHLEY
: Triaged
Depends On: 1251821
Blocks:
  Show dependency treegraph
 
Reported: 2015-09-03 16:50 EDT by Kaleb KEITHLEY
Modified: 2015-09-03 19:07 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 1251821
Environment:
Last Closed: 2015-09-03 19:07:15 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Kaleb KEITHLEY 2015-09-03 16:50:28 EDT
+++ This bug was initially created as a clone of Bug #1251821 +++

References to configuration files are specific to RPM based distros and are incorrect on ubuntu/debian/arch.

--- Additional comment from Kaleb KEITHLEY on 2015-08-19 00:17:13 EDT ---

Perhaps you could give me some specifics about what doesn't work or what's different on your distro?

Thanks

--- Additional comment from Joe Julian on 2015-09-03 12:31:14 EDT ---

For example, https://github.com/gluster/glusterfs/blob/master/extras/ganesha/scripts/ganesha-ha.sh#L53

Only EL based distros use /etc/sysconfig others use /etc/defaults or /etc/conf.d

--- Additional comment from Vijay Bellur on 2015-09-03 15:13:31 EDT ---

REVIEW: http://review.gluster.org/12102 (common-ha: distribution neutral location of config files) posted (#1) for review on master by Kaleb KEITHLEY (kkeithle@redhat.com)
Comment 1 Kaleb KEITHLEY 2015-09-03 19:07:15 EDT
Doh. I forgot we're only fixing these on release-3.7 branch because we're replacing HA in 3.8.

*** This bug has been marked as a duplicate of bug 1251821 ***

Note You need to log in before you can comment on or make changes to this bug.