Bug 1251857 - nfs-ganesha: new volume creation tries to bring up glusterfs-nfs even when nfs-ganesha is already on
nfs-ganesha: new volume creation tries to bring up glusterfs-nfs even when nf...
Status: CLOSED CURRENTRELEASE
Product: GlusterFS
Classification: Community
Component: ganesha-nfs (Show other bugs)
mainline
x86_64 Linux
high Severity low
: ---
: ---
Assigned To: Soumya Koduri
: Reopened
Depends On: 1226817
Blocks: 1202842 1216951 1240614 1254419
  Show dependency treegraph
 
Reported: 2015-08-10 03:15 EDT by Meghana
Modified: 2016-06-16 09:30 EDT (History)
9 users (show)

See Also:
Fixed In Version: glusterfs-3.8rc2
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 1226817
: 1254419 (view as bug list)
Environment:
Last Closed: 2016-06-16 09:30:14 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Comment 1 Meghana 2015-08-10 03:16:04 EDT
Once we have nfs-ganesha up and running, the new volume creation still tries to bring up the glusterfs-nfs up, though unsuccessfully.

This is visible once you check the gluster status for that particular newly created volume,

Version-Release number of selected component (if applicable):
glusterfs-3.7.1


How reproducible:
always

Steps to Reproduce:
1. create a volume of type 6x2, start it
2. bring up nfs-ganesha, after doing all the pre-requisites
3. create another volume of any type,
4. gluster volume status <name of newly created volume>

Actual results:
step 4 results in response as displayed in description section

Expected results:
we should have a mechanism to find out if nfs-ganesha is already running, then the new volume should accept that as the nfs server, rather try to bring glusterfs-nfs.
Comment 2 Anand Avati 2015-08-10 06:16:46 EDT
REVIEW: http://review.gluster.org/11871 (Set nfs.disable to "on" when global NFS-Ganesha key is enabled) posted (#1) for review on master by Meghana M (mmadhusu@redhat.com)
Comment 3 Anand Avati 2015-08-10 08:11:57 EDT
REVIEW: http://review.gluster.org/11871 (Set nfs.disable to "on" when global NFS-Ganesha key is enabled) posted (#2) for review on master by Meghana M (mmadhusu@redhat.com)
Comment 4 Anand Avati 2015-08-10 08:37:33 EDT
REVIEW: http://review.gluster.org/11871 (Set nfs.disable to "on" when global NFS-Ganesha key is enabled) posted (#3) for review on master by Meghana M (mmadhusu@redhat.com)
Comment 5 Anand Avati 2015-08-10 20:36:25 EDT
COMMIT: http://review.gluster.org/11871 committed in master by Kaleb KEITHLEY (kkeithle@redhat.com) 
------
commit cdf238e7c90273beff73617481d19d77fc8014db
Author: Meghana M <mmadhusu@redhat.com>
Date:   Mon Aug 3 03:03:07 2015 +0530

    Set nfs.disable to "on" when global NFS-Ganesha key is enabled
    
    "nfs.disable" gets set to "on" for all the existing volumes,
    when the command "gluster nfs-ganesha enable" is executed.
    When a new volume is created,it gets exported via Gluster-NFS on
    the nodes outside the NFS-Ganesha. To fix this,
    the "nfs.disable" key is set to "on" before starting the volume,
    whenever the global option is set to "enable".
    
    Change-Id: I7ce58928c36eadb8c122cded5bdcea271a0a4ffa
    BUG: 1251857
    Signed-off-by: Meghana M <mmadhusu@redhat.com>
    Reviewed-on: http://review.gluster.org/11871
    Reviewed-by: jiffin tony Thottan <jthottan@redhat.com>
    Tested-by: NetBSD Build System <jenkins@build.gluster.org>
    Tested-by: Gluster Build System <jenkins@build.gluster.com>
    Reviewed-by: Kaleb KEITHLEY <kkeithle@redhat.com>
Comment 8 Nagaprasad Sathyanarayana 2015-10-25 11:04:17 EDT
Fix for this BZ is already present in a GlusterFS release. You can find clone of this BZ, fixed in a GlusterFS release and closed. Hence closing this mainline BZ as well.
Comment 9 Niels de Vos 2016-06-16 09:30:14 EDT
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.8.0, please open a new bug report.

glusterfs-3.8.0 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] http://blog.gluster.org/2016/06/glusterfs-3-8-released/
[2] http://thread.gmane.org/gmane.comp.file-systems.gluster.user

Note You need to log in before you can comment on or make changes to this bug.