Bug 1251894 - Wrong permissions for new copr repository files
Wrong permissions for new copr repository files
Status: CLOSED DUPLICATE of bug 1250299
Product: Fedora
Classification: Fedora
Component: dnf-plugins-core (Show other bugs)
22
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: packaging-team-maint
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-08-10 04:55 EDT by Heiko Adams
Modified: 2015-08-11 10:38 EDT (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-08-11 10:38:12 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Heiko Adams 2015-08-10 04:55:21 EDT
Description of problem:
When adding new copr repositories by using "sudo dnf copr enable xy" the repository files are only readable for root which causes "dnf repolist" to claim the copr repository as not readable.

Version-Release number of selected component (if applicable):
dnf-plugins-core-0.1.9-1.fc22.noarch

How reproducible:
allways

Steps to Reproduce:
1. Run "sudo dnf copr enable" for a copr repo you want to use
2. Run "dnf repolist" to see all available repos on your machine

Actual results:
The copr repo-file is not readable to your user due to wrong file premissions.

Expected results:
The copr repo-file should be readable to all users like other repos.

Additional info:
Doing a "sudo chmod a+x" on the copr repo file solves the problem
Comment 1 Radek Holy 2015-08-11 10:38:12 EDT

*** This bug has been marked as a duplicate of bug 1250299 ***

Note You need to log in before you can comment on or make changes to this bug.