Bug 1251901 - [RHEV-H] Failed to deploy Hosted Engine through specify software iscsi as storage.
[RHEV-H] Failed to deploy Hosted Engine through specify software iscsi as sto...
Status: CLOSED DUPLICATE of bug 1247888
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-node-plugin-hosted-engine (Show other bugs)
3.5.4
Unspecified Unspecified
high Severity medium
: ---
: 3.5.4
Assigned To: Ryan Barry
Virtualization Bugs
node
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-08-10 05:19 EDT by cshao
Modified: 2016-02-10 15:04 EST (History)
12 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-08-12 08:06:23 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: Node
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
20150812-software-iscsi.tar.gz (7.00 MB, application/x-gzip)
2015-08-11 22:18 EDT, cshao
no flags Details
20150812-software-iscsi.tar.gz (7.00 MB, application/x-gzip)
2015-08-11 22:19 EDT, cshao
no flags Details

  None (edit)
Comment 1 Fabian Deutsch 2015-08-10 06:51:57 EDT
From the logs: 

2015-07-21 08:56:32 DEBUG otopi.plugins.otopi.dialog.human dialog.__logString:215 DIALOG:SEND                 The following CPU types are supported by this host:
2015-07-21 08:56:32 DEBUG otopi.plugins.otopi.dialog.human dialog.__logString:215 DIALOG:SEND                 	 - model_Opteron_G3: AMD Opteron G3
2015-07-21 08:56:32 DEBUG otopi.plugins.otopi.dialog.human dialog.__logString:215 DIALOG:SEND                 	 - model_Opteron_G2: AMD Opteron G2
2015-07-21 08:56:32 DEBUG otopi.plugins.otopi.dialog.human dialog.__logString:215 DIALOG:SEND                 	 - model_Opteron_G1: AMD Opteron G1
2015-07-21 08:56:32 DEBUG otopi.context context._executeMethod:152 method exception
Traceback (most recent call last):
  File "/usr/lib/python2.7/site-packages/otopi/context.py", line 142, in _executeMethod
  File "/usr/share/ovirt-hosted-engine-setup/plugins/ovirt-hosted-engine-setup/vdsmd/cpu.py", line 194, in _customization
RuntimeError: Invalid CPU type specified: None
2015-07-21 08:56:32 ERROR otopi.context context._executeMethod:161 Failed to execute stage 'Environment customization': Invalid CPU type specified: None
2015-07-21 08:56:32 DEBUG otopi.context context.dumpEnvironment:490 ENVIRONMENT DUMP - BEGIN

Sandro, can you tell why we encounter this bug again (which we also saw in bug 1245143)?
Comment 2 Sandro Bonazzola 2015-08-10 09:11:27 EDT
(In reply to Fabian Deutsch from comment #1)
> From the logs: 
> 
> 2015-07-21 08:56:32 DEBUG otopi.plugins.otopi.dialog.human
> dialog.__logString:215 DIALOG:SEND                 The following CPU types
> are supported by this host:
> 2015-07-21 08:56:32 DEBUG otopi.plugins.otopi.dialog.human
> dialog.__logString:215 DIALOG:SEND                 	 - model_Opteron_G3: AMD
> Opteron G3
> 2015-07-21 08:56:32 DEBUG otopi.plugins.otopi.dialog.human
> dialog.__logString:215 DIALOG:SEND                 	 - model_Opteron_G2: AMD
> Opteron G2
> 2015-07-21 08:56:32 DEBUG otopi.plugins.otopi.dialog.human
> dialog.__logString:215 DIALOG:SEND                 	 - model_Opteron_G1: AMD
> Opteron G1
> 2015-07-21 08:56:32 DEBUG otopi.context context._executeMethod:152 method
> exception
> Traceback (most recent call last):
>   File "/usr/lib/python2.7/site-packages/otopi/context.py", line 142, in
> _executeMethod
>   File
> "/usr/share/ovirt-hosted-engine-setup/plugins/ovirt-hosted-engine-setup/
> vdsmd/cpu.py", line 194, in _customization
> RuntimeError: Invalid CPU type specified: None
> 2015-07-21 08:56:32 ERROR otopi.context context._executeMethod:161 Failed to
> execute stage 'Environment customization': Invalid CPU type specified: None
> 2015-07-21 08:56:32 DEBUG otopi.context context.dumpEnvironment:490
> ENVIRONMENT DUMP - BEGIN
> 
> Sandro, can you tell why we encounter this bug again (which we also saw in
> bug 1245143)?

Hadn't you solved on node TUI the handling on the answer file? If not then https://gerrit.ovirt.org/44240 is needed.
Comment 3 Fabian Deutsch 2015-08-10 09:15:07 EDT
We are now relying on he-setup's capability to retrieve a remote answerfile.

But: It looks like the intention was to install the first host. But this line:
          Please specify the Host ID [Must be integer, default: 2]: 
looks like the button to deploy an additional host was pressed.

Chen, could it be that you pressed the button to add an additional host?
Or that the storage was not clean?
Comment 4 cshao 2015-08-10 10:38:59 EDT
(In reply to Fabian Deutsch from comment #3)
> We are now relying on he-setup's capability to retrieve a remote answerfile.
> 
> But: It looks like the intention was to install the first host. But this
> line:
>           Please specify the Host ID [Must be integer, default: 2]: 
> looks like the button to deploy an additional host was pressed.
> 
> Chen, could it be that you pressed the button to add an additional host?
All above info was copy from the original bug 1245143, but actually this issue still can be reproduced on latest build rhev-hypervisor6-6.7-20150804.0 with the first host.

> Or that the storage was not clean?
I am certain the storage was clean.

Thanks!
Comment 5 Fabian Deutsch 2015-08-10 10:41:02 EDT
Please provide the exact logs from the reproducer.
Comment 6 Fabian Deutsch 2015-08-11 07:47:11 EDT
I'm seeing contradiction informtaions here:

On the one side - as described in comment 3 - I see that an additional host shall be added.

But on the other hand the description says it was the first host deployment.

So something must be wrong here, please clarify the reproducing steps and the open questions.
Comment 7 cshao 2015-08-11 22:16:20 EDT
OK, let me update the exact log and test steps:

rhev-hypervisor6-6.7-20150804.0
ovirt-node-3.2.3-16.el6.noarch
ovirt-node-plugin-hosted-engine-0.2.0-18.0.el6ev.noarch
ovirt-hosted-engine-ha-1.2.6-2.el6ev.noarch
ovirt-hosted-engine-setup-1.2.5.2-1.el6ev.noarch
ovirt-host-deploy-1.3.2-1.el6ev.noarch
rhevm-appliance-20150727.0-1.x86_64.rhevm.ova
rhevm vt16.6 (3.5.4-1.2.el6ev)

Test steps:
1. Prepare software iscsi storage and keep storage is clean.
2. Install RHEV-H and enabled Network.
3. Enter Hosted Engine menu, file the OVA URL with correct path.
4. Click <Setup first host setup>.
5. Specify software iscsi storage during storage configuration.
6. Finish the configuration in console.

Test result:
Failed to deploy Hosted Engine through specify software iscsi as storage, and pop-up msg in console: [screen is terminating], Hit <Return> to return to the TUI


          --== STORAGE CONFIGURATION ==--
         
          During customization use CTRL-D to abort.
          Please specify the storage you would like to use (iscsi, nfs3, nfs4)[nfs3]: iscsi
          Please specify the iSCSI portal IP address: 10.66.8.222
          Please specify the iSCSI portal port [3260]: 3260
          Please specify the iSCSI portal user: root
          Please specify the iSCSI portal password: 
          Please specify the target name (iqn.2013-01.com:hadong, iqn.2013-02.com:hadong, iqn.2013-03.com:hadong, iqn.2013-04.com:hadong) [iqn.2013-01.com:hadong]: iqn.2013-04.com:hadong
[ INFO  ] Discovering iSCSI node
[ INFO  ] Connecting to the storage server
          The following luns have been found on the requested target:
                 1 - sdb - 84796MB
          Please specify the lun id (1) [1]: 1
[ INFO  ] Installing on first host
          Please provide storage domain name. [hosted_storage]: 
          Local storage datacenter name is an internal name and currently will not be shown in engine's admin UI.
          Please enter local datacenter name [hosted_datacenter]: 
         
          --== SYSTEM CONFIGURATION ==--
         
         
          --== NETWORK CONFIGURATION ==--
         
          Please indicate a nic to set rhevm bridge on: (eth0) [eth0]: 
          iptables was detected on your computer, do you wish setup to configure it? (Yes, No)[Yes]: 
          Please indicate a pingable gateway IP address [10.66.73.254]: 
         
          --== VM CONFIGURATION ==--
         
[ INFO  ] Checking OVF archive content (could take a few minutes depending on archive size)
[ INFO  ] Checking OVF XML content (could take a few minutes depending on archive size)
[WARNING] OVF does not contain a valid image description, using default.
          Please specify an alias for the Hosted Engine image [hosted_engine]: 
          The following CPU types are supported by this host:
                 - model_Opteron_G3: AMD Opteron G3
                 - model_Opteron_G2: AMD Opteron G2
                 - model_Opteron_G1: AMD Opteron G1
          Please specify the CPU type to be used by the VM [model_Opteron_G3]: 
[WARNING] Minimum requirements for CPUs not met
          You may specify a unicast MAC address for the VM or accept a randomly generated default [00:16:3e:55:bb:cf]: 
          Please specify the console type you would like to use to connect to the VM (vnc, spice) [vnc]: 
         
          --== HOSTED ENGINE CONFIGURATION ==--
         
          Enter the name which will be used to identify this host inside the Administrator Portal [hosted_engine_1]: 
          Enter 'admin@internal' user password that will be used for accessing the Administrator Portal: 
          Confirm 'admin@internal' user password: 
          Please provide the FQDN for the engine you would like to use.
          This needs to match the FQDN that you will use for the engine installation within the VM.
          Note: This will be the FQDN of the VM you are now going to create,
          it should not point to the base host or to any other existing machine.
          Engine FQDN: cshaoengine.redhat.com
[WARNING] Failed to resolve cshaoengine.redhat.com using DNS, it can be resolved only locally
          Please provide the name of the SMTP server through which we will send notifications [localhost]: 
          Please provide the TCP port number of the SMTP server [25]: 
          Please provide the email address from which notifications will be sent [root@localhost]: 
          Please provide a comma-separated list of email addresses which will get notifications [root@localhost]: 
[ INFO  ] Stage: Setup validation
[WARNING] Failed to resolve cshaorhevh.redhat.com using DNS, it can be resolved only locally
         
          --== CONFIGURATION PREVIEW ==--
         
          Bridge interface                   : eth0
          Engine FQDN                        : cshaoengine.redhat.com
          Bridge name                        : rhevm
          SSH daemon port                    : 22
          Firewall manager                   : iptables
          Gateway address                    : 10.66.73.254
          Host name for web application      : hosted_engine_1
          iSCSI Target Name                  : iqn.2013-04.com:hadong
          iSCSI Portal port                  : 3260
          Host ID                            : 1
          iSCSI LUN ID                       : 1
          Image alias                        : hosted_engine
          Image size GB                      : 50
          iSCSI Portal IP Address            : 10.66.8.222
          iSCSI Portal user                  : root
          Console type                       : vnc
          Memory size MB                     : 4096
          MAC address                        : 00:16:3e:55:bb:cf
          Boot type                          : disk
          Number of CPUs                     : 1
          OVF archive (for disk boot)        : /data/ovirt-hosted-engine-setup/rhevm-appliance-20150727.0-1.x86_64.rhevm.ova
          CPU Type                           : model_Opteron_G3
         
          Please confirm installation settings (Yes, No)[Yes]:
[ INFO  ] Stage: Transaction setup
[ INFO  ] Stage: Misc configuration
[ INFO  ] Stage: Package installation
[ INFO  ] Stage: Misc configuration
[ INFO  ] Configuring libvirt
[ INFO  ] Configuring VDSM
[ INFO  ] Starting vdsmd
[ INFO  ] Waiting for VDSM hardware info
[ INFO  ] Waiting for VDSM hardware info
[ INFO  ] Waiting for VDSM hardware info
[ INFO  ] Waiting for VDSM hardware info
[ INFO  ] Configuring the management bridge
[ INFO  ] Creating Volume Group
[ INFO  ] Creating Storage Domain
[ INFO  ] Creating Storage Pool
[ INFO  ] Connecting Storage Pool
[ INFO  ] Verifying sanlock lockspace initialization
[ INFO  ] Creating VM Image
[ INFO  ] Extracting disk image from OVF archive (could take a few minutes depending on archive size)
[ INFO  ] Validating pre-allocated volume size
[ INFO  ] Uploading volume to data domain (could take a few minutes depending on archive size)
[ ERROR ] Failed to execute stage 'Misc configuration': Command '/usr/bin/sudo' failed to execute
[ INFO  ] Stage: Clean up
[ INFO  ] Generating answer file '/var/lib/ovirt-hosted-engine-setup/answers/answers-20150812020221.conf'
[ INFO  ] Stage: Pre-termination
[ INFO  ] Stage: Termination


[screen is terminating]                      : hosted_engine
Hit <Return> to return to the TUI
Comment 8 cshao 2015-08-11 22:18:11 EDT
Created attachment 1061768 [details]
20150812-software-iscsi.tar.gz

/var/log/*.*
sosreport
Comment 9 cshao 2015-08-11 22:19:52 EDT
Created attachment 1061769 [details]
20150812-software-iscsi.tar.gz
Comment 10 Fabian Deutsch 2015-08-12 03:49:38 EDT
First, the error now pasted in comment 7 is a different one than the one in the description.

And the message in the ovirt-hosted-engine-setup logs indicates a different cause:

2015-08-12 02:02:15 DEBUG otopi.plugins.ovirt_hosted_engine_setup.vm.boot_disk plugin.execute:937 execute-output: ('/usr/bin/sudo', '-u', 'vdsm', '-g', 'kvm', '/usr/bin/qemu-img', 'convert', '-O', 'raw', '/data/ovirt-hosted-engine-setup/tmp-setup/tmplaKqsT', '/rhev/data-center/mnt/blockSD/e96dee60-8bbf-4004-ac2d-4704aa7ce6cc/images/fafd3a02-39d5-4793-9aef-773113d461c6/610f5f0e-9cad-41ea-a52c-010d6e3b6fa4') stderr:
/rhev/data-center/mnt/blockSD/e96dee60-8bbf-4004-ac2d-4704aa7ce6cc/images/fafd3a02-39d5-4793-9aef-773113d461c6/610f5f0e-9cad-41ea-a52c-010d6e3b6fa4: error while converting raw: Permission denied

2015-08-12 02:02:15 DEBUG otopi.context context._executeMethod:152 method exception
Traceback (most recent call last):
  File "/usr/lib/python2.6/site-packages/otopi/context.py", line 142, in _executeMethod
  File "/usr/share/ovirt-hosted-engine-setup/plugins/ovirt-hosted-engine-setup/vm/boot_disk.py", line 513, in _misc
  File "/usr/lib/python2.6/site-packages/otopi/transaction.py", line 168, in __exit__
  File "/usr/lib/python2.6/site-packages/otopi/transaction.py", line 160, in commit
  File "/usr/share/ovirt-hosted-engine-setup/plugins/ovirt-hosted-engine-setup/vm/boot_disk.py", line 209, in commit
RuntimeError: Command '/usr/bin/sudo' failed to execute
2015-08-12 02:02:15 ERROR otopi.context context._executeMethod:161 Failed to execute stage 'Misc configuration': Command '/usr/bin/sudo' failed to execute

Is the env still available?
Comment 12 Fabian Deutsch 2015-08-12 08:00:19 EDT
This looks to be very similar to bug 1222058.

Simone, do you have any insight into the relationship to this other bug, or to this bug?
Comment 13 Simone Tiraboschi 2015-08-12 08:06:23 EDT
As for comment #7 it's  a clone of BZ#1247888 which should be solved in 3.5.5

*** This bug has been marked as a duplicate of bug 1247888 ***

Note You need to log in before you can comment on or make changes to this bug.