Bug 1251958 - VDSM: Live merge fails after a disk containing a snapshot has been extended
VDSM: Live merge fails after a disk containing a snapshot has been extended
Status: CLOSED ERRATA
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: vdsm (Show other bugs)
3.5.1
Unspecified Unspecified
high Severity high
: ovirt-3.5.7
: 3.5.7
Assigned To: Adam Litke
Aharon Canan
storage
: ZStream
Depends On: 1232481
Blocks:
  Show dependency treegraph
 
Reported: 2015-08-10 08:08 EDT by rhev-integ
Modified: 2016-02-10 14:20 EST (History)
15 users (show)

See Also:
Fixed In Version: vdsm-4.16.27-1
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 1232481
Environment:
Last Closed: 2016-01-12 15:34:31 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: Storage
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Knowledge Base (Solution) 1488453 None None None Never
oVirt gerrit 42836 master MERGED Live Merge: Prevent merge when base volume is too small Never
oVirt gerrit 42921 master MERGED Live merge: Update base size after live merge Never
oVirt gerrit 43407 master MERGED Live Merge: Allow extension of non-leaf raw volumes Never
oVirt gerrit 45104 ovirt-3.5 ABANDONED virt: Add _getVolumeInfo helper Never
oVirt gerrit 45105 ovirt-3.5 ABANDONED Live Merge: Allow extension of non-leaf raw volumes Never
oVirt gerrit 45106 ovirt-3.5 ABANDONED virt: Introduce Vm._setVolumeSize helper Never
oVirt gerrit 45107 ovirt-3.5 ABANDONED Live merge: Update base size after live merge Never
oVirt gerrit 45947 ovirt-3.5 MERGED virt: Add _getVolumeInfo helper Never
oVirt gerrit 45948 ovirt-3.5 MERGED Live Merge: Allow extension of non-leaf raw volumes Never
oVirt gerrit 45949 ovirt-3.5 MERGED virt: Introduce Vm._setVolumeSize helper Never
oVirt gerrit 45950 ovirt-3.5 MERGED Live merge: Update base size after live merge Never

  None (edit)
Comment 1 Aharon Canan 2015-10-06 08:27:00 EDT
Verified using the following versions:
---------------------------------------
rhevm-3.5.5-0.1.el6ev.noarch - running on Rhel6.7
vdsm-4.16.27-1.el7ev.x86_64 - running on Rhel7.1

Scenario 1:
----------------
1. Create a VM with 1gb preallocated disk (probably thin as well, didn't test that) in a block-based domain.
2. Create a snapshot.
3. Extend the disk to 2gb.
4. Start the VM.
5. Delete the snapshot - Live merge works well!


same verification like in https://bugzilla.redhat.com/show_bug.cgi?id=1241433 - same issue and 2 bugs - engine and vdsm
Comment 2 Adam Litke 2015-10-22 09:50:18 EDT
This will fail when the VM is not running on an SPM host as described in bug 1274323
Comment 3 Adam Litke 2015-10-22 09:51:40 EDT
Moving back to ASSIGNED per previous comment.
Comment 5 Yaniv Lavi 2015-10-28 10:07:57 EDT
Why did you move this to 3.5.7?
Comment 6 Tal Nisan 2015-11-01 06:20:06 EST
See comment #2, the bug is not completely fixed
Comment 7 Adam Litke 2015-11-03 09:20:16 EST
Talked with Tal and we decided to move this back to MODIFIED and track the backport of bug 1274323 in a new clone.  It will just keep things simpler.

To re-verify, you can rerun the scenario in comment one ensuring that the VM runs on the SPM host.
Comment 8 Aharon Canan 2015-12-24 05:18:20 EST
Verified using the following versions:
---------------------------------------
rhevm-3.5.7-0.1.el6ev.noarch - running on Rhel6.7
vdsm-4.16.31-1.el7ev.x86_64 - running on Rhel7.2

Scenario 1:
----------------
1. Create a VM with 1gb preallocated disk (probably thin as well, didn't test that) in a block-based domain.
2. Create a snapshot.
3. Extend the disk to 2gb.
4. Start the VM on SPM.
5. Delete the snapshot

Scenario 2:
--------------------
1) Create a VM with 1gb preallocated disk in a block-based domain.
2) Create a snapshot.
3) Create a second snapshot.
4) Extend the disk to 2gb.
5) Start the VM on SPM.
6) Delete the second snapshot


Same flows on HSM will be verified on https://bugzilla.redhat.com/show_bug.cgi?id=1292129

Also, didn't face any errors like in https://bugzilla.redhat.com/show_bug.cgi?id=1232481#c28
Comment 11 errata-xmlrpc 2016-01-12 15:34:31 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2016-0034.html

Note You need to log in before you can comment on or make changes to this bug.