Bug 1252297 - Quota: volume-reset shouldn't remove quota-deem-statfs, unless explicitly specified, when quota is enabled.
Quota: volume-reset shouldn't remove quota-deem-statfs, unless explicitly spe...
Status: CLOSED CURRENTRELEASE
Product: GlusterFS
Classification: Community
Component: quota (Show other bugs)
3.7.3
Unspecified Unspecified
medium Severity unspecified
: ---
: ---
Assigned To: Manikandan
: EasyFix, ZStream
: 1211860 (view as bug list)
Depends On: 1027723 1250582
Blocks: 1211860
  Show dependency treegraph
 
Reported: 2015-08-11 02:40 EDT by Manikandan
Modified: 2016-09-20 00:28 EDT (History)
10 users (show)

See Also:
Fixed In Version: glusterfs-3.7.4
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 1250582
Environment:
Last Closed: 2015-09-09 05:39:23 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Comment 1 Anand Avati 2015-08-11 03:26:14 EDT
REVIEW: http://review.gluster.org/11879 (quota : volume-reset shouldn't remove quota-deem-statfs) posted (#1) for review on release-3.7 by Manikandan Selvaganesh (mselvaga@redhat.com)
Comment 2 Anand Avati 2015-08-12 03:26:24 EDT
REVIEW: http://review.gluster.org/11879 (quota : volume-reset shouldn't remove quota-deem-statfs) posted (#2) for review on release-3.7 by Manikandan Selvaganesh (mselvaga@redhat.com)
Comment 3 Anand Avati 2015-08-12 07:46:58 EDT
COMMIT: http://review.gluster.org/11879 committed in release-3.7 by Raghavendra G (rgowdapp@redhat.com) 
------
commit 13061c8006471c87ff92007c8decc5586c600f0f
Author: Manikandan Selvaganesh <mselvaga@redhat.com>
Date:   Wed Aug 5 19:23:01 2015 +0530

    quota : volume-reset shouldn't remove quota-deem-statfs
    
    Volume-reset shouldn't remove quota-deem-statfs, unless
    explicitly specified, when quota is enabled.
    
    1) glusterd_op_stage_reset_volume ()
       'gluster volume set/reset <VOLNAME>' features.quota/
       features.inode-quota' should not be allowed as it is deprecated.
       Setting and resetting quota/inode-quota features should be allowed
       only through 'gluster volume quota <VOLNAME> enable/disable'.
    
    2) glusterd_enable_default_options ()
       Option 'features.quota-deem-statfs' should not be turned off
       with 'gluster volume reset <VOLNAME>', since quota features
       can be set/reset only with 'gluster volume quota <VOLNAME>
       enable/disable'.
    
    But, 'gluster volume set features.quota-deem-statfs'
    can be turned on/off when quota is enabled.
    
            Backport of http://review.gluster.org/#/c/11839/
    
    Cherry picked from commit 1868be8a5c309da8d516624d4af3b3b97819a9eb
    > Change-Id: Ib5aa00a4d8c82819c08dfc23e2a86f43ebc436c4
    > BUG: 1250582
    > Signed-off-by: Manikandan Selvaganesh <mselvaga@redhat.com>
    > Reviewed-on: http://review.gluster.org/11839
    > Tested-by: NetBSD Build System <jenkins@build.gluster.org>
    > Tested-by: Gluster Build System <jenkins@build.gluster.com>
    > Reviewed-by: Vijaikumar Mallikarjuna <vmallika@redhat.com>
    > Reviewed-by: Atin Mukherjee <amukherj@redhat.com>
    
    Change-Id: Ib5aa00a4d8c82819c08dfc23e2a86f43ebc436c4
    BUG: 1252297
    Signed-off-by: Manikandan Selvaganesh <mselvaga@redhat.com>
    Reviewed-on: http://review.gluster.org/11879
    Tested-by: NetBSD Build System <jenkins@build.gluster.org>
    Tested-by: Gluster Build System <jenkins@build.gluster.com>
    Reviewed-by: Raghavendra G <rgowdapp@redhat.com>
Comment 4 Vijaikumar Mallikarjuna 2015-08-13 07:32:18 EDT
*** Bug 1211860 has been marked as a duplicate of this bug. ***
Comment 5 Kaushal 2015-09-09 05:39:23 EDT
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.7.4, please open a new bug report.

glusterfs-3.7.4 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] http://thread.gmane.org/gmane.comp.file-systems.gluster.devel/12496
[2] http://thread.gmane.org/gmane.comp.file-systems.gluster.user

Note You need to log in before you can comment on or make changes to this bug.