Bug 125234 - [PATCH] redhat-config-users does not set account expiration, and when fixed sets it incorrectly
[PATCH] redhat-config-users does not set account expiration, and when fixed s...
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 3
Classification: Red Hat
Component: redhat-config-users (Show other bugs)
3.0
All Linux
medium Severity medium
: ---
: ---
Assigned To: Nils Philippsen
:
: 126347 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-06-03 16:52 EDT by Josef Bacik
Modified: 2007-11-30 17:07 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-12-20 16:25:54 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
The patch that fixes both the invalid variable name and the wrong date problem (987 bytes, patch)
2004-06-03 17:11 EDT, Josef Bacik
no flags Details | Diff

  None (edit)
Description Josef Bacik 2004-06-03 16:52:01 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.4.2)
Gecko/20040301

Description of problem:
When you try to set a user accounts expiration date, you will set it,
hit ok, then open it back up and there will be no expiration date. 
This is fixable, the programmer simply made a typo.  But when that is
corrected the program still sets the wrong expiration date.  Say for
instance I set an account to expire June 3, 2004, it will enter it as
expiring June 4, 2004.  I do not beleive this to be a bug with
redhat-config-user, but rather with the library libuser.  I have
patched it through redhat-config-user however, its ugly, but it works,
and I'm going to attatch it to this bugzilla report.  As soon as I
figure out how to that is :)

Version-Release number of selected component (if applicable):
redhat-config-users-1.1.18-1

How reproducible:
Always

Steps to Reproduce:
1.Open redhat-config-users
2.Set the expiration date for the account
3.Press ok
4.Look at the user properties again, there will be no expiration date

    

Actual Results:  You didnt see and expiration date.  After the
variable name problem was fixed, I set the expiration date with
usermod to June 1, 2004, and when I pulled it up on
redhat-config-users, got an expiration date of May 31, 2004

Expected Results:  I should have been able to set the expiration date
to begin with.  Also should have seen June 1, 2004 as the expiration
date in redhat-config-users.

Additional info:

I beleive the second part of this problem to not actually be a problem
with redhat-config-users, but rather with libuser and perhaps the time
in the on_ok_button_clicked function.
Comment 1 Josef Bacik 2004-06-03 17:11:20 EDT
Created attachment 100853 [details]
The patch that fixes both the invalid variable name and the wrong date problem

This will fix the variable name for in userProperties.py so you can at least
set the expiration date.  This also has the workaround for the wrong date
problem, albiet it is not the greatest patch in the world, it works.
Comment 3 Brent Fox 2004-06-21 15:28:40 EDT
*** Bug 126347 has been marked as a duplicate of this bug. ***
Comment 4 Brent Fox 2004-06-21 16:12:06 EDT
Patch applied and contained in system-config-users-1.2.14-1 in
Rawhide.  Please let me know if you need a formal errata created for
this bug.
Comment 5 Josef Bacik 2004-06-21 16:26:42 EDT
Just a note, I applied the patch to a new system and noticed that I
messed up with the date problem, and I'm working on fixing it now. 
You can still set the expiration date fine.  I don't think this needs
to be an errata, I only had one user with this problem and he was
content with the patch I sent him.
Comment 7 Nils Philippsen 2004-10-06 08:11:06 EDT
*** Bug 128429 has been marked as a duplicate of this bug. ***
Comment 8 Nils Philippsen 2004-10-06 08:13:51 EDT
This is supposed to be fixed in redhat-config-users-1.1.18-2.
Comment 9 John Flanagan 2004-12-20 16:25:54 EST
An advisory has been issued which should help the problem 
described in this bug report. This report is therefore being 
closed with a resolution of ERRATA. For more information
on the solution and/or where to find the updated files, 
please follow the link below. You may reopen this bug report 
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2004-557.html

Note You need to log in before you can comment on or make changes to this bug.