Bug 125240 - kdelibs (?) should require htmlview >= 3.0.0-4
kdelibs (?) should require htmlview >= 3.0.0-4
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: htmlview (Show other bugs)
2
i686 Linux
medium Severity low
: ---
: ---
Assigned To: Christopher Aillon
:
: 125686 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-06-03 19:39 EDT by Ben Smith
Modified: 2007-11-30 17:10 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-04-25 03:17:29 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Ben Smith 2004-06-03 19:39:30 EDT
Description of problem:
Upgraded FC1 box to kde-3.2.2 (from FC2)
(I think) kdelibs replaced the 'Evolution' icon on the panel with one
that points to 'launchmail'.  The version of htmlview in FC1 doesn't
include 'launchmail' so the icon doesn't work.

Version-Release number of selected component (if applicable):
kdelibs-3.2.2-4

How reproducible:
very

Steps to Reproduce:
1. build kde-3.2.2 and dependencies (from FC2) on FC1
2. install kde-3.2.2 on FC1
3. click on 'mail' icon on panel
4. error 'file not found: launchmail'
  
Additional info:
The first version of htmlview to include launchmail is 3.0.0-4 :
http://www.redhat.com/archives/fedora-devel-list/2004-May/msg00266.html
Comment 1 Ben Smith 2004-06-03 20:38:50 EDT
Ok now this is looking like a different problem, since the
'launchmail' script says all over it that it's for Gnome and now that
I've upgraded htmlview the script still doesn't work.  

It says:  'The mail client   does not exist:  please reconfigure'
Comment 2 Ben Smith 2004-06-03 21:13:07 EDT
And now it looks like htmlview should depend on control-center, guess
I'll make another bug for that...
Comment 3 Ben Smith 2004-06-09 22:58:41 EDT
OK, that looks right, *some* kde package should depend on htmlview,
just still not sure it's kdelibs.  I need to find out what package
creates or modifies the e-mail icon to point to 'launchmail'.
Comment 4 Ngo Than 2004-07-12 10:23:18 EDT
it's a bug in htmlview, which owns redhat-email.desktop and point to
lauchmail
Comment 5 Warren Togami 2005-04-25 03:17:29 EDT
It would upset KDE users too much to make KDE require GNOME packages.  Meanwhile
KDE completely lacks any notion of "Preferred" application choosing leaving us
to rely on GNOME's chooser.  These are conflicting requirements meaning this
problem cannot be fixed.  Sorry.
Comment 6 Warren Togami 2005-04-25 03:17:56 EDT
*** Bug 125686 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.