Bug 1252465 - rescue mode crashes when trying to rescue a dual-boot system
rescue mode crashes when trying to rescue a dual-boot system
Status: CLOSED DUPLICATE of bug 1249304
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
23
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Anaconda Maintenance Team
Fedora Extras Quality Assurance
:
Depends On:
Blocks: F23BetaBlocker
  Show dependency treegraph
 
Reported: 2015-08-11 09:39 EDT by Kamil Páral
Modified: 2015-08-11 13:46 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-08-11 10:10:51 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
anaconda traceback (666.75 KB, image/jpeg)
2015-08-11 09:39 EDT, Kamil Páral
no flags Details
journal (149.58 KB, text/plain)
2015-08-11 09:40 EDT, Kamil Páral
no flags Details
anaconda.log (1.51 KB, text/plain)
2015-08-11 09:40 EDT, Kamil Páral
no flags Details
program.log (5.96 KB, text/plain)
2015-08-11 09:40 EDT, Kamil Páral
no flags Details
storage.log (43.40 KB, text/plain)
2015-08-11 09:40 EDT, Kamil Páral
no flags Details
syslog (103.93 KB, text/plain)
2015-08-11 09:40 EDT, Kamil Páral
no flags Details

  None (edit)
Description Kamil Páral 2015-08-11 09:39:40 EDT
Created attachment 1061527 [details]
anaconda traceback

Description of problem:
I have installed a dual-boot system with Windows 8 and Fedora 23 Alpha, in UEFI mode. When I boot F23 Alpha Workstation netinst and select "Rescue system", I end up in a tmux console with anaconda traceback. The error is in fsminsize.py:57 and the error is:

> UnboundLocalError: local variable 'e' referenced before assignment

The error is not logged anywhere, and no anaconda-tb file is created, so there seems to be a second bug or an omission in logging and crash handling. As a punishment, all you get is a camera shot, because I don't know how else to get the info.

This problem seems to be specific to my disk contents. I have tried the same with a clean F23 Alpha install, and that seems to work. So this is likely related to the dual boot setup.

In the log I see some output related to NTFS partitions:

14:59:34,187 INFO program: Running... ntfsinfo -m /dev/sda4
14:59:34,198 INFO program: stdout:
14:59:34,198 INFO program: Failed to open '/dev/sda4'.
14:59:34,198 INFO program: stderr:
14:59:34,199 INFO program: b'Volume is scheduled for check.'
14:59:34,200 INFO program: b"Please boot into Windows TWICE, or use the 'force' option."
14:59:34,200 INFO program: b'NOTE: If you had not scheduled check and last time accessed this volume'
14:59:34,200 INFO program: b'using ntfsmount and shutdown system properly, then init scripts in your'
14:59:34,200 INFO program: b'distribution are broken. Please report to your distribution developers'
14:59:34,201 INFO program: b'(NOT to us!) that init scripts kill ntfsmount or mount.ntfs-fuse during'
14:59:34,201 INFO program: b'shutdown instead of proper umount.'
14:59:34,201 DEBUG program: Return code: 1
14:59:34,202 INFO program: Running... ntfsresize -m /dev/sda4
14:59:34,212 INFO program: stdout:
14:59:34,212 INFO program: ntfsresize v2015.3.14 (libntfs-3g)
14:59:34,213 INFO program: ERROR: Volume is scheduled for check.
14:59:34,213 INFO program: Run chkdsk /f and please try again, or see option -f.
14:59:34,213 DEBUG program: Return code: 1

I tried booting into Windows twice in a row, that didn't help. Maybe it would help if I forced filesystem check from windows. But anyway, anaconda should not crash, even if this was something that could not be fixed from Linux.

Version-Release number of selected component (if applicable):
F23 Alpha
anaconda 23.17-1

How reproducible:
always for my particular disk layout

Steps to Reproduce:
1. install Windows 8 and Fedora 23 Alpha in dual-boot, UEFI mode
2. boot F23 Alpha Workstation netinst (UEFI or BIOS mode)
3. see crash immediately on start
Comment 1 Kamil Páral 2015-08-11 09:40:21 EDT
Created attachment 1061528 [details]
journal
Comment 2 Kamil Páral 2015-08-11 09:40:23 EDT
Created attachment 1061529 [details]
anaconda.log
Comment 3 Kamil Páral 2015-08-11 09:40:25 EDT
Created attachment 1061530 [details]
program.log
Comment 4 Kamil Páral 2015-08-11 09:40:27 EDT
Created attachment 1061531 [details]
storage.log
Comment 5 Kamil Páral 2015-08-11 09:40:30 EDT
Created attachment 1061532 [details]
syslog
Comment 6 Kamil Páral 2015-08-11 09:44:20 EDT
This seems to violate:
"The rescue mode of the installer must start successfully and be able to detect and mount any installation performed according to the applicable criteria, and provide a shell with access to utilities capable of performing typical recovery operations. "
https://fedoraproject.org/wiki/Fedora_23_Beta_Release_Criteria#rescue-mode

A dual-boot system is a pretty common system that people might want to perform a rescue operation on.
Comment 7 David Shea 2015-08-11 10:10:51 EDT
Fixed in the newest blivet.

*** This bug has been marked as a duplicate of bug 1249304 ***

Note You need to log in before you can comment on or make changes to this bug.