Bug 1249304 - UnboundLocalError: local variable 'e' referenced before assignment
UnboundLocalError: local variable 'e' referenced before assignment
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: python-blivet (Show other bugs)
23
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Vojtech Trefny
Fedora Extras Quality Assurance
abrt_hash:dc69f3b38b87ec0211ad32e6ca4...
:
: 1239158 1252465 1252593 1258122 (view as bug list)
Depends On:
Blocks: F23BetaBlocker
  Show dependency treegraph
 
Reported: 2015-08-01 08:53 EDT by Joost van der Sluis
Modified: 2016-04-02 10:57 EDT (History)
25 users (show)

See Also:
Fixed In Version: 23.19.1-1.fc23
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-08-27 13:58:40 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: anaconda-tb (194.44 KB, text/plain)
2015-08-01 08:53 EDT, Joost van der Sluis
no flags Details
File: anaconda.log (12.43 KB, text/plain)
2015-08-01 08:53 EDT, Joost van der Sluis
no flags Details
File: dnf.log (1.54 KB, text/plain)
2015-08-01 08:53 EDT, Joost van der Sluis
no flags Details
File: environ (494 bytes, text/plain)
2015-08-01 08:53 EDT, Joost van der Sluis
no flags Details
File: lsblk_output (3.06 KB, text/plain)
2015-08-01 08:53 EDT, Joost van der Sluis
no flags Details
File: nmcli_dev_list (1.20 KB, text/plain)
2015-08-01 08:53 EDT, Joost van der Sluis
no flags Details
File: os_info (451 bytes, text/plain)
2015-08-01 08:53 EDT, Joost van der Sluis
no flags Details
File: program.log (21.92 KB, text/plain)
2015-08-01 08:53 EDT, Joost van der Sluis
no flags Details
File: storage.log (31.34 KB, text/plain)
2015-08-01 08:53 EDT, Joost van der Sluis
no flags Details
File: syslog (99.57 KB, text/plain)
2015-08-01 08:53 EDT, Joost van der Sluis
no flags Details
File: ifcfg.log (2.09 KB, text/plain)
2015-08-01 08:53 EDT, Joost van der Sluis
no flags Details
File: packaging.log (205 bytes, text/plain)
2015-08-01 08:53 EDT, Joost van der Sluis
no flags Details
/tmp/anaconda.log after seeing this bug on the released F23 image (40.33 KB, text/plain)
2016-02-22 19:28 EST, Ivan Shapovalov
no flags Details
/tmp/ifcfg.log after seeing this bug on the released F23 image (4.39 KB, text/plain)
2016-02-22 19:29 EST, Ivan Shapovalov
no flags Details
/tmp/program.log after seeing this bug on the released F23 image (62.66 KB, text/plain)
2016-02-22 19:29 EST, Ivan Shapovalov
no flags Details
/tmp/storage.log after seeing this bug on the released F23 image (288.28 KB, text/plain)
2016-02-22 19:30 EST, Ivan Shapovalov
no flags Details

  None (edit)
Description Joost van der Sluis 2015-08-01 08:53:03 EDT
Description of problem:
I just started my system using boot.isofrom USB. btw: I'm on a 4K display.

Version-Release number of selected component:
anaconda-23.17-1

The following was filed automatically by anaconda:
anaconda 23.17-1 exception report
Traceback (most recent call first):
  File "/usr/lib/python3.4/site-packages/blivet/tasks/fsminsize.py", line 57, in _getResizeInfo
    error_msg = "failed to gather info from resize program: %s" % e
  File "/usr/lib/python3.4/site-packages/blivet/tasks/fsminsize.py", line 168, in doTask
    resize_info = self._getResizeInfo()
  File "/usr/lib/python3.4/site-packages/blivet/formats/fs.py", line 288, in updateSizeInfo
    result = self._minsize.doTask()
  File "/usr/lib/python3.4/site-packages/blivet/formats/fs.py", line 134, in __init__
    self.updateSizeInfo()
  File "/usr/lib/python3.4/site-packages/blivet/formats/__init__.py", line 85, in getFormat
    fmt = fmt_class(*args, **kwargs)
  File "/usr/lib/python3.4/site-packages/blivet/populator.py", line 1431, in handleUdevDeviceFormat
    device.format = formats.getFormat(format_designator, **kwargs)
  File "/usr/lib/python3.4/site-packages/blivet/populator.py", line 761, in addUdevDevice
    self.handleUdevDeviceFormat(info, device)
  File "/usr/lib/python3.4/site-packages/blivet/populator.py", line 1660, in _populate
    self.addUdevDevice(dev)
  File "/usr/lib/python3.4/site-packages/blivet/populator.py", line 1597, in populate
    self._populate()
  File "/usr/lib/python3.4/site-packages/blivet/devicetree.py", line 554, in populate
    self._populator.populate(cleanupOnly=cleanupOnly)
  File "/usr/lib/python3.4/site-packages/blivet/blivet.py", line 279, in reset
    self.devicetree.populate(cleanupOnly=cleanupOnly)
  File "/usr/lib/python3.4/site-packages/blivet/osinstall.py", line 1123, in storageInitialize
    storage.reset()
  File "/usr/lib64/python3.4/threading.py", line 868, in run
    self._target(*self._args, **self._kwargs)
  File "/usr/lib64/python3.4/site-packages/pyanaconda/threads.py", line 253, in run
    threading.Thread.run(self, *args, **kwargs)
  File "/usr/lib64/python3.4/site-packages/pyanaconda/threads.py", line 171, in raise_if_error
    raise exc_info[0](exc_info[1]).with_traceback(exc_info[2])
  File "/usr/lib64/python3.4/site-packages/pyanaconda/threads.py", line 116, in wait
    self.raise_if_error(name)
  File "/usr/lib64/python3.4/site-packages/pyanaconda/timezone.py", line 76, in time_initialize
    threadMgr.wait(THREAD_STORAGE)
  File "/usr/lib64/python3.4/threading.py", line 868, in run
    self._target(*self._args, **self._kwargs)
  File "/usr/lib64/python3.4/site-packages/pyanaconda/threads.py", line 253, in run
    threading.Thread.run(self, *args, **kwargs)
UnboundLocalError: local variable 'e' referenced before assignment

Additional info:
addons:         com_redhat_kdump
cmdline:        /usr/bin/python3  /sbin/anaconda
cmdline_file:   BOOT_IMAGE=vmlinuz initrd=initrd.img inst.stage2=hd:LABEL=Fedora-23-x86_64 rd.live.check quiet
dnf.rpm.log:    Aug 01 14:40:36 INFO --- logging initialized ---
executable:     /sbin/anaconda
hashmarkername: anaconda
kernel:         4.2.0-0.rc4.git1.1.fc23.x86_64
product:        Fedora
release:        Cannot get release name.
type:           anaconda
version:        23
Comment 1 Joost van der Sluis 2015-08-01 08:53:07 EDT
Created attachment 1058286 [details]
File: anaconda-tb
Comment 2 Joost van der Sluis 2015-08-01 08:53:08 EDT
Created attachment 1058287 [details]
File: anaconda.log
Comment 3 Joost van der Sluis 2015-08-01 08:53:09 EDT
Created attachment 1058288 [details]
File: dnf.log
Comment 4 Joost van der Sluis 2015-08-01 08:53:11 EDT
Created attachment 1058289 [details]
File: environ
Comment 5 Joost van der Sluis 2015-08-01 08:53:12 EDT
Created attachment 1058290 [details]
File: lsblk_output
Comment 6 Joost van der Sluis 2015-08-01 08:53:13 EDT
Created attachment 1058291 [details]
File: nmcli_dev_list
Comment 7 Joost van der Sluis 2015-08-01 08:53:14 EDT
Created attachment 1058292 [details]
File: os_info
Comment 8 Joost van der Sluis 2015-08-01 08:53:16 EDT
Created attachment 1058293 [details]
File: program.log
Comment 9 Joost van der Sluis 2015-08-01 08:53:17 EDT
Created attachment 1058294 [details]
File: storage.log
Comment 10 Joost van der Sluis 2015-08-01 08:53:19 EDT
Created attachment 1058295 [details]
File: syslog
Comment 11 Joost van der Sluis 2015-08-01 08:53:20 EDT
Created attachment 1058296 [details]
File: ifcfg.log
Comment 12 Joost van der Sluis 2015-08-01 08:53:21 EDT
Created attachment 1058297 [details]
File: packaging.log
Comment 13 Vojtech Trefny 2015-08-03 15:22:00 EDT
*** Bug 1239158 has been marked as a duplicate of this bug. ***
Comment 14 Fedora Update System 2015-08-07 20:56:11 EDT
python-blivet-1.12-1.fc23 has been submitted as an update for Fedora 23.
https://admin.fedoraproject.org/updates/python-blivet-1.12-1.fc23
Comment 15 Fedora Update System 2015-08-08 12:20:33 EDT
Package python-blivet-1.12-1.fc23:
* should fix your issue,
* was pushed to the Fedora 23 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing python-blivet-1.12-1.fc23'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2015-13041/python-blivet-1.12-1.fc23
then log in and leave karma (feedback).
Comment 16 David Shea 2015-08-11 10:10:51 EDT
*** Bug 1252465 has been marked as a duplicate of this bug. ***
Comment 17 Samantha N. Bueno 2015-08-11 16:41:09 EDT
*** Bug 1252593 has been marked as a duplicate of this bug. ***
Comment 18 Fedora Update System 2015-08-12 16:12:24 EDT
Package python-blivet-1.12-1.fc23, anaconda-23.19-1.fc23:
* should fix your issue,
* was pushed to the Fedora 23 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing python-blivet-1.12-1.fc23 anaconda-23.19-1.fc23'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2015-13041/anaconda-23.19-1.fc23,python-blivet-1.12-1.fc23
then log in and leave karma (feedback).
Comment 19 Dumindu 2015-08-12 21:05:15 EDT
Another user experienced a similar problem:

installation crash when move to hard driver selection

cmdline:        /usr/bin/python3  /sbin/anaconda --liveinst --method=livecd:///dev/mapper/live-base
cmdline_file:   BOOT_IMAGE=vmlinuz0 initrd=initrd0.img root=live:CDLABEL=Fedora-Live-WS-x86_64-23_A-2 rootfstype=auto ro rd.live.image quiet  rhgb rd.luks=0 rd.md=0 rd.dm=0 
hashmarkername: anaconda
kernel:         4.2.0-0.rc5.git0.2.fc23.x86_64
other involved packages: python3-blivet-1.10-1.fc23.noarch, python3-libs-3.4.3-5.fc23.x86_64
package:        anaconda-core-23.17-1.fc23.x86_64
packaging.log:  
product:        Fedora
reason:         UnboundLocalError: local variable 'e' referenced before assignment
release:        Fedora release 23 (Twenty Three)
version:        23
Comment 20 jperrygodfrey 2015-08-13 10:47:11 EDT
Another user experienced a similar problem:

I clicked the wizard to Install to hard Drive.  

cmdline:        /usr/bin/python3  /sbin/anaconda --liveinst --method=livecd:///dev/mapper/live-base
cmdline_file:   BOOT_IMAGE=vmlinuz0 initrd=initrd0.img root=live:CDLABEL=Fedora-Live-KDE-x86_64-23_A-2 rootfstype=auto ro rd.live.image quiet  rhgb rd.luks=0 rd.md=0 rd.dm=0 
hashmarkername: anaconda
kernel:         4.2.0-0.rc5.git0.2.fc23.x86_64
other involved packages: python3-blivet-1.10-1.fc23.noarch, python3-libs-3.4.3-5.fc23.x86_64
package:        anaconda-core-23.17-1.fc23.x86_64
packaging.log:  
product:        Fedora
reason:         UnboundLocalError: local variable 'e' referenced before assignment
release:        Fedora release 23 (Twenty Three)
version:        23
Comment 21 Donavan Lance 2015-08-13 21:16:25 EDT
Another user experienced a similar problem:

Started Fedora 23 Workstation Alpha, clicked "Install to Hard Drive", then pressed continue at the "Welcome to Fedora 23" screen. The installer then crashed saying, "An unknown error has occured".

cmdline:        /usr/bin/python3  /sbin/anaconda --liveinst --method=livecd:///dev/mapper/live-base
cmdline_file:   BOOT_IMAGE=/isolinux/vmlinuz0 root=live:LABEL=Fedora-Live-WS-x86_64-23_A-2 ro rd.live.image quiet rhgb rd.live.check
hashmarkername: anaconda
kernel:         4.2.0-0.rc5.git0.2.fc23.x86_64
other involved packages: python3-blivet-1.10-1.fc23.noarch, python3-libs-3.4.3-5.fc23.x86_64
package:        anaconda-core-23.17-1.fc23.x86_64
packaging.log:  
product:        Fedora
reason:         UnboundLocalError: local variable 'e' referenced before assignment
release:        Fedora release 23 (Twenty Three)
version:        23
Comment 22 Dumindu 2015-08-16 01:50:09 EDT
su -c 'yum update --enablerepo=updates-testing python-blivet-1.12-1.fc23 anaconda-23.19-1.fc23' fixed this issue.
Comment 23 Alexander 2015-08-18 05:39:13 EDT
Another user experienced a similar problem:

1. Start "Install to Hard Drive"
2. Change language from Ukrainian to English (click on English line).

Yestarday at the same configuration the installation was successfull. 
Today i have reproduced the error 5/5 times.

cmdline:        /usr/bin/python3  /sbin/anaconda --liveinst --method=livecd:///dev/mapper/live-base
cmdline_file:   BOOT_IMAGE=vmlinuz0 live_dir=/multiboot/Fedora-Live-Workstation-x86_64-23_Alpha-2/LiveOS initrd=initrd0.img root=live:LABEL=MULTIBOOT live_dir=/multiboot/Fedora-Live-Workstation-x86_64-23_Alpha-2/LiveOS NULL=Fedora-Live-WS-x86_64-23_A-2 rootfstype=auto ro rd.live.image quiet  rhgb rd.luks=0 rd.md=0 rd.dm=0 
hashmarkername: anaconda
kernel:         4.2.0-0.rc5.git0.2.fc23.x86_64
other involved packages: python3-libs-3.4.3-5.fc23.x86_64, python3-blivet-1.10-1.fc23.noarch
package:        anaconda-core-23.17-1.fc23.x86_64
packaging.log:  
product:        Fedora
reason:         UnboundLocalError: local variable 'e' referenced before assignment
release:        Fedora release 23 (Twenty Three)
version:        23
Comment 24 Pavel Sergeev 2015-08-19 17:54:13 EDT
Another user experienced a similar problem:

Just started installation from the Live DVD. The error message occurred on the first dialog without any actions.

cmdline:        /usr/bin/python3  /sbin/anaconda --liveinst --method=livecd:///dev/mapper/live-base
cmdline_file:   BOOT_IMAGE=/isolinux/vmlinuz0 root=live:LABEL=Fedora-Live-WS-x86_64-23_A-2 ro rd.live.image quiet rhgb
hashmarkername: anaconda
kernel:         4.2.0-0.rc5.git0.2.fc23.x86_64
other involved packages: python3-blivet-1.10-1.fc23.noarch, python3-libs-3.4.3-5.fc23.x86_64
package:        anaconda-core-23.17-1.fc23.x86_64
packaging.log:  
product:        Fedora
reason:         UnboundLocalError: local variable 'e' referenced before assignment
release:        Fedora release 23 (Twenty Three)
version:        23
Comment 25 Adam Williamson 2015-08-20 12:34:11 EDT
Discussed at 2015-08-20 blocker review meeting: http://meetbot-raw.fedoraproject.org/fedora-blocker-review/2015-08-20/f23-blocker-review.2015-08-20-16.05.log.txt . It's not entirely clear how serious or commonly encountered this is, or what exact circumstances trigger it. The fix is already pending and we're not frozen, so we agreed to defer the decision in the hopes that the fix will land and the bug will go away.

devs, if you could explain when this happens and how serious it is that'd help if it somehow *doesn't* go away - I can see the code in question is basically turning one exception into another, but didn't have time to trace it out and see if something catches the FSError and does something useful with it or if it just fails nicer.
Comment 26 Fedora Update System 2015-08-20 15:21:11 EDT
anaconda-23.19.1-1.fc23, python-blivet-1.12.1-1.fc23 has been pushed to the Fedora 23 testing repository. If problems still persist, please make note of it in this bug report.\nIf you want to test the update, you can install it with \n su -c 'yum --enablerepo=updates-testing update anaconda python-blivet'. You can provide feedback for this update here: https://bodhi.fedoraproject.org/F23/FEDORA-2015-13831
Comment 27 Alexander 2015-08-21 16:34:30 EDT
Sorry for my poor English.

I noticed that this bug appears when I set in the BIOS to boot from the second hdd (sata 2) (on the first hdd i have windows 10 installed), so probably this is a hardware problem or some issue with compatibility with windows 10. (O_o)

When in BIOS is set to boot from the first hdd (sata 1) - I can't reproduce this bug.


su -c 'yum --enablerepo=updates-testing update anaconda python-blivet' fix this bug for me, but after it i can't delete old partitions on my hard drives .
Comment 28 Fedora Update System 2015-08-22 12:25:24 EDT
anaconda-23.19.1-1.fc23, python-blivet-1.12.1-1.fc23 has been pushed to the Fedora 23 testing repository. If problems still persist, please make note of it in this bug report.\nIf you want to test the update, you can install it with \n su -c 'yum --enablerepo=updates-testing update anaconda python-blivet'. You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2015-13831
Comment 29 Adam Williamson 2015-08-24 12:27:40 EDT
Discussed at 2015-08-24 blocker review meeting: http://meetbot-raw.fedoraproject.org/fedora-blocker-review/2015-08-24/f23-blocker-review.2015-08-24-16.03.log.txt . Agreed to punt this again as we're still expecting it to be resolved and we're still not sure precisely what situations trigger it.
Comment 30 Zbigniew Jędrzejewski-Szmek 2015-08-24 12:55:49 EDT
FWIW, I'm seeing that too on bare metal.
Comment 31 Fedora Update System 2015-08-27 13:58:24 EDT
anaconda-23.19.1-1.fc23, python-blivet-1.12.1-1.fc23 has been pushed to the Fedora 23 stable repository. If problems still persist, please make note of it in this bug report.
Comment 32 philip 2015-08-28 04:38:44 EDT
Another user experienced a similar problem:

Boot Fedora 23 Alpha from Live USB. On screen whilst waiting for hard disk probe to finish the error occurs.

cmdline:        /usr/bin/python3  /sbin/anaconda --liveinst --method=livecd:///dev/mapper/live-base
cmdline_file:   BOOT_IMAGE=/isolinux/vmlinuz0 root=live:LABEL=Fedora-Live-WS-x86_64-23_A-2 ro rd.live.image quiet rhgb nomodeset
hashmarkername: anaconda
kernel:         4.2.0-0.rc5.git0.2.fc23.x86_64
other involved packages: python3-libs-3.4.3-5.fc23.x86_64, python3-blivet-1.10-1.fc23.noarch
package:        anaconda-core-23.17-1.fc23.x86_64
packaging.log:  
product:        Fedora
reason:         UnboundLocalError: local variable 'e' referenced before assignment
release:        Fedora release 23 (Twenty Three)
version:        23
Comment 33 Martin Kolman 2015-08-31 07:45:30 EDT
*** Bug 1258122 has been marked as a duplicate of this bug. ***
Comment 34 Glenn Johnson 2015-09-05 07:00:06 EDT
Another user experienced a similar problem:

Attempting to install Fedora 23 Live Cinnamon

cmdline:        /usr/bin/python3  /sbin/anaconda --liveinst --method=livecd:///dev/mapper/live-base
cmdline_file:   BOOT_IMAGE=vmlinuz0 initrd=initrd0.img root=live:CDLABEL=Fedora-Live-Cinnamon-x86_64-23_A rootfstype=auto ro rd.live.image quiet  rhgb rd.luks=0 rd.md=0 rd.dm=0 
hashmarkername: anaconda
kernel:         4.2.0-0.rc5.git0.2.fc23.x86_64
other involved packages: python3-libs-3.4.3-5.fc23.x86_64, python3-blivet-1.10-1.fc23.noarch
package:        anaconda-core-23.17-1.fc23.x86_64
packaging.log:  
product:        Fedora
reason:         UnboundLocalError: local variable 'e' referenced before assignment
release:        Fedora release 23 (Twenty Three)
version:        23
Comment 35 Glenn Johnson 2015-09-05 07:31:31 EDT
Another user experienced a similar problem:

Attempting to install 23 Alpha Workstation from an image downloaded minutes ago. Seems this error is not fixed.

cmdline:        /usr/bin/python3  /sbin/anaconda --liveinst --method=livecd:///dev/mapper/live-base
cmdline_file:   BOOT_IMAGE=vmlinuz0 initrd=initrd0.img root=live:CDLABEL=Fedora-Live-WS-x86_64-23_A-2 rootfstype=auto ro rd.live.image quiet  rhgb rd.luks=0 rd.md=0 rd.dm=0 
hashmarkername: anaconda
kernel:         4.2.0-0.rc5.git0.2.fc23.x86_64
other involved packages: python3-blivet-1.10-1.fc23.noarch, python3-libs-3.4.3-5.fc23.x86_64
package:        anaconda-core-23.17-1.fc23.x86_64
packaging.log:  
product:        Fedora
reason:         UnboundLocalError: local variable 'e' referenced before assignment
release:        Fedora release 23 (Twenty Three)
version:        23
Comment 36 Adam Williamson 2015-09-05 10:44:19 EDT
Glenn: we don't rebuild the Alpha images; milestones are frozen. See the "anaconda-core-23.17-1.fc23.x86_64" in your last report. The fix can be found in more recent nightly builds, or Beta TCs.
Comment 37 Franck GILET 2015-09-08 01:04:36 EDT
Another user experienced a similar problem:

Just when I want to launch the installation from Fedora live

cmdline:        /usr/bin/python3  /sbin/anaconda --liveinst --method=livecd:///dev/mapper/live-base
cmdline_file:   BOOT_IMAGE=vmlinuz0 initrd=initrd0.img root=live:CDLABEL=GRMCHPXFRER rootfstype=auto ro rd.live.image quiet  rhgb rd.luks=0 rd.md=0 rd.dm=0 
hashmarkername: anaconda
kernel:         4.2.0-0.rc5.git0.2.fc23.x86_64
other involved packages: python3-blivet-1.10-1.fc23.noarch, python3-libs-3.4.3-5.fc23.x86_64
package:        anaconda-core-23.17-1.fc23.x86_64
packaging.log:  
product:        Fedora
reason:         UnboundLocalError: local variable 'e' referenced before assignment
release:        Fedora release 23 (Twenty Three)
version:        23
Comment 38 Adam Williamson 2015-09-22 02:34:33 EDT
This should be OK in Beta, so dropping CommonBugs.
Comment 39 Ivan Shapovalov 2016-01-24 06:27:25 EST
Still seeing this in released image! anaconda-23.19.10-1.fc23.x86-64, python3-blivet-1.12.8-1.fc23-noarch.
Comment 40 Vojtech Trefny 2016-01-26 04:44:26 EST
This should really be fixed, please attach the logs from /tmp to this bug as individual, text/plain attachments. Thanks.
Comment 41 Ivan Shapovalov 2016-02-22 19:28 EST
Created attachment 1129578 [details]
/tmp/anaconda.log after seeing this bug on the released F23 image
Comment 42 Ivan Shapovalov 2016-02-22 19:29 EST
Created attachment 1129579 [details]
/tmp/ifcfg.log after seeing this bug on the released F23 image
Comment 43 Ivan Shapovalov 2016-02-22 19:29 EST
Created attachment 1129580 [details]
/tmp/program.log after seeing this bug on the released F23 image
Comment 44 Ivan Shapovalov 2016-02-22 19:30 EST
Created attachment 1129581 [details]
/tmp/storage.log after seeing this bug on the released F23 image
Comment 45 Ivan Shapovalov 2016-02-22 19:34:22 EST
(In reply to Vojtech Trefny from comment #40)
> This should really be fixed, please attach the logs from /tmp to this bug as
> individual, text/plain attachments. Thanks.

Done. Sorry for the delay.

What I've done:
- booted in BIOS (legacy) mode
- started installation
- went to configure disks
- chose manual partitioning (existing partitions: GPT disk, one ntfs, one BIOS boot partition, one swap)
- chose btrfs
- created / and /home as btrfs subvolumes
- attempted to create /boot (which failed with this error)
Comment 46 Patrik Suzzi 2016-04-02 10:57:23 EDT
I encountered the same error in Fedora 23 Workstation downloaded today, April 2nd 2016. 
( I know probably this will be fixed in next release. )

However, these are the steps to reproduce: 
- Install Fedora in a system where you already used up a large number of partitions(in my case I have two for Win and 4 for Ubuntu).
- As the LVM scheme won't work, switch to the Standard partition and add a new mount point
- After adding the new mount point, you'll see "Failed to add new device - Click for details" to the bottom left of the screen. 
- Click on the link "Click or details": a popup will open, with the message "local variable 'e' referenced before assignment".

Note You need to log in before you can comment on or make changes to this bug.