Bug 1252474 - Chargeback reports contain records for last day only
Chargeback reports contain records for last day only
Status: CLOSED ERRATA
Product: Red Hat CloudForms Management Engine
Classification: Red Hat
Component: UI - OPS (Show other bugs)
5.4.0
Unspecified Unspecified
high Severity high
: GA
: 5.4.3
Assigned To: Harpreet Kataria
Nandini Chandra
: Reopened, ZStream
Depends On: 1230262
Blocks:
  Show dependency treegraph
 
Reported: 2015-08-11 10:00 EDT by Chris Pelland
Modified: 2015-10-22 10:33 EDT (History)
12 users (show)

See Also:
Fixed In Version: 5.4.3.0
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 1230262
Environment:
Last Closed: 2015-10-22 10:33:04 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
screen shot from 54 (59.12 KB, image/png)
2015-08-24 03:52 EDT, Nandini Chandra
no flags Details
screen shot from 53 (116.71 KB, image/png)
2015-08-24 03:53 EDT, Nandini Chandra
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Knowledge Base (Solution) 1584333 None None None Never

  None (edit)
Comment 2 CFME Bot 2015-08-11 17:03:27 EDT
New commit detected on cfme/5.4.z:
https://code.engineering.redhat.com/gerrit/gitweb?p=cfme.git;a=commitdiff;h=509571b8ef009a92447c93b863b6e76c7e7d70d6

commit 509571b8ef009a92447c93b863b6e76c7e7d70d6
Author:     Harpreet Kataria <hkataria@redhat.com>
AuthorDate: Tue Aug 11 10:08:18 2015 -0400
Commit:     Harpreet Kataria <hkataria@redhat.com>
CommitDate: Tue Aug 11 10:08:18 2015 -0400

    Added missing case statement introduced during HAML conversion.
    
    This was preventing Going back pull down to not show up in Chargeback reports editor UI.
    
    https://bugzilla.redhat.com/show_bug.cgi?id=1230262
    https://bugzilla.redhat.com/show_bug.cgi?id=1252474

 vmdb/app/views/report/_form_filter_chargeback.html.haml | 1 +
 1 file changed, 1 insertion(+)
Comment 3 CFME Bot 2015-08-11 17:03:35 EDT
New commit detected on cfme/5.4.z:
https://code.engineering.redhat.com/gerrit/gitweb?p=cfme.git;a=commitdiff;h=9ebb102a0ee22891aa5bb3bda7be19a5798bde57

commit 9ebb102a0ee22891aa5bb3bda7be19a5798bde57
Merge: 42f127d 509571b
Author:     Dan Clarizio <dclarizi@redhat.com>
AuthorDate: Tue Aug 11 16:54:48 2015 -0400
Commit:     Dan Clarizio <dclarizi@redhat.com>
CommitDate: Tue Aug 11 16:54:48 2015 -0400

    Merge branch '54z_bz_1252474' into '5.4.z'
    
    Added missing case statement introduced during HAML conversion.
    
    This was preventing Going back pull down to not show up in Chargeback reports editor UI.
    
    https://bugzilla.redhat.com/show_bug.cgi?id=1230262
    https://bugzilla.redhat.com/show_bug.cgi?id=1252474
    
    @dclarizio clean patch was applied from upstream
    original PR: https://github.com/ManageIQ/manageiq/pull/3788
    
    See merge request !219

 vmdb/app/views/report/_form_filter_chargeback.html.haml | 1 +
 1 file changed, 1 insertion(+)
Comment 7 Nandini Chandra 2015-08-24 03:52:41 EDT
Created attachment 1066237 [details]
screen shot from 54
Comment 8 Nandini Chandra 2015-08-24 03:53:29 EDT
Created attachment 1066238 [details]
screen shot from 53
Comment 11 CFME Bot 2015-08-27 13:44:39 EDT
New commit detected on manageiq/master:
https://github.com/ManageIQ/manageiq/commit/c75ff21d6a1dd2149aedadd016564034d013dd07

commit c75ff21d6a1dd2149aedadd016564034d013dd07
Author:     Harpreet Kataria <hkataria@redhat.com>
AuthorDate: Thu Aug 27 12:33:06 2015 -0400
Commit:     Harpreet Kataria <hkataria@redhat.com>
CommitDate: Thu Aug 27 12:33:06 2015 -0400

    Fixed HAML indentation so "going back" title is displayed.
    
    https://bugzilla.redhat.com/show_bug.cgi?id=1230262
    https://bugzilla.redhat.com/show_bug.cgi?id=1252474

 app/views/report/_form_filter_chargeback.html.haml | 2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)
Comment 15 CFME Bot 2015-08-27 17:30:39 EDT
New commit detected on cfme/5.4.z:
https://code.engineering.redhat.com/gerrit/gitweb?p=cfme.git;a=commitdiff;h=994922149f41c53131b1672b1206f69e25c53244

commit 994922149f41c53131b1672b1206f69e25c53244
Author:     Harpreet Kataria <hkataria@redhat.com>
AuthorDate: Thu Aug 27 14:54:19 2015 -0400
Commit:     Harpreet Kataria <hkataria@redhat.com>
CommitDate: Thu Aug 27 14:54:19 2015 -0400

    Fixed HAML indentation so "going back" title is displayed.
    
    https://bugzilla.redhat.com/show_bug.cgi?id=1230262
    https://bugzilla.redhat.com/show_bug.cgi?id=1252474

 vmdb/app/views/report/_form_filter_chargeback.html.haml | 2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)
Comment 16 CFME Bot 2015-08-27 17:30:47 EDT
New commit detected on cfme/5.4.z:
https://code.engineering.redhat.com/gerrit/gitweb?p=cfme.git;a=commitdiff;h=1196c6440e9181a243d6471578095d6ebf192be9

commit 1196c6440e9181a243d6471578095d6ebf192be9
Merge: 83e434d 9949221
Author:     Dan Clarizio <dclarizi@redhat.com>
AuthorDate: Thu Aug 27 17:13:52 2015 -0400
Commit:     Dan Clarizio <dclarizi@redhat.com>
CommitDate: Thu Aug 27 17:13:52 2015 -0400

    Merge branch '54z_bz_1252474' into '5.4.z'
    
    Fixed HAML indentation so "going back" title is displayed.
    
    https://bugzilla.redhat.com/show_bug.cgi?id=1230262
    https://bugzilla.redhat.com/show_bug.cgi?id=1252474
    
    @dclarizio clean patch was applied.
    original PR: https://github.com/ManageIQ/manageiq/pull/4081
    
    See merge request !239

 vmdb/app/views/report/_form_filter_chargeback.html.haml | 2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)
Comment 18 Nandini Chandra 2015-10-06 11:55:25 EDT
Verified in 5.4.3.0.

Verified that the 'Going back' pull down shows up in Chargeback reports editor UI.
Comment 20 errata-xmlrpc 2015-10-22 10:33:04 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2015-1916.html

Note You need to log in before you can comment on or make changes to this bug.