Bug 1252581 - Panel does not show main menu entries
Summary: Panel does not show main menu entries
Keywords:
Status: CLOSED UPSTREAM
Alias: None
Product: Fedora
Classification: Fedora
Component: lxqt-common
Version: 23
Hardware: x86_64
OS: Linux
medium
high
Target Milestone: ---
Assignee: Raphael Groner
QA Contact: Fedora Extras Quality Assurance
URL: https://github.com/lxde/lxmenu-data/p...
Whiteboard:
: 1272671 1295135 (view as bug list)
Depends On:
Blocks: LXQt
TreeView+ depends on / blocked
 
Reported: 2015-08-11 19:19 UTC by greyman
Modified: 2018-09-08 08:27 UTC (History)
12 users (show)

Fixed In Version: lxqt-common-0.10.0-8.fc23 lxqt-common-0.10.0-8.fc22
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-02-07 05:24:30 UTC
Type: Bug


Attachments (Terms of Use)
screenshot (1.07 MB, image/png)
2015-08-11 19:19 UTC, greyman
no flags Details


Links
System ID Priority Status Summary Last Updated
Red Hat Bugzilla 1264489 unspecified CLOSED [abrt] menu-cache: fm_xml_file_item_get_tag(): menu-cache-gen killed by SIGSEGV 2020-10-14 00:28:05 UTC
Red Hat Bugzilla 1624474 high CLOSED Missing icons in leave dialog and leave menu of panel 2020-10-14 00:28:05 UTC

Internal Links: 1264489 1624474

Description greyman 2015-08-11 19:19:51 UTC
Created attachment 1061655 [details]
screenshot

Description of problem:

LXQt Desktop main menu does not show menu categories.

Version-Release number of selected component (if applicable):

lxqt-common.noarch                     0.9.1-5.fc23   

How reproducible:

Fresh install of LXQt Desktop. Click on Main menu.

Steps to Reproduce:
1. Install F23 Alpha LXQt Desktop
2. Log In
3. Click on LXQt main menu

Actual results:

Menu pops up, categories are clickable, but have no text.

Expected results:

Menu pops up, categories show text.


Additional info: See screenshot.

Comment 1 Raphael Groner 2015-08-12 14:43:10 UTC
What packages did you install and what language is configured for your user?

Please be aware that F23 is in Alpha state and LXQt is not an official desktop of Fedora, we currently provide some packages additionally.

Comment 2 greyman 2015-08-12 15:50:00 UTC
Raphael - here is an fpaste of dnf list installed | grep qt; http://ur1.ca/nf3ne

I installed from an F23 net install image and selected the LXQt desktop group and a few of the other groups such as LXQt Multimedia, office, etc.

When I ran dnf group list, the LXQt desktop did not show as installed. When I ran dnf group install "LXQt Desktop", dnf listed all of the pacakges normally associated with the group, asked me to y/n on the install, then instead of downloading and installing the packages, it just said complete.

dnf is; Version     : 1.0.2
Release     : 3.fc23

I've also run dnf distro-sync and dnf-update. There are no updates listed.

I'm aware this is alpha, just testing.

Thanks - Zach

Comment 3 greyman 2015-08-14 14:52:49 UTC
I updated the bug to include rawhide and created an issue at the LXQt github site; https://github.com/lxde/lxqt/issues/783

Let me know if I can do anything else.

Comment 4 Peter Mattern 2015-08-16 13:10:15 UTC
The items missing in panel plugin Application menu are those corresponding to desktop entry files *.desktop provided by lxmenu-data which isn't a dependency of any LXQt component on Fedora right now.
So workaround is to install package lxmenu-data manually, solution to make some LXQt component depend on it, probably lxqt-panel or lxqt-common.

Same thing on Fedora 22.

(Items "Leave" and "Lock Screen" are provided by desktop entry files that belong to lxqt-common and as such not affected by this problem.)

Comment 5 Raphael Groner 2015-08-16 14:58:12 UTC
(In reply to Peter Mattern from comment #4)
…
> So workaround is to install package lxmenu-data manually, solution to make
> some LXQt component depend on it, probably lxqt-panel or lxqt-common.

That's not a question about a workaround. That's a clear bug that has to be fixed. As I see that lxde-common depends on lxmenu-data ("Requires: lxmenu-data" in lxde-common.spec), that's a bug in lxqt-common. LXQt is a fork of LXDE and should not loose any features, Fedora policy says to keep it feature rich.

To sum it up, my vote goes for adding it as a dependency to lxqt-common package.

> Same thing on Fedora 22.

I'll so set version of this bug to rawhide. But lower severity cause we now know a workaround.

Comment 6 Raphael Groner 2015-09-17 21:24:00 UTC
I can confirm this bug with german localisation.
lxqt-panel-0.9.0-7.f23.x86_64
lxmenu-data-0.1.4-1.f23.noarch

Installation of lxmenu-data does not change anything, still no visible group names.

Comment 7 Peter Mattern 2015-09-18 14:04:03 UTC
LXQt panel's main menu sometimes doesn't get updated as it should. Normally the workaround is updating the timestamp of the *.menu file in use, by default /etc/xdg/menu/lxqt-applications.menu, see https://github.com/lxde/lxqt/issues/65.
Both problem and solving by installation of lxmenu-data can still be verified on rawhide 24 here.

Note it turned out the problem might be not as strictly downstream as I had first thought and the said upstream issue is re-opened for now.

Comment 8 Raphael Groner 2015-09-18 14:19:36 UTC
(In reply to Peter Mattern from comment #7)
> LXQt panel's main menu sometimes doesn't get updated as it should. Normally
> the workaround is updating the timestamp of the *.menu file in use, by
> default /etc/xdg/menu/lxqt-applications.menu, see
> https://github.com/lxde/lxqt/issues/65.

This needs to be fixed for lxmenu-data with a scriptlet in the spec file.

Reassigning to lxmenu-data. If it's fixed there, lxqt should include that package as a dependency somewhere as already discussed, maybe at least in the packages group.

Comment 9 Raphael Groner 2015-09-18 14:25:02 UTC
Requested commit ACL for lxmenu-data, and new branch for epel7 as lxqt-panel is available also in epel7.

Comment 10 Raphael Groner 2015-09-18 14:25:44 UTC
Caution! Broken usability in F23 with LXQt.

Comment 11 Raphael Groner 2015-09-18 14:46:42 UTC
The workaround with touch does work only if lxqt-panel is running. Touching before a login to LXQt does not help. So an automatic fix is not that easy as thought originally.

Comment 12 Mamoru TASAKA 2015-09-20 13:12:04 UTC
Reassigning to lxqt-panel, as it turned out that touching *.menu is not the right solution (and anyway I don't think it is right).

Comment 13 Raphael Groner 2015-10-17 15:37:58 UTC
*** Bug 1272671 has been marked as a duplicate of this bug. ***

Comment 14 bodhi.zazen 2015-10-17 18:37:49 UTC
FWIW installing lxmenu-data resolved the problem here.

After a short delay the menus were updated.

Comment 15 Peter Mattern 2015-10-18 13:21:31 UTC
@Mamoru TASAKA
Looks like some misunderstanding to me: Updating the timestamp of the *.menu file in use is a workaround of the problem that LXQt's main menu sometimes doesn't get updated as it should, see https://github.com/lxde/lxqt/issues/65.
As such it is used to make the installation of lxmenu-data take effect but is in no way a solution of the actual problem discussed in this bug report.

@Raphael Groner
The problem described in https://github.com/lxde/lxqt/issues/65 is affecting several kinds of changes in *.desktop files, the additional installation of package lxmenu-data is just one example. So a scriptlet belonging to lxmenu-data which updates the timestamp as you propose above does not solve the problem which rather needs to be addressed upstream.

Comment 16 Gerald Cox 2015-11-06 17:05:37 UTC
(In reply to bodhi.zazen from comment #14)
> FWIW installing lxmenu-data resolved the problem here.
> 
> After a short delay the menus were updated.

Yes, same for me also.  Looks like lxmenu-data should be a dependency and for some reason it isn't being pulled in.

Comment 17 Raphael Groner 2015-11-07 01:34:31 UTC
Please add lxmenu-data package into lxqt packages group.

Comment 18 Raphael Groner 2015-11-07 01:37:14 UTC
Alternatively to add lxmenu-data package into lxqt packages group, lxqt-panel must Require: lxmenu-data

Comment 19 Raphael Groner 2016-01-03 11:59:22 UTC
*** Bug 1295135 has been marked as a duplicate of this bug. ***

Comment 20 Pavel Roskin 2016-01-17 06:30:36 UTC
Group membership is a very soft dependency. But this is a clear cut missing package dependency for the lxqt-common package. Package lxqt-common-0.10.0-5.fc23.noarch has file /etc/xdg/menus/lxqt-applications.menu that has references to file lxde-utility.directory (and many others), which is provided by the lxmenu-data package. Therefore, lxqt-common must depend on lxmenu-data, but is doesn't. The fix is to add the missing dependency.

Comment 21 Raphael Groner 2016-01-17 08:46:23 UTC
I'll fix it soon.

Comment 22 Fedora Update System 2016-02-02 22:11:40 UTC
lxqt-common-0.10.0-8.fc23 has been submitted as an update to Fedora 23. https://bodhi.fedoraproject.org/updates/FEDORA-2016-f7705f4141

Comment 23 Fedora Update System 2016-02-02 22:11:41 UTC
lxqt-common-0.10.0-8.fc22 has been submitted as an update to Fedora 22. https://bodhi.fedoraproject.org/updates/FEDORA-2016-1e516ca440

Comment 24 Fedora Update System 2016-02-03 23:01:01 UTC
lxqt-common-0.10.0-8.fc23 has been pushed to the Fedora 23 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2016-f7705f4141

Comment 25 Fedora Update System 2016-02-03 23:25:41 UTC
lxqt-common-0.10.0-8.fc22 has been pushed to the Fedora 22 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2016-1e516ca440

Comment 26 Fedora Update System 2016-02-07 05:24:25 UTC
lxqt-common-0.10.0-8.fc23 has been pushed to the Fedora 23 stable repository. If problems still persist, please make note of it in this bug report.

Comment 27 Fedora Update System 2016-02-12 12:21:06 UTC
lxqt-common-0.10.0-8.fc22 has been pushed to the Fedora 22 stable repository. If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.