Bug 1252593 - UnboundLocalError: local variable 'e' referenced before assignment
UnboundLocalError: local variable 'e' referenced before assignment
Status: CLOSED DUPLICATE of bug 1249304
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
23
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Anaconda Maintenance Team
Fedora Extras Quality Assurance
abrt_hash:3a4b9b7114b54d7906d015329fa...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-08-11 16:31 EDT by danutz1200
Modified: 2015-08-11 16:41 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-08-11 16:41:09 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: anaconda-tb (507.89 KB, text/plain)
2015-08-11 16:31 EDT, danutz1200
no flags Details
File: anaconda.log (9.55 KB, text/plain)
2015-08-11 16:31 EDT, danutz1200
no flags Details
File: environ (649 bytes, text/plain)
2015-08-11 16:31 EDT, danutz1200
no flags Details
File: journalctl (314.57 KB, text/plain)
2015-08-11 16:31 EDT, danutz1200
no flags Details
File: lsblk_output (3.22 KB, text/plain)
2015-08-11 16:31 EDT, danutz1200
no flags Details
File: nmcli_dev_list (2.20 KB, text/plain)
2015-08-11 16:31 EDT, danutz1200
no flags Details
File: os_info (518 bytes, text/plain)
2015-08-11 16:31 EDT, danutz1200
no flags Details
File: program.log (24.77 KB, text/plain)
2015-08-11 16:31 EDT, danutz1200
no flags Details
File: storage.log (135.73 KB, text/plain)
2015-08-11 16:31 EDT, danutz1200
no flags Details
File: ifcfg.log (3.82 KB, text/plain)
2015-08-11 16:31 EDT, danutz1200
no flags Details

  None (edit)
Description danutz1200 2015-08-11 16:31:07 EDT
Description of problem:
Legacy usb boot
First step in installing

Version-Release number of selected component:
anaconda-core-23.17-1.fc23.x86_64

The following was filed automatically by anaconda:
anaconda 23.17-1 exception report
Traceback (most recent call first):
  File "/usr/lib/python3.4/site-packages/blivet/tasks/fsminsize.py", line 57, in _getResizeInfo
    error_msg = "failed to gather info from resize program: %s" % e
  File "/usr/lib/python3.4/site-packages/blivet/tasks/fsminsize.py", line 168, in doTask
    resize_info = self._getResizeInfo()
  File "/usr/lib/python3.4/site-packages/blivet/formats/fs.py", line 288, in updateSizeInfo
    result = self._minsize.doTask()
  File "/usr/lib/python3.4/site-packages/blivet/formats/fs.py", line 134, in __init__
    self.updateSizeInfo()
  File "/usr/lib/python3.4/site-packages/blivet/formats/__init__.py", line 85, in getFormat
    fmt = fmt_class(*args, **kwargs)
  File "/usr/lib/python3.4/site-packages/blivet/populator.py", line 1431, in handleUdevDeviceFormat
    device.format = formats.getFormat(format_designator, **kwargs)
  File "/usr/lib/python3.4/site-packages/blivet/populator.py", line 761, in addUdevDevice
    self.handleUdevDeviceFormat(info, device)
  File "/usr/lib/python3.4/site-packages/blivet/populator.py", line 1660, in _populate
    self.addUdevDevice(dev)
  File "/usr/lib/python3.4/site-packages/blivet/populator.py", line 1597, in populate
    self._populate()
  File "/usr/lib/python3.4/site-packages/blivet/devicetree.py", line 554, in populate
    self._populator.populate(cleanupOnly=cleanupOnly)
  File "/usr/lib/python3.4/site-packages/blivet/blivet.py", line 279, in reset
    self.devicetree.populate(cleanupOnly=cleanupOnly)
  File "/usr/lib/python3.4/site-packages/blivet/osinstall.py", line 1123, in storageInitialize
    storage.reset()
  File "/usr/lib64/python3.4/threading.py", line 868, in run
    self._target(*self._args, **self._kwargs)
  File "/usr/lib64/python3.4/site-packages/pyanaconda/threads.py", line 253, in run
    threading.Thread.run(self, *args, **kwargs)
UnboundLocalError: local variable 'e' referenced before assignment

Additional info:
cmdline:        /usr/bin/python3  /sbin/anaconda --liveinst --method=livecd:///dev/mapper/live-base
cmdline_file:   BOOT_IMAGE=vmlinuz0 initrd=initrd0.img root=live:CDLABEL=FEDORA-LIVE rootfstype=auto ro rd.live.image quiet  rhgb rd.luks=0 rd.md=0 rd.dm=0 
executable:     /sbin/anaconda
hashmarkername: anaconda
kernel:         4.2.0-0.rc5.git0.2.fc23.x86_64
other involved packages: python3-libs-3.4.3-5.fc23.x86_64, python3-blivet-1.10-1.fc23.noarch
product:        Fedora
release:        Fedora release 23 (Twenty Three)
type:           anaconda
version:        23

Potential duplicate: bug 1240464
Comment 1 danutz1200 2015-08-11 16:31:13 EDT
Created attachment 1061676 [details]
File: anaconda-tb
Comment 2 danutz1200 2015-08-11 16:31:15 EDT
Created attachment 1061677 [details]
File: anaconda.log
Comment 3 danutz1200 2015-08-11 16:31:16 EDT
Created attachment 1061678 [details]
File: environ
Comment 4 danutz1200 2015-08-11 16:31:20 EDT
Created attachment 1061679 [details]
File: journalctl
Comment 5 danutz1200 2015-08-11 16:31:21 EDT
Created attachment 1061680 [details]
File: lsblk_output
Comment 6 danutz1200 2015-08-11 16:31:23 EDT
Created attachment 1061681 [details]
File: nmcli_dev_list
Comment 7 danutz1200 2015-08-11 16:31:24 EDT
Created attachment 1061682 [details]
File: os_info
Comment 8 danutz1200 2015-08-11 16:31:27 EDT
Created attachment 1061683 [details]
File: program.log
Comment 9 danutz1200 2015-08-11 16:31:29 EDT
Created attachment 1061684 [details]
File: storage.log
Comment 10 danutz1200 2015-08-11 16:31:34 EDT
Created attachment 1061685 [details]
File: ifcfg.log
Comment 11 Samantha N. Bueno 2015-08-11 16:41:09 EDT

*** This bug has been marked as a duplicate of bug 1249304 ***

Note You need to log in before you can comment on or make changes to this bug.