Bug 125265 - Soundcard Creative Vibra16x PnP not properly configured
Soundcard Creative Vibra16x PnP not properly configured
Status: CLOSED DUPLICATE of bug 115885
Product: Fedora
Classification: Fedora
Component: alsa-lib (Show other bugs)
2
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Bill Nottingham
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-06-04 04:33 EDT by Miguel Quiros
Modified: 2014-03-16 22:45 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 14:03:57 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Miguel Quiros 2004-06-04 04:33:50 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; es-ES; rv:1.7) Gecko/20040514

Description of problem:
I have upgraded Red Hat 7.3 to Fedora 2 and I cannot properly
configure the title soundcard. It used to work before the upgrade.
The kernel seems to detect the card. I can see the following is
written in /var/log/messages when booting the system:
      SB audio device quirk - increasing port range
      Card 'Creative Vibra16x PnP'

But both kudzu and system-config-soundcard fail to detect the card.
When starting X (turning previously on the option "start sound daemon
on startup"), I can see in the console the message "no alsa card found".

After looking for some information in the network about card
configuration in the Alsa system, I have found that there is something
call alsaconf but it seems not to be icluded in the Fedora distribution.

After reading here and there, I have learned that the module for this
card seems to be snd-sb16 so I have introduced in /etc/modprobe.conf:
      alias snd-card0 snd-sb16

Now, when X is started, the message "no alsa card found" does not
appear and the following shows up at the end of /var/log/messages:
       pnp: Device 00:01.00 activated
       Error running install command for sound-slot-0
       Error running install command for sound-slot-1
(Why two "sound-slots" if there is only one card?)
A lot of sound modules are also loaded.

I can see now that sound works partially. In "Sound"->"Volume
control", it looks like two cards were present, one of them called
"CTL1745 [Audio mixer(OSS)]" and the other one called "Sound Blaster
16 [Alsa Mixer]".

I can hear sound from the program XMMS but if I turn on the "sounds
for the events", the only event that produces any sound is quitting
the sessions. Also, the "test sound" button of the program for
assigning sounds to events does not yield any sound. Perhaps, things
that use Alsa work but thing that use OSS do not (???).

Afterwards, I have introduced also the following in /etc/modprobe.conf:
     alias sound-slot-0 snd-sb16
     alias sound-slot-1 snd-sb16
Doing this the error messages "error running install sound-slot ..."
do not show up but, apart from this, I cannot see any other
difference, no new module is loaded and what did not work, still do
not work.

Version-Release number of selected component (if applicable):
alsa-lib-1.0.3a-2

How reproducible:
Always

Steps to Reproduce:
1. Start Fedora, see that the soundcard is not properly detected.
2. Configure modprobe.conf as indicated
3.
    

Actual Results:  The sound only works partially.

Expected Results:  Sound working with every program.

Additional info:
Comment 1 Bill Nottingham 2004-06-04 16:29:04 EDT

*** This bug has been marked as a duplicate of 115885 ***
Comment 2 Red Hat Bugzilla 2006-02-21 14:03:57 EST
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.

Note You need to log in before you can comment on or make changes to this bug.