Bug 1252660 - [abrt] xorg-x11-server-Xorg: kgem_expire_cache(): Xorg killed by SIGABRT
[abrt] xorg-x11-server-Xorg: kgem_expire_cache(): Xorg killed by SIGABRT
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: xorg-x11-drv-intel (Show other bugs)
22
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Adam Jackson
Fedora Extras Quality Assurance
https://retrace.fedoraproject.org/faf...
abrt_hash:d50e49b98d7aa0d1a293a33113f...
:
: 1235136 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-08-11 23:26 EDT by Amol
Modified: 2015-10-29 09:12 EDT (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-10-29 09:12:47 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: backtrace (17.01 KB, text/plain)
2015-08-11 23:26 EDT, Amol
no flags Details
File: cgroup (190 bytes, text/plain)
2015-08-11 23:26 EDT, Amol
no flags Details
File: core_backtrace (4.16 KB, text/plain)
2015-08-11 23:26 EDT, Amol
no flags Details
File: dso_list (5.81 KB, text/plain)
2015-08-11 23:26 EDT, Amol
no flags Details
File: environ (409 bytes, text/plain)
2015-08-11 23:26 EDT, Amol
no flags Details
File: limits (1.29 KB, text/plain)
2015-08-11 23:26 EDT, Amol
no flags Details
File: maps (41.02 KB, text/plain)
2015-08-11 23:26 EDT, Amol
no flags Details
File: mountinfo (3.42 KB, text/plain)
2015-08-11 23:26 EDT, Amol
no flags Details
File: namespaces (85 bytes, text/plain)
2015-08-11 23:26 EDT, Amol
no flags Details
File: open_fds (1.89 KB, text/plain)
2015-08-11 23:26 EDT, Amol
no flags Details
File: proc_pid_status (1012 bytes, text/plain)
2015-08-11 23:26 EDT, Amol
no flags Details
File: var_log_messages (294 bytes, text/plain)
2015-08-11 23:26 EDT, Amol
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
FreeDesktop.org 91120 None None None Never

  None (edit)
Description Amol 2015-08-11 23:26:14 EDT
Description of problem:
Watching HD movies

Version-Release number of selected component:
xorg-x11-server-Xorg-1.17.2-2.fc22

Additional info:
reporter:       libreport-2.6.2
backtrace_rating: 4
cmdline:        /usr/libexec/Xorg vt2 -displayfd 3 -auth /run/user/1000/gdm/Xauthority -nolisten tcp -background none -noreset -keeptty -verbose 3
crash_function: kgem_expire_cache
executable:     /usr/libexec/Xorg
global_pid:     2018
kernel:         4.1.3-201.fc22.x86_64
runlevel:       N 5
type:           CCpp
uid:            1000

Truncated backtrace:
Thread no. 1 (10 frames)
 #6 kgem_expire_cache at kgem.c:4173
 #7 do_execbuf at kgem.c:3874
 #8 _kgem_submit at kgem.c:3980
 #9 sna_blt_copy_boxes at sna_blt.c:4012
 #10 gen4_render_copy_boxes at gen4_render.c:2395
 #11 __sna_dri2_copy_region at sna_dri2.c:1234
 #12 dri2_copy_region at dri2.c:871
 #13 DRI2CopyRegion at dri2.c:912
 #14 ProcDRI2CopyRegion at dri2ext.c:332
 #15 ProcDRI2Dispatch at dri2ext.c:609

Potential duplicate: bug 1186711
Comment 1 Amol 2015-08-11 23:26:17 EDT
Created attachment 1061770 [details]
File: backtrace
Comment 2 Amol 2015-08-11 23:26:19 EDT
Created attachment 1061771 [details]
File: cgroup
Comment 3 Amol 2015-08-11 23:26:20 EDT
Created attachment 1061772 [details]
File: core_backtrace
Comment 4 Amol 2015-08-11 23:26:22 EDT
Created attachment 1061773 [details]
File: dso_list
Comment 5 Amol 2015-08-11 23:26:23 EDT
Created attachment 1061774 [details]
File: environ
Comment 6 Amol 2015-08-11 23:26:25 EDT
Created attachment 1061775 [details]
File: limits
Comment 7 Amol 2015-08-11 23:26:27 EDT
Created attachment 1061776 [details]
File: maps
Comment 8 Amol 2015-08-11 23:26:29 EDT
Created attachment 1061777 [details]
File: mountinfo
Comment 9 Amol 2015-08-11 23:26:30 EDT
Created attachment 1061778 [details]
File: namespaces
Comment 10 Amol 2015-08-11 23:26:32 EDT
Created attachment 1061779 [details]
File: open_fds
Comment 11 Amol 2015-08-11 23:26:34 EDT
Created attachment 1061780 [details]
File: proc_pid_status
Comment 12 Amol 2015-08-11 23:26:35 EDT
Created attachment 1061781 [details]
File: var_log_messages
Comment 13 Amol 2015-08-12 13:30:03 EDT
Another user experienced a similar problem:

Playing HD videos with GNOME videos

reporter:       libreport-2.6.2
backtrace_rating: 4
cmdline:        /usr/libexec/Xorg vt2 -displayfd 3 -auth /run/user/1000/gdm/Xauthority -nolisten tcp -background none -noreset -keeptty -verbose 3
crash_function: kgem_expire_cache
executable:     /usr/libexec/Xorg
global_pid:     5586
kernel:         4.1.3-201.fc22.x86_64
package:        xorg-x11-server-Xorg-1.17.2-2.fc22
reason:         Xorg killed by SIGABRT
runlevel:       N 5
type:           CCpp
uid:            1000
Comment 14 Hannes Frederic Sowa 2015-08-14 15:24:56 EDT
Another user experienced a similar problem:

Playing a video with Totem (Gnome Video) in fullscreen and scrolling around in the Video.

reporter:       libreport-2.6.2
backtrace_rating: 4
cmdline:        /usr/libexec/Xorg vt2 -displayfd 3 -auth /run/user/1000/gdm/Xauthority -nolisten tcp -background none -noreset -keeptty -verbose 3
crash_function: kgem_expire_cache
executable:     /usr/libexec/Xorg
global_pid:     2187
kernel:         4.1.4-200.fc22.x86_64
package:        xorg-x11-server-Xorg-1.17.2-2.fc22
reason:         Xorg killed by SIGABRT
runlevel:       N 5
type:           CCpp
uid:            1000
Comment 15 Hannes Frederic Sowa 2015-08-19 06:53:19 EDT
*** Bug 1235136 has been marked as a duplicate of this bug. ***
Comment 16 Branko Grubić 2015-08-22 09:58:35 EDT
There is an update available for testing with newer git snapshot (after commit which fixes this issue), so if anyone can, please test it.
https://bodhi.fedoraproject.org/updates/xorg-x11-drv-intel-2.99.917-15.20150729.fc22
Comment 17 Branko Grubić 2015-08-22 10:12:14 EDT
(In reply to Branko Grubić (bitlord) from comment #16)
> There is an update available for testing with newer git snapshot (after
> commit which fixes this issue), so if anyone can, please test it.
> https://bodhi.fedoraproject.org/updates/xorg-x11-drv-intel-2.99.917-15.
> 20150729.fc22

I was able to reproduce the crash with old package, but after upgrade to xorg-x11-drv-intel-2.99.917-15.20150729.fc22 it doesn't crash anymore. So I guess it fixes this issue (at least on my system with intel ~g45/q45/q43 (gen4/4.5)).
Comment 18 Branko Grubić 2015-10-29 09:12:47 EDT
This is fixed in >=f22, I'll close this bug.

Note You need to log in before you can comment on or make changes to this bug.