Bug 1252737 - xml output for volume status on tiered volume
xml output for volume status on tiered volume
Status: CLOSED CURRENTRELEASE
Product: GlusterFS
Classification: Community
Component: tiering (Show other bugs)
mainline
All All
unspecified Severity medium
: ---
: ---
Assigned To: hari gowtham
bugs@gluster.org
: Triaged
Depends On:
Blocks: 1260856 1260923
  Show dependency treegraph
 
Reported: 2015-08-12 03:45 EDT by hari gowtham
Modified: 2016-06-16 09:30 EDT (History)
2 users (show)

See Also:
Fixed In Version: glusterfs-3.8rc2
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 1260856 (view as bug list)
Environment:
Last Closed: 2016-06-16 09:30:53 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description hari gowtham 2015-08-12 03:45:54 EDT
Description of problem:
The existing xml output for volume status is not sufficient for a tiered volume 

Version-Release number of selected component (if applicable):
mainline

How reproducible:
100%

Steps to Reproduce:
1.create a tiered volume.
2.gluster volume rebalance <volume-name> tier status --xml
3.

Actual results:
<?xml version="1.0" encoding="UTF-8" standalone="yes"?>
<cliOutput>
  <opRet>0</opRet>
  <opErrno>0</opErrno>
  <opErrstr/>
  <volRebalance>
    <task-id>e379577e-6346-4ad9-b005-cbf2138609b6</task-id>
    <op>7</op>
  </volRebalance>
</cliOutput>


Expected results:
<?xml version="1.0" encoding="UTF-8" standalone="yes"?>
<cliOutput>
  <opRet>0</opRet>
  <opErrno>0</opErrno>
  <opErrstr/>
  <volRebalance>
    <task-id>34f47e29-2193-4a86-9b1e-c7e56bdae3d4</task-id>
    <op>7</op>
    <nodeCount>1</nodeCount>
    <node>
      <nodeName>localhost</nodeName>
      <promotedfiles>0</promotedfiles>
      <demotedfiles>0</demotedfiles>
      <statusStr>in progress</statusStr>
    </node>
  </volRebalance>
</cliOutput>


Additional info:
Comment 1 Anand Avati 2015-08-12 03:49:46 EDT
REVIEW: http://review.gluster.org/11890 (xml for tiering status volume) posted (#1) for review on master by hari gowtham (hari.gowtham005@gmail.com)
Comment 2 Anand Avati 2015-08-13 02:26:33 EDT
REVIEW: http://review.gluster.org/11890 (xml/tiering: enhance xml output for tiering related cli commands) posted (#2) for review on master by hari gowtham (hari.gowtham005@gmail.com)
Comment 3 Anand Avati 2015-08-13 07:44:48 EDT
REVIEW: http://review.gluster.org/11890 (xml/tiering: enhance xml output for tiering related cli commands) posted (#3) for review on master by hari gowtham (hari.gowtham005@gmail.com)
Comment 4 Anand Avati 2015-08-28 03:48:37 EDT
REVIEW: http://review.gluster.org/11890 (xml/tiering: enhance xml output for tiering status related cli commands) posted (#4) for review on master by hari gowtham (hari.gowtham005@gmail.com)
Comment 5 Niels de Vos 2016-06-16 09:30:53 EDT
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.8.0, please open a new bug report.

glusterfs-3.8.0 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] http://blog.gluster.org/2016/06/glusterfs-3-8-released/
[2] http://thread.gmane.org/gmane.comp.file-systems.gluster.user

Note You need to log in before you can comment on or make changes to this bug.