Bug 1260856 - xml output for volume status on tiered volume
xml output for volume status on tiered volume
Status: CLOSED CURRENTRELEASE
Product: GlusterFS
Classification: Community
Component: tiering (Show other bugs)
3.7.5
All All
unspecified Severity medium
: ---
: ---
Assigned To: hari gowtham
bugs@gluster.org
: Triaged
Depends On: 1252737
Blocks: 1260923
  Show dependency treegraph
 
Reported: 2015-09-08 01:19 EDT by hari gowtham
Modified: 2015-10-30 13:32 EDT (History)
2 users (show)

See Also:
Fixed In Version: glusterfs-3.7.5
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 1252737
Environment:
Last Closed: 2015-10-14 06:29:23 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description hari gowtham 2015-09-08 01:19:27 EDT
+++ This bug was initially created as a clone of Bug #1252737 +++

Description of problem:
The existing xml output for volume status is not sufficient for a tiered volume 

Version-Release number of selected component (if applicable):
mainline

How reproducible:
100%

Steps to Reproduce:
1.create a tiered volume.
2.gluster volume rebalance <volume-name> tier status --xml
3.

Actual results:
<?xml version="1.0" encoding="UTF-8" standalone="yes"?>
<cliOutput>
  <opRet>0</opRet>
  <opErrno>0</opErrno>
  <opErrstr/>
  <volRebalance>
    <task-id>e379577e-6346-4ad9-b005-cbf2138609b6</task-id>
    <op>7</op>
  </volRebalance>
</cliOutput>


Expected results:
<?xml version="1.0" encoding="UTF-8" standalone="yes"?>
<cliOutput>
  <opRet>0</opRet>
  <opErrno>0</opErrno>
  <opErrstr/>
  <volRebalance>
    <task-id>34f47e29-2193-4a86-9b1e-c7e56bdae3d4</task-id>
    <op>7</op>
    <nodeCount>1</nodeCount>
    <node>
      <nodeName>localhost</nodeName>
      <promotedfiles>0</promotedfiles>
      <demotedfiles>0</demotedfiles>
      <statusStr>in progress</statusStr>
    </node>
  </volRebalance>
</cliOutput>


Additional info:

--- Additional comment from Anand Avati on 2015-08-12 03:49:46 EDT ---

REVIEW: http://review.gluster.org/11890 (xml for tiering status volume) posted (#1) for review on master by hari gowtham (hari.gowtham005@gmail.com)

--- Additional comment from Anand Avati on 2015-08-13 02:26:33 EDT ---

REVIEW: http://review.gluster.org/11890 (xml/tiering: enhance xml output for tiering related cli commands) posted (#2) for review on master by hari gowtham (hari.gowtham005@gmail.com)

--- Additional comment from Anand Avati on 2015-08-13 07:44:48 EDT ---

REVIEW: http://review.gluster.org/11890 (xml/tiering: enhance xml output for tiering related cli commands) posted (#3) for review on master by hari gowtham (hari.gowtham005@gmail.com)

--- Additional comment from Anand Avati on 2015-08-28 03:48:37 EDT ---

REVIEW: http://review.gluster.org/11890 (xml/tiering: enhance xml output for tiering status related cli commands) posted (#4) for review on master by hari gowtham (hari.gowtham005@gmail.com)
Comment 1 Vijay Bellur 2015-09-08 01:22:51 EDT
REVIEW: http://review.gluster.org/12119 (xml/tiering: enhance xml output for tiering status related cli commands) posted (#1) for review on release-3.7 by hari gowtham (hari.gowtham005@gmail.com)
Comment 2 Vijay Bellur 2015-09-08 01:31:17 EDT
REVIEW: http://review.gluster.org/12119 (xml/tiering: enhance xml output for tiering status related cli commands) posted (#2) for review on release-3.7 by hari gowtham (hari.gowtham005@gmail.com)
Comment 3 Vijay Bellur 2015-09-08 08:23:15 EDT
COMMIT: http://review.gluster.org/12119 committed in release-3.7 by Dan Lambright (dlambrig@redhat.com) 
------
commit 143f0f98c50725ccb853ab29215e306b95d95cc0
Author: Hari Gowtham <hgowtham@redhat.com>
Date:   Wed Aug 5 19:30:20 2015 +0530

    xml/tiering: enhance xml output for tiering status related cli commands
    
            backport of : http://review.gluster.org/#/c/11890/
    
    <?xml version="1.0" encoding="UTF-8" standalone="yes"?>
    <cliOutput>
      <opRet>0</opRet>
      <opErrno>0</opErrno>
      <opErrstr/>
      <volRebalance>
        <task-id>34f47e29-2193-4a86-9b1e-c7e56bdae3d4</task-id>
        <op>7</op>
        <nodeCount>1</nodeCount>
        <node>
          <nodeName>localhost</nodeName>
          <promotedfiles>0</promotedfiles>
          <demotedfiles>0</demotedfiles>
          <statusStr>in progress</statusStr>
        </node>
      </volRebalance>
    </cliOutput>
    
    >Change-Id: I61083f7b9b0b3bd840982b8c5d6ea4b42e27c9b3
    >BUG: 1252737
    >Signed-off-by: Hari Gowtham <hgowtham@redhat.com>
    
    Change-Id: I266c5bb051770dfeaba4f54f9f37d25e90ba7a24
    BUG: 1260856
    Signed-off-by: Hari Gowtham <hgowtham@redhat.com>
    Reviewed-on: http://review.gluster.org/12119
    Tested-by: NetBSD Build System <jenkins@build.gluster.org>
    Tested-by: Gluster Build System <jenkins@build.gluster.com>
    Reviewed-by: Dan Lambright <dlambrig@redhat.com>
    Tested-by: Dan Lambright <dlambrig@redhat.com>
Comment 4 Pranith Kumar K 2015-10-14 06:29:23 EDT
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-glusterfs-3.7.5, please open a new bug report.

glusterfs-glusterfs-3.7.5 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] http://www.gluster.org/pipermail/gluster-users/2015-October/023968.html
[2] http://thread.gmane.org/gmane.comp.file-systems.gluster.user
Comment 5 Pranith Kumar K 2015-10-14 06:38:21 EDT
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.7.5, please open a new bug report.

glusterfs-3.7.5 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] http://www.gluster.org/pipermail/gluster-users/2015-October/023968.html
[2] http://thread.gmane.org/gmane.comp.file-systems.gluster.user

Note You need to log in before you can comment on or make changes to this bug.