Bug 1252882 - [abrt] meld: meldapp.py:277:parse_args:UnboundLocalError: local variable 'args' referenced before assignment
[abrt] meld: meldapp.py:277:parse_args:UnboundLocalError: local variable 'arg...
Status: CLOSED DUPLICATE of bug 1216120
Product: Fedora
Classification: Fedora
Component: meld (Show other bugs)
22
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Dominic Hopf
Fedora Extras Quality Assurance
https://retrace.fedoraproject.org/faf...
abrt_hash:18b0ac0b46112957112e2fab0c9...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-08-12 08:40 EDT by Jaroslav Škarvada
Modified: 2015-09-08 17:28 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-09-08 17:28:19 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: backtrace (2.29 KB, text/plain)
2015-08-12 08:40 EDT, Jaroslav Škarvada
no flags Details
File: environ (3.89 KB, text/plain)
2015-08-12 08:40 EDT, Jaroslav Škarvada
no flags Details

  None (edit)
Description Jaroslav Škarvada 2015-08-12 08:40:10 EDT
Description of problem:
git mergetool

Version-Release number of selected component:
meld-3.14.0-1.fc22

Additional info:
reporter:       libreport-2.6.2
cmdline:        /usr/bin/python /usr/bin/meld --help
executable:     /usr/bin/meld
kernel:         4.1.3-201.fc22.x86_64
runlevel:       N 5
type:           Python
uid:            1000

Truncated backtrace:
meldapp.py:277:parse_args:UnboundLocalError: local variable 'args' referenced before assignment

Traceback (most recent call last):
  File "/usr/lib/python2.7/site-packages/meld/meldapp.py", line 72, in do_command_line
    tab = self.parse_args(command_line)
  File "/usr/lib/python2.7/site-packages/meld/meldapp.py", line 277, in parse_args
    if len(args) > 3:
UnboundLocalError: local variable 'args' referenced before assignment

Local variables in innermost frame:
usages: [('', u'Spustit s pr\xe1zdn\xfdm oknem'), (u'<soubor|slo\u017eka>', u'Spustit nov\xe9 porovn\xe1n\xed spr\xe1vy verz\xed'), (u'<soubor> <soubor> [<soubor>]', u'Spustit dvojcestn\xe9 nebo trojcestn\xe9 porovn\xe1n\xed soubor\u016f'), (u'<slo\u017eka> <slo\u017eka> [<slo\u017eka>]', u'Spustit dvojcestn\xe9 nebo trojcestn\xe9 porovn\xe1n\xed slo\u017eek')]
self: <MeldApp object at 0x7fe25ead0e60 (meld+meldapp+MeldApp at 0x1fb52d0)>
parser: <meld.meldapp.GLibFriendlyOptionParser instance at 0x7fe25cf82c68>
command_line: <ApplicationCommandLine object at 0x7fe25d02d4b0 (GApplicationCommandLine at 0x24d4fa0)>
s: (u'<slo\u017eka> <slo\u017eka> [<slo\u017eka>]', u'Spustit dvojcestn\xe9 nebo trojcestn\xe9 porovn\xe1n\xed slo\u017eek')
rawargs: ['--help']
cleanup: <function cleanup at 0x7fe25d0305f0>
u: (u'<slo\u017eka> <slo\u017eka> [<slo\u017eka>]', u'Spustit dvojcestn\xe9 nebo trojcestn\xe9 porovn\xe1n\xed slo\u017eek')
usage: u'\n  %prog                              Spustit s pr\xe1zdn\xfdm oknem\n  %prog <soubor|slo\u017eka>              Spustit nov\xe9 porovn\xe1n\xed spr\xe1vy verz\xed\n  %prog <soubor> <soubor> [<soubor>] Spustit dvojcestn\xe9 nebo trojcestn\xe9 porovn\xe1n\xed soubor\u016f\n  %prog <slo\u017eka> <slo\u017eka> [<slo\u017eka>] Spustit dvojcestn\xe9 nebo trojcestn\xe9 porovn\xe1n\xed slo\u017eek'
usage_lines: [u'  %prog                              Spustit s pr\xe1zdn\xfdm oknem', u'  %prog <soubor|slo\u017eka>              Spustit nov\xe9 porovn\xe1n\xed spr\xe1vy verz\xed', u'  %prog <soubor> <soubor> [<soubor>] Spustit dvojcestn\xe9 nebo trojcestn\xe9 porovn\xe1n\xed soubor\u016f', u'  %prog <slo\u017eka> <slo\u017eka> [<slo\u017eka>] Spustit dvojcestn\xe9 nebo trojcestn\xe9 porovn\xe1n\xed slo\u017eek']
GLibFriendlyOptionParser: <class meld.meldapp.GLibFriendlyOptionParser at 0x7fe25d02ab48>
pad_args_fmt: '%-28s %s'
Comment 1 Jaroslav Škarvada 2015-08-12 08:40:13 EDT
Created attachment 1061936 [details]
File: backtrace
Comment 2 Jaroslav Škarvada 2015-08-12 08:40:14 EDT
Created attachment 1061937 [details]
File: environ
Comment 3 Dominic Hopf 2015-09-08 17:28:19 EDT

*** This bug has been marked as a duplicate of bug 1216120 ***

Note You need to log in before you can comment on or make changes to this bug.