Bug 1252902 - inst.repo=hd: is not working
inst.repo=hd: is not working
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: python-blivet (Show other bugs)
23
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Jiri Konecny
Fedora Extras Quality Assurance
CommonBugs AcceptedBlocker
: Reopened
: 1267993 (view as bug list)
Depends On:
Blocks: F23FinalBlocker
  Show dependency treegraph
 
Reported: 2015-08-12 09:26 EDT by Kamil Páral
Modified: 2015-10-14 09:17 EDT (History)
12 users (show)

See Also:
Fixed In Version: python-blivet-1.12.6-1.fc23
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-10-14 09:17:11 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
netinst - anaconda main hub (157.48 KB, image/png)
2015-08-12 09:30 EDT, Kamil Páral
no flags Details
netinst - installation source spoke (91.05 KB, image/png)
2015-08-12 09:30 EDT, Kamil Páral
no flags Details
netinst - journal (182.08 KB, text/plain)
2015-08-12 09:31 EDT, Kamil Páral
no flags Details
netinst - anaconda.log (15.54 KB, text/plain)
2015-08-12 09:31 EDT, Kamil Páral
no flags Details
netinst - packaging.log (212 bytes, text/plain)
2015-08-12 09:31 EDT, Kamil Páral
no flags Details
netinst - program.log (25.11 KB, text/plain)
2015-08-12 09:31 EDT, Kamil Páral
no flags Details
netinst - storage.log (67.33 KB, text/plain)
2015-08-12 09:31 EDT, Kamil Páral
no flags Details
netinst - syslog (106.39 KB, text/plain)
2015-08-12 09:31 EDT, Kamil Páral
no flags Details
pxe - anaconda-tb-kj53hldk (229.93 KB, text/plain)
2015-08-12 09:32 EDT, Kamil Páral
no flags Details
pxe - anaconda.log (8.75 KB, text/plain)
2015-08-12 09:32 EDT, Kamil Páral
no flags Details
pxe - packaging.log (220 bytes, text/plain)
2015-08-12 09:32 EDT, Kamil Páral
no flags Details
pxe - program.log (23.64 KB, text/plain)
2015-08-12 09:32 EDT, Kamil Páral
no flags Details
pxe - storage.log (56.69 KB, text/plain)
2015-08-12 09:32 EDT, Kamil Páral
no flags Details
pxe - syslog (99.19 KB, text/plain)
2015-08-12 09:32 EDT, Kamil Páral
no flags Details

  None (edit)
Description Kamil Páral 2015-08-12 09:26:45 EDT
Description of problem:
I wanted to test https://fedoraproject.org/wiki/QA:Testcase_install_repository_Hard_drive_variation . I placed DVD.iso on an ext4 formatted flash drive.

* When I booted the installer from netinst (a different flash drive), and used inst.repo=hd:LABEL=data:/DVD.iso, anaconda complained "Error setting up base repository". In the installation source dialog, the disk and the partition was visible, but no file was selected. When I manually selected DVD.iso from that partition (by clicking that blank unlabeled rectangular button next to it - that was quite a discovery), I correctly verified the image consistency, but still anaconda spit out the same error when confirming it.

* When I booted the installer from PXE and used inst.repo=hd:LABEL=data:/DVD.iso, anaconda crashed on start, before doing anything, with error "blivet.errors.FSError: umount failed".

Version-Release number of selected component (if applicable):
F23 Alpha
anaconda 23.17-1

How reproducible:
seems always

Steps to Reproduce:
1. follow the test case https://fedoraproject.org/wiki/QA:Testcase_install_repository_Hard_drive_variation , use F23 Alpha Server DVD x86_64 as the DVD.iso source
2. boot from PXE or from netinst, add inst.repo=hd:LABEL=label:/file.iso
3. see either crash or error setting up repository
Comment 1 Kamil Páral 2015-08-12 09:30:32 EDT
Created attachment 1061945 [details]
netinst - anaconda main hub
Comment 2 Kamil Páral 2015-08-12 09:30:47 EDT
Created attachment 1061946 [details]
netinst - installation source spoke
Comment 3 Kamil Páral 2015-08-12 09:31:23 EDT
Created attachment 1061948 [details]
netinst - journal
Comment 4 Kamil Páral 2015-08-12 09:31:28 EDT
Created attachment 1061949 [details]
netinst - anaconda.log
Comment 5 Kamil Páral 2015-08-12 09:31:31 EDT
Created attachment 1061950 [details]
netinst - packaging.log
Comment 6 Kamil Páral 2015-08-12 09:31:35 EDT
Created attachment 1061951 [details]
netinst - program.log
Comment 7 Kamil Páral 2015-08-12 09:31:39 EDT
Created attachment 1061952 [details]
netinst - storage.log
Comment 8 Kamil Páral 2015-08-12 09:31:44 EDT
Created attachment 1061953 [details]
netinst - syslog
Comment 9 Kamil Páral 2015-08-12 09:32:31 EDT
Created attachment 1061954 [details]
pxe - anaconda-tb-kj53hldk
Comment 10 Kamil Páral 2015-08-12 09:32:35 EDT
Created attachment 1061955 [details]
pxe - anaconda.log
Comment 11 Kamil Páral 2015-08-12 09:32:39 EDT
Created attachment 1061956 [details]
pxe - packaging.log
Comment 12 Kamil Páral 2015-08-12 09:32:42 EDT
Created attachment 1061957 [details]
pxe - program.log
Comment 13 Kamil Páral 2015-08-12 09:32:46 EDT
Created attachment 1061958 [details]
pxe - storage.log
Comment 14 Kamil Páral 2015-08-12 09:32:50 EDT
Created attachment 1061959 [details]
pxe - syslog
Comment 15 Kamil Páral 2015-08-12 09:34:53 EDT
Proposing as a blocker bug:
"The installer must be able to use all supported local and remote package and installer sources. "
https://fedoraproject.org/wiki/Fedora_23_Final_Release_Criteria#package-and-installer-sources
Comment 16 Adam Williamson 2015-08-20 13:16:12 EDT
Discussed at 2015-08-20 blocker review meeting: http://meetbot-raw.fedoraproject.org/fedora-blocker-review/2015-08-20/f23-blocker-review.2015-08-20-16.05.log.txt . Accepted as a blocker per criterion cited in #c15.
Comment 17 Fedora Update System 2015-09-03 15:33:45 EDT
python-blivet-1.12.2-1.fc23 anaconda-23.19.2-1.fc23 has been submitted as an update to Fedora 23. https://bodhi.fedoraproject.org/updates/FEDORA-2015-15030
Comment 18 Fedora Update System 2015-09-04 03:33:15 EDT
anaconda-23.19.2-1.fc23, python-blivet-1.12.2-1.fc23 has been pushed to the Fedora 23 testing repository. If problems still persist, please make note of it in this bug report.\nIf you want to test the update, you can install it with \n su -c 'yum --enablerepo=updates-testing update anaconda python-blivet'. You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2015-15030
Comment 19 Fedora Update System 2015-09-07 12:35:37 EDT
anaconda-23.19.2-1.fc23, python-blivet-1.12.2-1.fc23 has been pushed to the Fedora 23 stable repository. If problems still persist, please make note of it in this bug report.
Comment 20 Kamil Páral 2015-09-08 03:50:58 EDT
We need to verify this with Beta TC4 or later.
Comment 21 Kamil Páral 2015-09-08 05:48:37 EDT
Unfortunately this problem still persists, even with Beta TC4. The original reproduced with netinst (I haven't tested PXE) still stands. I've shown in to Jiri in person. Jiri, if you need fresh logs, just let me know.
Comment 22 Adam Williamson 2015-09-10 15:47:54 EDT
https://github.com/rhinstaller/blivet/commit/2bb2b354af4149d5bb30e8f2ca156d8d293f5e5e looks like it might be for this also, so maybe 1.12.3?
Comment 23 Jiri Konecny 2015-09-11 04:11:53 EDT
Hi awilliam,

I already tested that PR but it didn't helped. 

My first patch works but I tried it only with inst.repo=hd: parameter and this seems to be working correctly now. The problem now appears when we use both inst.repo= and inst.stage2= parameters. Seems like this is some problem with mounting same folder or something similar. I'm going to look on it today.

Thank you Kamil that you showed me that bug on your machine. I now know what to look for. I can reproduce it on my machine so the logs are not needed.

----
BTW 1.12.2 is incorrect version. It's bodhi2 bug which changing versions automatically.
Comment 24 Jiri Konecny 2015-09-14 08:15:34 EDT
PR: https://github.com/rhinstaller/blivet/pull/223
Comment 25 Jiri Konecny 2015-09-16 05:55:42 EDT
I fixed this in the blivet so I'm changing the component to blivet and setting up blivets version.

It should be fixed in the next anaconda version (hope new blivet gets there).
Comment 26 Fedora Update System 2015-09-24 19:35:55 EDT
python-blivet-1.12.5-1.fc23 anaconda-23.19.5-1.fc23 has been submitted as an update to Fedora 23. https://bodhi.fedoraproject.org/updates/FEDORA-2015-fe57978cc8
Comment 27 Fedora Update System 2015-09-25 12:32:03 EDT
anaconda-23.19.5-1.fc23, python-blivet-1.12.5-1.fc23 has been pushed to the Fedora 23 testing repository. If problems still persist, please make note of it in this bug report.
If you want to test the update, you can install it with
$ su -c 'dnf --enablerepo=updates-testing update python-blivet anaconda'
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2015-fe57978cc8
Comment 28 Adam Williamson 2015-09-30 12:51:24 EDT
This should be fixed in Final TC1, Kamil, can you confirm? Thanks!
Comment 29 Kamil Páral 2015-10-01 10:23:48 EDT
When I tried to reproduce with with F23 TC1 DVD + netinst, I see the same problem as in comment 0. Furthermore, when I tried to manually pick the iso image, anaconda crashed, reported as bug 1267993 (should contain all relevant logs even for the inst.repo part).
Comment 30 Kamil Páral 2015-10-01 10:31:32 EDT
When I tried to reproduce this with F23 TC1 DVD + PXE, it worked correctly. So PXE boot is fixed, but netinst boot is not.
Comment 31 Fedora Update System 2015-10-01 12:02:07 EDT
anaconda-23.19.5-1.fc23, python-blivet-1.12.5-1.fc23 has been pushed to the Fedora 23 stable repository. If problems still persist, please make note of it in this bug report.
Comment 32 Adam Williamson 2015-10-01 15:09:16 EDT
Re-opening per #c29.
Comment 33 Brian Lane 2015-10-01 15:56:52 EDT
*** Bug 1267993 has been marked as a duplicate of this bug. ***
Comment 34 Jiri Konecny 2015-10-02 09:03:29 EDT
It's a regression from my last patch. It's already fixed and it will be in the next release.

Sorry for the regression.
Comment 35 Fedora Update System 2015-10-08 14:22:30 EDT
python-blivet-1.12.6-1.fc23 anaconda-23.19.6-1.fc23 has been submitted as an update to Fedora 23. https://bodhi.fedoraproject.org/updates/FEDORA-2015-6f7d535c92
Comment 36 Fedora Update System 2015-10-09 09:54:52 EDT
anaconda-23.19.6-1.fc23, python-blivet-1.12.6-1.fc23 has been pushed to the Fedora 23 testing repository. If problems still persist, please make note of it in this bug report.
If you want to test the update, you can install it with
$ su -c 'dnf --enablerepo=updates-testing update anaconda python-blivet'
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2015-6f7d535c92
Comment 37 Fedora Update System 2015-10-12 02:27:00 EDT
anaconda-23.19.6-1.fc23, python-blivet-1.12.6-1.fc23 has been pushed to the Fedora 23 stable repository. If problems still persist, please make note of it in this bug report.
Comment 38 Kamil Páral 2015-10-14 09:17:11 EDT
This is fixed with F23 TC9, tested both netinst and PXE boot.

Note You need to log in before you can comment on or make changes to this bug.