Bug 1267993 - blivet.errors.FSError: mount failed: 32
blivet.errors.FSError: mount failed: 32
Status: CLOSED DUPLICATE of bug 1252902
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
23
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Anaconda Maintenance Team
Fedora Extras Quality Assurance
abrt_hash:fe9e24d0203702ac7985780fdfb...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-10-01 10:19 EDT by Kamil Páral
Modified: 2015-10-01 15:56 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-10-01 15:56:52 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: anaconda-tb (369.24 KB, text/plain)
2015-10-01 10:19 EDT, Kamil Páral
no flags Details
File: anaconda.log (13.56 KB, text/plain)
2015-10-01 10:19 EDT, Kamil Páral
no flags Details
File: dnf.log (435 bytes, text/plain)
2015-10-01 10:19 EDT, Kamil Páral
no flags Details
File: dnf.rpm.log (147 bytes, text/plain)
2015-10-01 10:19 EDT, Kamil Páral
no flags Details
File: environ (459 bytes, text/plain)
2015-10-01 10:19 EDT, Kamil Páral
no flags Details
File: lsblk_output (2.53 KB, text/plain)
2015-10-01 10:19 EDT, Kamil Páral
no flags Details
File: nmcli_dev_list (1.56 KB, text/plain)
2015-10-01 10:19 EDT, Kamil Páral
no flags Details
File: os_info (451 bytes, text/plain)
2015-10-01 10:19 EDT, Kamil Páral
no flags Details
File: storage.log (118.85 KB, text/plain)
2015-10-01 10:19 EDT, Kamil Páral
no flags Details
File: syslog (105.64 KB, text/plain)
2015-10-01 10:19 EDT, Kamil Páral
no flags Details
File: ifcfg.log (2.58 KB, text/plain)
2015-10-01 10:19 EDT, Kamil Páral
no flags Details
File: packaging.log (257 bytes, text/plain)
2015-10-01 10:19 EDT, Kamil Páral
no flags Details
File: program.log (62.56 KB, application/octet-stream)
2015-10-01 10:20 EDT, Kamil Páral
no flags Details

  None (edit)
Description Kamil Páral 2015-10-01 10:19:35 EDT
Description of problem:
I have tried to reproduce bug 1252902. I have booted netinst with inst.repo=LABEL=data:/DVD.iso. In the main hub, anaconda said "error setting up base repository" under installation source. When I entered the spoke, a red bar said "Failed to set up installation source; check the repo url". When I tried to pick the iso file manually by clicking the unnamed rectangular button, anaconda crashed. The source device seems to be selected properly in anaconda gui - it says /dev/sdc1 (14.48GiB) ext4 data, which seems correct.

Version-Release number of selected component:
anaconda-23.19.5-1

The following was filed automatically by anaconda:
anaconda 23.19.5-1 exception report
Traceback (most recent call first):
  File "/usr/lib/python3.4/site-packages/blivet/tasks/fsmount.py", line 123, in doTask
    raise FSError("mount failed: %s" % rc)
  File "/usr/lib/python3.4/site-packages/blivet/formats/fs.py", line 595, in _setup
    self._mount.doTask(chrootedMountpoint, options=options)
  File "/usr/lib/python3.4/site-packages/blivet/formats/__init__.py", line 483, in setup
    self._setup(**kwargs)
  File "/usr/lib/python3.4/site-packages/blivet/formats/fs.py", line 754, in mount
    return self.setup(**kwargs)
  File "/usr/lib64/python3.4/site-packages/pyanaconda/ui/gui/spokes/source.py", line 350, in run
    dev.format.mount(mountpoint=mountpoint)
  File "/usr/lib64/python3.4/site-packages/pyanaconda/ui/gui/spokes/source.py", line 1152, in on_chooser_clicked
    f = dialog.run(self._get_selected_partition())
blivet.errors.FSError: mount failed: 32

Additional info:
addons:         com_redhat_kdump
cmdline:        /usr/bin/python3  /sbin/anaconda
cmdline_file:   BOOT_IMAGE=/images/pxeboot/vmlinuz inst.stage2=hd:LABEL=Fedora-S-23_T1-x86_64 quiet inst.repo=hd:LABEL=data:/DVD.iso
executable:     /sbin/anaconda
hashmarkername: anaconda
kernel:         4.2.1-300.fc23.x86_64
product:        Fedora
release:        Cannot get release name.
type:           anaconda
version:        23
Comment 1 Kamil Páral 2015-10-01 10:19:40 EDT
Created attachment 1079125 [details]
File: anaconda-tb
Comment 2 Kamil Páral 2015-10-01 10:19:41 EDT
Created attachment 1079126 [details]
File: anaconda.log
Comment 3 Kamil Páral 2015-10-01 10:19:43 EDT
Created attachment 1079127 [details]
File: dnf.log
Comment 4 Kamil Páral 2015-10-01 10:19:45 EDT
Created attachment 1079128 [details]
File: dnf.rpm.log
Comment 5 Kamil Páral 2015-10-01 10:19:46 EDT
Created attachment 1079129 [details]
File: environ
Comment 6 Kamil Páral 2015-10-01 10:19:48 EDT
Created attachment 1079130 [details]
File: lsblk_output
Comment 7 Kamil Páral 2015-10-01 10:19:49 EDT
Created attachment 1079131 [details]
File: nmcli_dev_list
Comment 8 Kamil Páral 2015-10-01 10:19:51 EDT
Created attachment 1079132 [details]
File: os_info
Comment 9 Kamil Páral 2015-10-01 10:19:53 EDT
Created attachment 1079133 [details]
File: storage.log
Comment 10 Kamil Páral 2015-10-01 10:19:56 EDT
Created attachment 1079134 [details]
File: syslog
Comment 11 Kamil Páral 2015-10-01 10:19:57 EDT
Created attachment 1079135 [details]
File: ifcfg.log
Comment 12 Kamil Páral 2015-10-01 10:19:59 EDT
Created attachment 1079136 [details]
File: packaging.log
Comment 13 Kamil Páral 2015-10-01 10:20:01 EDT
Created attachment 1079137 [details]
File: program.log
Comment 14 Kamil Páral 2015-10-01 10:22:03 EDT
When I switch to TTY2, I see /dev/sdc1 mounted at /mnt/sysimage, and there is DVD.iso available under /mnt/sysimage.
Comment 15 Brian Lane 2015-10-01 15:56:52 EDT

*** This bug has been marked as a duplicate of bug 1252902 ***

Note You need to log in before you can comment on or make changes to this bug.