Bug 1252903 - Fix invalid logic in tier.t
Fix invalid logic in tier.t
Status: CLOSED CURRENTRELEASE
Product: GlusterFS
Classification: Community
Component: tiering (Show other bugs)
3.7.5
x86_64 Unspecified
high Severity unspecified
: ---
: ---
Assigned To: Dan Lambright
bugs@gluster.org
:
Depends On: 1231268 1262335
Blocks: 1244290 1260923
  Show dependency treegraph
 
Reported: 2015-08-12 09:28 EDT by Dan Lambright
Modified: 2015-10-30 13:32 EDT (History)
2 users (show)

See Also:
Fixed In Version: glusterfs-3.7.4
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 1231268
Environment:
Last Closed: 2015-09-09 05:39:25 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Dan Lambright 2015-08-12 09:28:59 EDT
+++ This bug was initially created as a clone of Bug #1231268 +++

The tier.t logic did not properly check for corrupted data after migration.

--- Additional comment from Anand Avati on 2015-06-17 11:15:57 EDT ---

REVIEW: http://review.gluster.org/11285 (cluster/tier : fixed logical bug in tier.t) posted (#1) for review on master by Pamela Ousley (pousley@redhat.com)

--- Additional comment from Anand Avati on 2015-06-22 10:48:19 EDT ---

REVIEW: http://review.gluster.org/11285 (cluster/tier : fixed logical bug in tier.t) posted (#2) for review on master by Pamela Ousley (pousley@redhat.com)

--- Additional comment from Anand Avati on 2015-06-22 13:56:08 EDT ---

REVIEW: http://review.gluster.org/11285 (cluster/tier : fixed logical bug in tier.t) posted (#3) for review on master by Pamela Ousley (pousley@redhat.com)

--- Additional comment from Anand Avati on 2015-06-26 19:25:40 EDT ---

REVIEW: http://review.gluster.org/11285 (cluster/tier : fixed logical bug in tier.t) posted (#4) for review on master by Pamela Ousley (pousley@redhat.com)

--- Additional comment from Anand Avati on 2015-06-29 11:32:15 EDT ---

REVIEW: http://review.gluster.org/11285 (cluster/tier : fixed logical bug in tier.t) posted (#5) for review on master by Pamela Ousley (pousley@redhat.com)

--- Additional comment from Anand Avati on 2015-06-29 11:45:30 EDT ---

REVIEW: http://review.gluster.org/11285 (cluster/tier : fixed logical bug in tier.t) posted (#6) for review on master by Pamela Ousley (pousley@redhat.com)

--- Additional comment from Anand Avati on 2015-07-07 15:45:36 EDT ---

REVIEW: http://review.gluster.org/11285 (cluster/tier : fix for logical bugs/timing errors in tier.t) posted (#7) for review on master by Pamela Ousley (pousley@redhat.com)

--- Additional comment from Anand Avati on 2015-07-07 15:58:14 EDT ---

REVIEW: http://review.gluster.org/11285 (cluster/tier : fix for logical bugs/timing errors in tier.t) posted (#8) for review on master by Pamela Ousley (pousley@redhat.com)

--- Additional comment from Anand Avati on 2015-07-13 13:14:56 EDT ---

REVIEW: http://review.gluster.org/11285 (cluster/tier : fix for logical bugs/timing errors in tier.t) posted (#9) for review on master by Pamela Ousley (pousley@redhat.com)

--- Additional comment from Anand Avati on 2015-07-13 17:12:30 EDT ---

COMMIT: http://review.gluster.org/11285 committed in master by Dan Lambright (dlambrig@redhat.com) 
------
commit f7b9379a0a03fb1d2df56bbfc8dca06f5f3b8437
Author: Pamela Ousley <pousley@redhat.com>
Date:   Wed Jun 17 15:07:55 2015 -0400

    cluster/tier : fix for logical bugs/timing errors in tier.t
    
    The md5sum fingerprints were not correctly compared after moving
    files between the hot and cold tiers.
    
    This version of tier.t uses a new function, "check_counters", to
    ensure that the number of promotions/demotions is as expected.
    This is intended to avoid spurious timing-related errors that were
    seen with the old script.
    
    Change-Id: I4a0ae7315493bfd307a0f68f21fa3ea33c88b08f
    BUG: 1231268
    Signed-off-by: Pamela Ousley <pousley@redhat.com>
    Reviewed-on: http://review.gluster.org/11285
    Tested-by: NetBSD Build System <jenkins@build.gluster.org>
    Tested-by: Gluster Build System <jenkins@build.gluster.com>
    Reviewed-by: Dan Lambright <dlambrig@redhat.com>

--- Additional comment from Anand Avati on 2015-08-11 15:38:21 EDT ---

REVIEW: http://review.gluster.org/11885 (cluster/tier: fix 64 bit issue with sql query using times) posted (#1) for review on master by Dan Lambright (dlambrig@redhat.com)
Comment 1 Anand Avati 2015-08-13 10:25:59 EDT
REVIEW: http://review.gluster.org/11913 (cluster/tier: fix 64 bit issue with sql query using times) posted (#1) for review on release-3.7 by Dan Lambright (dlambrig@redhat.com)
Comment 2 Anand Avati 2015-08-13 12:08:59 EDT
COMMIT: http://review.gluster.org/11913 committed in release-3.7 by Dan Lambright (dlambrig@redhat.com) 
------
commit 0e3c9029e1d022f2aadcac7c320b7c56069bc0c6
Author: Dan Lambright <dlambrig@redhat.com>
Date:   Thu Aug 13 10:24:23 2015 -0400

    cluster/tier: fix 64 bit issue with sql query using times
    
    This is a backport of 11885.
    
    > We overflowed when converting seconds to usecs in preperation for
    > sql queries. The fix uses uint64_t throughout including subexpressions.
    
    > Change-Id: I59bdb742197400dede97f54735b52030920b0d19
    > BUG: 1231268
    > Signed-off-by: Dan Lambright <dlambrig@redhat.com>
    
    Change-Id: Iaef7083dac7a162080f4bc23e29dedfe700fa342
    BUG: 1252903
    Signed-off-by: Dan Lambright <dlambrig@redhat.com>
    Reviewed-on: http://review.gluster.org/11913
    Tested-by: NetBSD Build System <jenkins@build.gluster.org>
    Reviewed-by: Joseph Fernandes
Comment 3 Kaushal 2015-09-09 05:39:25 EDT
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.7.4, please open a new bug report.

glusterfs-3.7.4 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] http://thread.gmane.org/gmane.comp.file-systems.gluster.devel/12496
[2] http://thread.gmane.org/gmane.comp.file-systems.gluster.user

Note You need to log in before you can comment on or make changes to this bug.