Bug 1262335 - Fix invalid logic in tier.t
Summary: Fix invalid logic in tier.t
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: GlusterFS
Classification: Community
Component: tiering
Version: 3.7.5
Hardware: x86_64
OS: Unspecified
high
unspecified
Target Milestone: ---
Assignee: Dan Lambright
QA Contact: bugs@gluster.org
URL:
Whiteboard:
Depends On: 1231268
Blocks: 1244290 1252903 1260923
TreeView+ depends on / blocked
 
Reported: 2015-09-11 12:42 UTC by Dan Lambright
Modified: 2015-10-30 17:32 UTC (History)
3 users (show)

Fixed In Version: glusterfs-3.7.5
Doc Type: Bug Fix
Doc Text:
Clone Of: 1231268
Environment:
Last Closed: 2015-10-14 10:28:00 UTC
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:


Attachments (Terms of Use)

Description Dan Lambright 2015-09-11 12:42:41 UTC
+++ This bug was initially created as a clone of Bug #1231268 +++

The tier.t logic did not properly check for corrupted data after migration.

--- Additional comment from Anand Avati on 2015-06-17 11:15:57 EDT ---

REVIEW: http://review.gluster.org/11285 (cluster/tier : fixed logical bug in tier.t) posted (#1) for review on master by Pamela Ousley (pousley@redhat.com)

--- Additional comment from Anand Avati on 2015-06-22 10:48:19 EDT ---

REVIEW: http://review.gluster.org/11285 (cluster/tier : fixed logical bug in tier.t) posted (#2) for review on master by Pamela Ousley (pousley@redhat.com)

--- Additional comment from Anand Avati on 2015-06-22 13:56:08 EDT ---

REVIEW: http://review.gluster.org/11285 (cluster/tier : fixed logical bug in tier.t) posted (#3) for review on master by Pamela Ousley (pousley@redhat.com)

--- Additional comment from Anand Avati on 2015-06-26 19:25:40 EDT ---

REVIEW: http://review.gluster.org/11285 (cluster/tier : fixed logical bug in tier.t) posted (#4) for review on master by Pamela Ousley (pousley@redhat.com)

--- Additional comment from Anand Avati on 2015-06-29 11:32:15 EDT ---

REVIEW: http://review.gluster.org/11285 (cluster/tier : fixed logical bug in tier.t) posted (#5) for review on master by Pamela Ousley (pousley@redhat.com)

--- Additional comment from Anand Avati on 2015-06-29 11:45:30 EDT ---

REVIEW: http://review.gluster.org/11285 (cluster/tier : fixed logical bug in tier.t) posted (#6) for review on master by Pamela Ousley (pousley@redhat.com)

--- Additional comment from Anand Avati on 2015-07-07 15:45:36 EDT ---

REVIEW: http://review.gluster.org/11285 (cluster/tier : fix for logical bugs/timing errors in tier.t) posted (#7) for review on master by Pamela Ousley (pousley@redhat.com)

--- Additional comment from Anand Avati on 2015-07-07 15:58:14 EDT ---

REVIEW: http://review.gluster.org/11285 (cluster/tier : fix for logical bugs/timing errors in tier.t) posted (#8) for review on master by Pamela Ousley (pousley@redhat.com)

--- Additional comment from Anand Avati on 2015-07-13 13:14:56 EDT ---

REVIEW: http://review.gluster.org/11285 (cluster/tier : fix for logical bugs/timing errors in tier.t) posted (#9) for review on master by Pamela Ousley (pousley@redhat.com)

--- Additional comment from Anand Avati on 2015-07-13 17:12:30 EDT ---

COMMIT: http://review.gluster.org/11285 committed in master by Dan Lambright (dlambrig@redhat.com) 
------
commit f7b9379a0a03fb1d2df56bbfc8dca06f5f3b8437
Author: Pamela Ousley <pousley@redhat.com>
Date:   Wed Jun 17 15:07:55 2015 -0400

    cluster/tier : fix for logical bugs/timing errors in tier.t
    
    The md5sum fingerprints were not correctly compared after moving
    files between the hot and cold tiers.
    
    This version of tier.t uses a new function, "check_counters", to
    ensure that the number of promotions/demotions is as expected.
    This is intended to avoid spurious timing-related errors that were
    seen with the old script.
    
    Change-Id: I4a0ae7315493bfd307a0f68f21fa3ea33c88b08f
    BUG: 1231268
    Signed-off-by: Pamela Ousley <pousley@redhat.com>
    Reviewed-on: http://review.gluster.org/11285
    Tested-by: NetBSD Build System <jenkins@build.gluster.org>
    Tested-by: Gluster Build System <jenkins@build.gluster.com>
    Reviewed-by: Dan Lambright <dlambrig@redhat.com>

--- Additional comment from Anand Avati on 2015-08-11 15:38:21 EDT ---

REVIEW: http://review.gluster.org/11885 (cluster/tier: fix 64 bit issue with sql query using times) posted (#1) for review on master by Dan Lambright (dlambrig@redhat.com)

--- Additional comment from Anand Avati on 2015-08-13 07:38:59 EDT ---

COMMIT: http://review.gluster.org/11885 committed in master by Dan Lambright (dlambrig@redhat.com) 
------
commit 6e055b7d7355cadbbf559ad4bed23872aa1743df
Author: Dan Lambright <dlambrig@redhat.com>
Date:   Tue Aug 11 15:36:26 2015 -0400

    cluster/tier: fix 64 bit issue with sql query using times
    
    We overflowed when converting seconds to usecs in preperation for
    sql queries. The fix uses uint64_t throughout including subexpressions.
    
    Change-Id: I59bdb742197400dede97f54735b52030920b0d19
    BUG: 1231268
    Signed-off-by: Dan Lambright <dlambrig@redhat.com>
    Reviewed-on: http://review.gluster.org/11885
    Tested-by: NetBSD Build System <jenkins@build.gluster.org>
    Tested-by: Gluster Build System <jenkins@build.gluster.com>
    Reviewed-by: Joseph Fernandes

--- Additional comment from Anand Avati on 2015-08-13 14:46:34 EDT ---

REVIEW: http://review.gluster.org/11914 (cluster/tier: add detach tier test) posted (#1) for review on master by Dan Lambright (dlambrig@redhat.com)

--- Additional comment from Anand Avati on 2015-08-14 10:05:33 EDT ---

REVIEW: http://review.gluster.org/11914 (cluster/tier: add detach tier test) posted (#2) for review on master by Dan Lambright (dlambrig@redhat.com)

--- Additional comment from Dan Lambright on 2015-08-25 01:15:35 EDT ---



--- Additional comment from Dan Lambright on 2015-08-25 01:18:42 EDT ---

There is still a problem with test 29, intermittent failures when the database is locked and another process tries to get a lock. When the second fails to get the lock the promote/demotion fails and this aborts the operation; the counter is never raised; the test fails.

--- Additional comment from Vijay Bellur on 2015-09-08 12:28:49 EDT ---

REVIEW: http://review.gluster.org/12128 (gluster/tier Remove tier.t from spurious failure list) posted (#1) for review on master by Dan Lambright (dlambrig@redhat.com)

--- Additional comment from Vijay Bellur on 2015-09-09 18:46:21 EDT ---

COMMIT: http://review.gluster.org/12128 committed in master by Dan Lambright (dlambrig@redhat.com) 
------
commit 3a6e397bccf7ebaf9528617f5615553670211edf
Author: Dan Lambright <dlambrig@redhat.com>
Date:   Tue Sep 8 12:26:47 2015 -0400

    gluster/tier Remove tier.t from spurious failure list
    
    The spurious failure was related to database lock contention,
    and was fixed in patch 12031.
    
    Ran tier.t in loop (very many) times successfully to confirm fixed.
    
    Change-Id: Ib7446bcd02c76dea03b4cf273aae0dba27c4ef19
    BUG: 1231268
    Signed-off-by: Dan Lambright <dlambrig@redhat.com>
    Reviewed-on: http://review.gluster.org/12128
    Tested-by: Gluster Build System <jenkins@build.gluster.com>

--- Additional comment from Vijay Bellur on 2015-09-09 18:48:02 EDT ---

REVIEW: http://review.gluster.org/11914 (cluster/tier: add detach tier test) posted (#3) for review on master by Dan Lambright (dlambrig@redhat.com)

Comment 1 Pranith Kumar K 2015-10-14 10:28:00 UTC
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-glusterfs-3.7.5, please open a new bug report.

glusterfs-glusterfs-3.7.5 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] http://www.gluster.org/pipermail/gluster-users/2015-October/023968.html
[2] http://thread.gmane.org/gmane.comp.file-systems.gluster.user

Comment 2 Pranith Kumar K 2015-10-14 10:37:35 UTC
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.7.5, please open a new bug report.

glusterfs-3.7.5 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] http://www.gluster.org/pipermail/gluster-users/2015-October/023968.html
[2] http://thread.gmane.org/gmane.comp.file-systems.gluster.user


Note You need to log in before you can comment on or make changes to this bug.