Bug 1252945 - Copying an activation key does not copy service level
Copying an activation key does not copy service level
Status: CLOSED ERRATA
Product: Red Hat Satellite 6
Classification: Red Hat
Component: Activation Keys (Show other bugs)
6.0.4
Unspecified Unspecified
unspecified Severity high (vote)
: Beta
: --
Assigned To: Christine Fouant
jcallaha
http://projects.theforeman.org/issues...
: Triaged
Depends On:
Blocks: 1257206
  Show dependency treegraph
 
Reported: 2015-08-12 10:53 EDT by Christine Fouant
Modified: 2016-07-27 05:17 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-07-27 05:17:38 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Foreman Issue Tracker 10414 None None None 2016-04-22 12:38 EDT

  None (edit)
Description Christine Fouant 2015-08-12 10:53:27 EDT
Copying an existing activation key with a service level setting does not yield expected results. The new key created has no service level setting attached to it, where it should have the same service level setting as the original.
Comment 1 Christine Fouant 2015-08-12 10:53:29 EDT
Created from redmine issue http://projects.theforeman.org/issues/10414
Comment 3 Bryan Kearney 2015-08-14 13:53:19 EDT
Upstream bug assigned to cfouant@redhat.com
Comment 4 Bryan Kearney 2015-08-25 16:06:56 EDT
Upstream bug component is Content Management
Comment 5 Bryan Kearney 2015-08-25 16:27:12 EDT
Upstream bug component is Activation Keys
Comment 6 Bryan Kearney 2016-03-15 20:06:44 EDT
Moving to POST since upstream bug http://projects.theforeman.org/issues/10414 has been closed
-------------
Christine Fouant
Applied in changeset commit:katello|1575ba26ea5ecb13205cba16a7a98e49c41269be.
Comment 7 Brad Buckingham 2016-03-16 05:54:57 EDT
Note: without this fix, a user would also observe errors attempting to copy an activation key (e.g. via hammer) that contains subscriptions.   E.g.

without the fix:

hammer> activation-key copy --organization-id 1 --id 2 --new-name test-copy
Could not copy the activation key:
  Couldn't find Katello::Pool with 'id'=4028fae453755df4015375606cdb0005

with the fix:

hammer> activation-key copy --organization-id 1 --id 2 --new-name test-copy
Activation key copied
Comment 8 jcallaha 2016-03-24 15:40:24 EDT
Verified in Satellite 6.2 Beta Snap 5.1
Comment 11 errata-xmlrpc 2016-07-27 05:17:38 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2016:1501

Note You need to log in before you can comment on or make changes to this bug.