Bug 1252972 - [abrt] webkitgtk4: _g_log_abort(): WebKitWebProcess killed by SIGTRAP
[abrt] webkitgtk4: _g_log_abort(): WebKitWebProcess killed by SIGTRAP
Status: CLOSED UPSTREAM
Product: Fedora
Classification: Fedora
Component: webkitgtk4 (Show other bugs)
23
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Tomas Popela
Fedora Extras Quality Assurance
https://retrace.fedoraproject.org/faf...
abrt_hash:e3920fdd030a707710b791f04c3...
:
: 1258116 1363927 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-08-12 11:40 EDT by Diogo Campos
Modified: 2016-11-18 12:39 EST (History)
17 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-09-25 17:06:39 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: backtrace (71.43 KB, text/plain)
2015-08-12 11:40 EDT, Diogo Campos
no flags Details
File: cgroup (190 bytes, text/plain)
2015-08-12 11:40 EDT, Diogo Campos
no flags Details
File: core_backtrace (6.22 KB, text/plain)
2015-08-12 11:40 EDT, Diogo Campos
no flags Details
File: dso_list (15.40 KB, text/plain)
2015-08-12 11:40 EDT, Diogo Campos
no flags Details
File: environ (1.63 KB, text/plain)
2015-08-12 11:40 EDT, Diogo Campos
no flags Details
File: limits (1.29 KB, text/plain)
2015-08-12 11:40 EDT, Diogo Campos
no flags Details
File: maps (89.15 KB, text/plain)
2015-08-12 11:40 EDT, Diogo Campos
no flags Details
File: mountinfo (3.32 KB, text/plain)
2015-08-12 11:40 EDT, Diogo Campos
no flags Details
File: namespaces (85 bytes, text/plain)
2015-08-12 11:40 EDT, Diogo Campos
no flags Details
File: open_fds (4.52 KB, text/plain)
2015-08-12 11:40 EDT, Diogo Campos
no flags Details
File: proc_pid_status (1018 bytes, text/plain)
2015-08-12 11:41 EDT, Diogo Campos
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
WebKit Project 149568 None None None Never

  None (edit)
Description Diogo Campos 2015-08-12 11:40:24 EDT
Version-Release number of selected component:
webkitgtk4-2.9.5-1.fc23

Additional info:
reporter:       libreport-2.6.2
backtrace_rating: 4
cmdline:        /usr/libexec/webkit2gtk-4.0/WebKitWebProcess 25
crash_function: _g_log_abort
executable:     /usr/libexec/webkit2gtk-4.0/WebKitWebProcess
global_pid:     14570
kernel:         4.2.0-0.rc5.git0.2.fc23.x86_64
runlevel:       N 5
type:           CCpp
uid:            1000

Truncated backtrace:
Thread no. 1 (10 frames)
 #0 _g_log_abort at gmessages.c:316
 #8 XGetGeometry at GetGeom.c:47
 #9 WebCore::GLContextGLX::defaultFrameBufferSize at /usr/src/debug/webkitgtk-2.9.5/Source/WebCore/platform/graphics/glx/GLContextGLX.cpp:189
 #10 WebKit::LayerTreeHostGtk::compositeLayersToContext at /usr/src/debug/webkitgtk-2.9.5/Source/WebKit2/WebProcess/WebPage/gtk/LayerTreeHostGtk.cpp:285
 #11 WebKit::LayerTreeHostGtk::flushAndRenderLayers at /usr/src/debug/webkitgtk-2.9.5/Source/WebKit2/WebProcess/WebPage/gtk/LayerTreeHostGtk.cpp:318
 #12 WebKit::LayerTreeHostGtk::layerFlushTimerFired at /usr/src/debug/webkitgtk-2.9.5/Source/WebKit2/WebProcess/WebPage/gtk/LayerTreeHostGtk.cpp:237
 #13 std::function<void ()>::operator()() const at /usr/include/c++/5.1.1/functional:2271
 #14 WTF::GMainLoopSource::voidCallback at /usr/src/debug/webkitgtk-2.9.5/Source/WTF/wtf/glib/GMainLoopSource.cpp:365
 #15 WTF::GMainLoopSource::voidSourceCallback at /usr/src/debug/webkitgtk-2.9.5/Source/WTF/wtf/glib/GMainLoopSource.cpp:456
 #20 WTF::RunLoop::run at /usr/src/debug/webkitgtk-2.9.5/Source/WTF/wtf/glib/RunLoopGLib.cpp:67
Comment 1 Diogo Campos 2015-08-12 11:40:33 EDT
Created attachment 1062067 [details]
File: backtrace
Comment 2 Diogo Campos 2015-08-12 11:40:34 EDT
Created attachment 1062068 [details]
File: cgroup
Comment 3 Diogo Campos 2015-08-12 11:40:37 EDT
Created attachment 1062069 [details]
File: core_backtrace
Comment 4 Diogo Campos 2015-08-12 11:40:39 EDT
Created attachment 1062071 [details]
File: dso_list
Comment 5 Diogo Campos 2015-08-12 11:40:42 EDT
Created attachment 1062072 [details]
File: environ
Comment 6 Diogo Campos 2015-08-12 11:40:44 EDT
Created attachment 1062073 [details]
File: limits
Comment 7 Diogo Campos 2015-08-12 11:40:49 EDT
Created attachment 1062074 [details]
File: maps
Comment 8 Diogo Campos 2015-08-12 11:40:52 EDT
Created attachment 1062075 [details]
File: mountinfo
Comment 9 Diogo Campos 2015-08-12 11:40:53 EDT
Created attachment 1062076 [details]
File: namespaces
Comment 10 Diogo Campos 2015-08-12 11:40:56 EDT
Created attachment 1062077 [details]
File: open_fds
Comment 11 Diogo Campos 2015-08-12 11:41:00 EDT
Created attachment 1062078 [details]
File: proc_pid_status
Comment 12 Fedora Update System 2015-08-25 11:42:34 EDT
webkitgtk4-2.9.90-2.fc23 has been submitted as an update to Fedora 23. https://bodhi.fedoraproject.org/updates/FEDORA-2015-14259
Comment 13 Michael Catanzaro 2015-08-25 11:46:25 EDT
Just kidding; this looks unrelated to the current update.
Comment 14 Michael Catanzaro 2015-09-25 17:08:26 EDT
*** Bug 1258116 has been marked as a duplicate of this bug. ***
Comment 15 Jean-François Fortin Tam 2015-12-10 23:15:41 EST
FWIW, it happened to me simply by reloading (F5) one tab in epiphany. There were no user-visible consequences but ABRT caught this anyhow.
Comment 16 Daniel 2016-02-02 07:59:50 EST
Another user experienced a similar problem:

Disconnected two NICs while another NIC was still up.

reporter:       libreport-2.6.3
backtrace_rating: 4
cmdline:        /usr/libexec/webkit2gtk-4.0/WebKitWebProcess 62
crash_function: _g_log_abort
executable:     /usr/libexec/webkit2gtk-4.0/WebKitWebProcess
global_pid:     5401
kernel:         4.2.3-300.fc23.x86_64
package:        webkitgtk4-2.10.4-1.fc23
reason:         WebKitWebProcess killed by SIGTRAP
runlevel:       N 5
type:           CCpp
uid:            1000
Comment 17 Michael Catanzaro 2016-11-18 12:39:45 EST
*** Bug 1363927 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.