Bug 1253149 - performance translators: Pending - porting logging messages to new logging framework
performance translators: Pending - porting logging messages to new logging fr...
Status: CLOSED CURRENTRELEASE
Product: GlusterFS
Classification: Community
Component: logging (Show other bugs)
mainline
x86_64 Linux
unspecified Severity high
: ---
: ---
Assigned To: hari gowtham
:
Depends On: 1242377 1258727
Blocks: 1241957
  Show dependency treegraph
 
Reported: 2015-08-13 02:35 EDT by hari gowtham
Modified: 2016-06-16 09:31 EDT (History)
4 users (show)

See Also:
Fixed In Version: glusterfs-3.8rc2
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 1242377
Environment:
Last Closed: 2016-06-16 09:31:51 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description hari gowtham 2015-08-13 02:35:20 EDT
+++ This bug was initially created as a clone of Bug #1242377 +++

Description of problem:
-----------------------
There are few instances of 'gf_log' as seen under performance_xlators directory in the code base

Version-Release number of selected component (if applicable):
-------------------------------------------------------------
RHGS 3.1 ( glusterfs-3.7.1-8.el6rhs )

Expected results:
-----------------
All gf_log instances should be ported to new logging framework

gf_log instances
-----------------
io-cache/src/ioc-inode.c:   gf_log ("io-cache", GF_LOG_WARNING,
io-cache/src/ioc-inode.c-   "asprintf failed while converting ptr to str");
--
io-cache/src/ioc-inode.c:   gf_log (frame->this->name, GF_LOG_WARNING,
io-cache/src/ioc-inode.c-   "cache validate called without any "
--
io-cache/src/page.c:        gf_log (frame->this->name, GF_LOG_WARNING,
io-cache/src/page.c-         "wasted copy: %"PRId64"[+%"PRId64"] "
--
quick-read/src/quick-read.c:  gf_log ("quick-read", GF_LOG_INFO,
quick-read/src/quick-read.c-    "quick read inode table lru not empty");
--
read-ahead/src/read-ahead.c:  gf_log (this->name, GF_LOG_WARNING, "conf null in xlator");
read-ahead/src/read-ahead.c-   goto out;
--
read-ahead/src/read-ahead.c:  gf_log (this->name, GF_LOG_INFO,
read-ahead/src/read-ahead.c-  "undestroyed read ahead file structures found");
--
symlink-cache/src/symlink-cache.c: gf_log (this->name, GF_LOG_ERROR,
symlink-cache/src/symlink-cache.c-	"out of memory :(");
Comment 1 Anand Avati 2015-08-13 03:32:05 EDT
REVIEW: http://review.gluster.org/11906 (performance translators : porting missing gf_log to gf_msg) posted (#1) for review on master by hari gowtham (hari.gowtham005@gmail.com)
Comment 2 Anand Avati 2015-08-24 01:59:17 EDT
REVIEW: http://review.gluster.org/11906 (performance translators : porting missing gf_log to gf_msg) posted (#2) for review on master by hari gowtham (hari.gowtham005@gmail.com)
Comment 3 Anand Avati 2015-08-24 02:22:39 EDT
REVIEW: http://review.gluster.org/11906 (performance translators : porting the missing gf_log to gf_msg) posted (#3) for review on master by hari gowtham (hari.gowtham005@gmail.com)
Comment 4 Anand Avati 2015-08-24 10:13:39 EDT
REVIEW: http://review.gluster.org/11906 (performance translators : porting the missing gf_log to gf_msg) posted (#4) for review on master by hari gowtham (hari.gowtham005@gmail.com)
Comment 5 Anand Avati 2015-08-28 09:27:50 EDT
REVIEW: http://review.gluster.org/11906 (performance translators : porting the missing gf_log to gf_msg) posted (#5) for review on master by hari gowtham (hari.gowtham005@gmail.com)
Comment 6 Anand Avati 2015-09-01 00:59:34 EDT
REVIEW: http://review.gluster.org/12069 (performance translators : porting the missing gf_log to gf_msg) posted (#1) for review on release-3.7 by hari gowtham (hari.gowtham005@gmail.com)
Comment 7 Niels de Vos 2016-06-16 09:31:51 EDT
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.8.0, please open a new bug report.

glusterfs-3.8.0 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] http://blog.gluster.org/2016/06/glusterfs-3-8-released/
[2] http://thread.gmane.org/gmane.comp.file-systems.gluster.user

Note You need to log in before you can comment on or make changes to this bug.