Bug 1258727 - performance translators: Pending - porting logging messages to new logging framework
performance translators: Pending - porting logging messages to new logging fr...
Status: CLOSED CURRENTRELEASE
Product: GlusterFS
Classification: Community
Component: logging (Show other bugs)
3.7.3
x86_64 Linux
high Severity high
: ---
: ---
Assigned To: hari gowtham
: EasyFix, Triaged
Depends On: 1242377
Blocks: 1241957 1253149 1260923
  Show dependency treegraph
 
Reported: 2015-09-01 02:38 EDT by hari gowtham
Modified: 2015-10-30 13:32 EDT (History)
7 users (show)

See Also:
Fixed In Version: glusterfs-3.7.5
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 1242377
Environment:
Last Closed: 2015-10-14 06:28:17 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description hari gowtham 2015-09-01 02:38:27 EDT
+++ This bug was initially created as a clone of Bug #1242377 +++

Description of problem:
-----------------------
There are few instances of 'gf_log' as seen under performance_xlators directory in the code base

Version-Release number of selected component (if applicable):
-------------------------------------------------------------
RHGS 3.1 ( glusterfs-3.7.1-8.el6rhs )

Expected results:
-----------------
All gf_log instances should be ported to new logging framework

gf_log instances
-----------------
io-cache/src/ioc-inode.c:   gf_log ("io-cache", GF_LOG_WARNING,
io-cache/src/ioc-inode.c-   "asprintf failed while converting ptr to str");
--
io-cache/src/ioc-inode.c:   gf_log (frame->this->name, GF_LOG_WARNING,
io-cache/src/ioc-inode.c-   "cache validate called without any "
--
io-cache/src/page.c:        gf_log (frame->this->name, GF_LOG_WARNING,
io-cache/src/page.c-         "wasted copy: %"PRId64"[+%"PRId64"] "
--
quick-read/src/quick-read.c:  gf_log ("quick-read", GF_LOG_INFO,
quick-read/src/quick-read.c-    "quick read inode table lru not empty");
--
read-ahead/src/read-ahead.c:  gf_log (this->name, GF_LOG_WARNING, "conf null in xlator");
read-ahead/src/read-ahead.c-   goto out;
--
read-ahead/src/read-ahead.c:  gf_log (this->name, GF_LOG_INFO,
read-ahead/src/read-ahead.c-  "undestroyed read ahead file structures found");
--
symlink-cache/src/symlink-cache.c: gf_log (this->name, GF_LOG_ERROR,
symlink-cache/src/symlink-cache.c-	"out of memory :(");
Comment 1 Anand Avati 2015-09-01 03:26:25 EDT
REVIEW: http://review.gluster.org/12073 (performance translators : port missing gf_log to gf_msg) posted (#2) for review on release-3.7 by hari gowtham (hari.gowtham005@gmail.com)
Comment 2 Anand Avati 2015-09-01 06:23:23 EDT
REVIEW: http://review.gluster.org/12073 (performance translators : port the missing gf_log to gf_msg) posted (#3) for review on release-3.7 by hari gowtham (hari.gowtham005@gmail.com)
Comment 3 Vijay Bellur 2015-09-03 07:10:38 EDT
REVIEW: http://review.gluster.org/12073 (performance translators : port the missing gf_log to gf_msg) posted (#6) for review on release-3.7 by hari gowtham (hari.gowtham005@gmail.com)
Comment 4 Vijay Bellur 2015-09-08 01:11:17 EDT
REVIEW: http://review.gluster.org/12073 (performance translators : port the missing gf_log to gf_msg) posted (#7) for review on release-3.7 by hari gowtham (hari.gowtham005@gmail.com)
Comment 6 Pranith Kumar K 2015-10-14 06:28:17 EDT
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-glusterfs-3.7.5, please open a new bug report.

glusterfs-glusterfs-3.7.5 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] http://www.gluster.org/pipermail/gluster-users/2015-October/023968.html
[2] http://thread.gmane.org/gmane.comp.file-systems.gluster.user
Comment 7 Pranith Kumar K 2015-10-14 06:37:44 EDT
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.7.5, please open a new bug report.

glusterfs-3.7.5 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] http://www.gluster.org/pipermail/gluster-users/2015-October/023968.html
[2] http://thread.gmane.org/gmane.comp.file-systems.gluster.user

Note You need to log in before you can comment on or make changes to this bug.