Bugzilla will be upgraded to version 5.0. The upgrade date is tentatively scheduled for 2 December 2018, pending final testing and feedback.
Bug 1253174 - [abrt] python3-dnf: output.py:947:_skipped_broken_deps:TypeError: unsupported operand type(s) for -=: 'set' and 'map'
[abrt] python3-dnf: output.py:947:_skipped_broken_deps:TypeError: unsupported...
Status: CLOSED DUPLICATE of bug 1252032
Product: Fedora
Classification: Fedora
Component: dnf (Show other bugs)
22
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: packaging-team-maint
Fedora Extras Quality Assurance
https://retrace.fedoraproject.org/faf...
abrt_hash:0f498fd3687cd52700fc5d522ec...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-08-13 03:51 EDT by roman
Modified: 2015-08-13 04:43 EDT (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-08-13 04:43:25 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: backtrace (1.28 KB, text/plain)
2015-08-13 03:51 EDT, roman
no flags Details
File: environ (3.02 KB, text/plain)
2015-08-13 03:51 EDT, roman
no flags Details

  None (edit)
Description roman 2015-08-13 03:51:34 EDT
Version-Release number of selected component:
python3-dnf-1.1.0-1.fc22

Additional info:
reporter:       libreport-2.6.2
cmdline:        /usr/bin/python3 -OO /usr/bin/dnf-3 upgrade --disablerepo russianfedora*
executable:     /usr/bin/dnf-3
kernel:         4.1.4-200.fc22.x86_64
runlevel:       N 5
type:           Python3
uid:            0

Truncated backtrace:
output.py:947:_skipped_broken_deps:TypeError: unsupported operand type(s) for -=: 'set' and 'map'

Traceback (most recent call last):
  File "/usr/bin/dnf-3", line 35, in <module>
    main.user_main(sys.argv[1:], exit_code=True)
  File "/usr/lib/python3.4/site-packages/dnf/cli/main.py", line 193, in user_main
    errcode = main(args)
  File "/usr/lib/python3.4/site-packages/dnf/cli/main.py", line 84, in main
    return _main(base, args)
  File "/usr/lib/python3.4/site-packages/dnf/cli/main.py", line 146, in _main
    ret = resolving(cli, base)
  File "/usr/lib/python3.4/site-packages/dnf/cli/main.py", line 168, in resolving
    base.do_transaction(display=displays)
  File "/usr/lib/python3.4/site-packages/dnf/cli/cli.py", line 165, in do_transaction
    pkg_str = self.output.list_transaction(trans)
  File "/usr/lib/python3.4/site-packages/dnf/cli/output.py", line 1024, in list_transaction
    for pkg in self._skipped_broken_deps(skipped_conflicts):
  File "/usr/lib/python3.4/site-packages/dnf/cli/output.py", line 947, in _skipped_broken_deps
    goal_diff -= skipped_conflicts
TypeError: unsupported operand type(s) for -=: 'set' and 'map'

Local variables in innermost frame:
goal_diff: set()
self: <dnf.cli.output.Output object at 0x7f5c6ce6dcc0>
skipped_conflicts: <map object at 0x7f5c6b896c88>

Potential duplicate: bug 1253044
Comment 1 roman 2015-08-13 03:51:44 EDT
Created attachment 1062369 [details]
File: backtrace
Comment 2 roman 2015-08-13 03:51:47 EDT
Created attachment 1062370 [details]
File: environ
Comment 3 Honza Silhan 2015-08-13 04:43:25 EDT

*** This bug has been marked as a duplicate of bug 1252032 ***

Note You need to log in before you can comment on or make changes to this bug.