Bug 125335 - RFE: make it so that mails from bugzilla thread
RFE: make it so that mails from bugzilla thread
Status: CLOSED CURRENTRELEASE
Product: Bugzilla
Classification: Community
Component: Bugzilla General (Show other bugs)
2.17
All Linux
medium Severity medium (vote)
: ---
: ---
Assigned To: David Lawrence
David Lawrence
: FutureFeature
: 98917 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-06-04 16:10 EDT by Jeremy Katz
Modified: 2007-04-18 13:08 EDT (History)
1 user (show)

See Also:
Fixed In Version: 2.17.1
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-06-04 16:50:30 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jeremy Katz 2004-06-04 16:10:11 EDT
When dealing with lots of bug mail, it would be nice if the mail got
threaded to make it easier to deal with all of the mail from one bug
report at a time.

Threading generally keys off of either the In-Reply-To or the
References header.  These reference a Message-Id.

15.50.34 <jeremy> dkl: real threading requires saving message-ids and
doing In-Reply-To or References
15.51.23 <jeremy> jlaska: not really, it's just to make it easier to
go through
100 bug spam at a time since I'd batch up each bug
15.51.33 <jeremy> dkl: which I'd imagine is a bit prohibitive to
actually do
15.52.13 <dkl> jeremy, what if the message id incorporated the bug
number somehow?
15.56.28 <jeremy> dkl: I think the message-id is usually assigned by
the mta, though -- you might be able to do them yourself, though. 
something like Message-Id: bug#.mail#@bugzilla.redhat.com and then you
could always have References: bug#.1@bugzilla.redhat.com in later mails
15.58.45 <jeremy> looking at the sendmail docs, it looks like sendmail
won't add a new Message-Id header if one already exists
(http://www.busan.edu/~nic/networking/sendmail/ch35_10.htm#SML2-CH-35-SECT-10-19)
16.01.12 <jeremy> so it at least looks theoretically possible -- want
me to file a bug?


And further investigation, Ximian's bugzilla already does something
similar but they just add an "In-Reply-To: <bug-bug#@hostname>" header
to all of the mails for a particular bug.  This is enough to get
clients that are smart enough (most) to recognize that the mails
should be grouped and you get a thread out of it.  This would be good
enough for me and a far simpler solution.
Comment 1 David Lawrence 2004-06-04 16:32:07 EDT
Added to each email:

In-Reply-To: bugzilla-%bugid%@redhat.com 

Let's see if it works.
Comment 2 David Lawrence 2004-06-04 16:32:40 EDT
Followup comment to see if the email threads properly.
Comment 3 David Lawrence 2004-06-04 16:41:25 EDT
Changed to:

In-Reply-To: <bugzilla-%bugid%@redhat.com>
Comment 4 Mark McLoughlin 2004-06-05 07:16:36 EDT
*** Bug 98917 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.