Bug 1253376 - Foreman task view does not respect user timezone
Summary: Foreman task view does not respect user timezone
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Satellite
Classification: Red Hat
Component: Tasks Plugin
Version: Nightly
Hardware: Unspecified
OS: Unspecified
unspecified
medium vote
Target Milestone: Unspecified
Assignee: Ohad Levy
QA Contact: Jitendra Yejare
URL: http://projects.theforeman.org/issues...
Whiteboard: Verified in Upstream
: 1336103 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2015-08-13 15:10 UTC by Walden Raines
Modified: 2019-11-14 06:52 UTC (History)
10 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-07-27 09:17:43 UTC
Target Upstream Version:


Attachments (Terms of Use)
Verified Screenshot of USer Time on Task page (201.72 KB, image/png)
2015-09-01 07:21 UTC, Jitendra Yejare
no flags Details


Links
System ID Priority Status Summary Last Updated
Red Hat Bugzilla 1315248 'medium' 'CLOSED' '[RFE] task export to convert times from UTC to local time zone' 2019-11-19 08:15:39 UTC
Red Hat Knowledge Base (Solution) 1753953 None None None Never
Red Hat Product Errata RHBA-2016:1501 normal SHIPPED_LIVE Red Hat Satellite 6.2 Capsule and Server 2016-07-27 12:28:58 UTC

Internal Links: 1315248

Description Walden Raines 2015-08-13 15:10:34 UTC
In the foreman task view the time of the task is shown always in UTC.  It should be converted to the user's timezone.

This issue may exist elsewhere but was observed on the tasks page.

h3. Steps to Reproduce

# Go to the user settings page and set the timezone to something other than UTC
# Go to the tasks page
# Note the time is displayed in UTC

Comment 1 Walden Raines 2015-08-13 15:10:35 UTC
Created from redmine issue http://projects.theforeman.org/issues/11344

Comment 3 Bryan Kearney 2015-08-25 18:36:14 UTC
Upstream bug component is Tasks Plugin

Comment 4 Bryan Kearney 2015-08-28 16:04:05 UTC
Moving to POST since upstream bug http://projects.theforeman.org/issues/11344 has been closed
-------------
Shlomi Zadok
Applied in changeset commit:2fdc08e53eda5642daac2a597838f9b38b1806db.

Comment 5 Jitendra Yejare 2015-09-01 07:19:51 UTC
Verified this BZ with Upstream build:
The time in Tasks Page is displayed according to User timezone set in User settings at not as per UTC. 
I verified this by setting the timezone to IST.


with versions:
foreman-proxy-1.10.0-0.develop.201508250705gitb446e0c.el7.noarch
foreman-release-1.10.0-0.develop.201508241946git8658fa3.el7.noarch
foreman-compute-1.10.0-0.develop.201508241946git8658fa3.el7.noarch
foreman-gce-1.10.0-0.develop.201508241946git8658fa3.el7.noarch
foreman-1.10.0-0.develop.201508241946git8658fa3.el7.noarch

The screenshot of proof has been attached.
So,mMoving this BZ state to Verified.

Comment 6 Jitendra Yejare 2015-09-01 07:21:04 UTC
Created attachment 1068869 [details]
Verified Screenshot of USer Time on Task page

Comment 8 Pavel Moravec 2016-06-16 06:23:11 UTC
Does it mean that with this fix, task export will have timestamps in local timezone and not in UTC?

If so, bz1315248 could be closed as DUP.

Comment 9 Ohad Levy 2016-06-16 07:21:35 UTC
No - I don't believe so as this patch only address the browser view.

Comment 11 errata-xmlrpc 2016-07-27 09:17:43 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2016:1501

Comment 12 Adam Ruzicka 2016-10-18 08:01:21 UTC
*** Bug 1336103 has been marked as a duplicate of this bug. ***


Note You need to log in before you can comment on or make changes to this bug.