Bug 1253496 - Cannot move windows after typing in into the administration console of cssh (clusterssh)
Cannot move windows after typing in into the administration console of cssh (...
Status: CLOSED DUPLICATE of bug 1254254
Product: Fedora
Classification: Fedora
Component: clusterssh (Show other bugs)
22
Unspecified Unspecified
unspecified Severity high
: ---
: ---
Assigned To: Filipe Rosset
Fedora Extras Quality Assurance
: Regression
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-08-13 16:36 EDT by Brandon Perkins
Modified: 2015-11-06 14:19 EST (History)
9 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-11-06 14:19:54 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
STDOUT and STDERR from running "kwin_x11 --replace" while performing cssh tasks. (7.07 KB, text/plain)
2015-08-13 16:36 EDT, Brandon Perkins
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
KDE Software Compilation 348569 None None None Never

  None (edit)
Description Brandon Perkins 2015-08-13 16:36:30 EDT
Created attachment 1062813 [details]
STDOUT and STDERR from running "kwin_x11 --replace" while performing cssh tasks.

Description of problem:
Cannot move windows after typing in into the administration console of cssh (clusterssh)

Version-Release number of selected component (if applicable):
kwin-5.3.2-1.fc22.x86_64
clusterssh-4.02.03-2.fc21.noarch


How reproducible:
Always.


Steps to Reproduce:
1. # dnf -y install @kde kdm clusterssh
2. # useradd testuser
3. # echo testpass | passwd --stdin testuser
4. # systemctl start kdm
5. Login as testuser with testpass
6. Launch a terminal
7. $ kwin_x11 --replace &
8. $ cssh localhost &
9. Click in the text entry field of the administration console of cssh
10. Verify you can still move windows
11. Click in the text entry field of the administration console of cssh again, then type a single character (likely, first character of the testuser password)

Actual results:
Windows can no longer be moved

Expected results:
Windows can continue to be moved

Additional info:
Log attached.
Comment 1 Brandon Perkins 2015-08-13 16:45:42 EDT
Note, lines 1-74 of the attachment are displayed before starting cssh (step 7).

Lines 75-92 are the results of just running cssh (step 8).

Steps 9-11 do NOT result in any messages.

Lines 93-99 are the result of trying to move a window (actual results).
Comment 2 fredi 2015-10-01 10:52:27 EDT
I have reported this as a konsole bug first, but today i found that it was reported even earlier, and the most complete thread is this bug against kwin in the KDE bugtracker:

https://bugs.kde.org/show_bug.cgi?id=348569

Hope this helps, i'm leaving the decision to mark as duplicate or not to the mantainer.
Comment 4 Brandon Perkins 2015-11-06 13:23:51 EST
FYI... the issue is still present in F23:

kwin-5.4.2-3.fc23.x86_64
clusterssh-4.02.03-3.fc23.noarch

I was hopeful it would be fixed in this release as a lot of other issues I had in F22 were resolved, but sadly, it's still with us.
Comment 5 Rex Dieter 2015-11-06 13:29:28 EST
Per
https://bugs.kde.org/show_bug.cgi?id=348569#c10
and
https://sourceforge.net/p/clusterssh/bugs/35/

reassigning to clusterssh

though kwin *may* have a workaround,
https://bugs.kde.org/show_bug.cgi?id=348569#c7
Comment 6 Rex Dieter 2015-11-06 14:19:54 EST
let'd dup bug #1254254 , the same issue really

*** This bug has been marked as a duplicate of bug 1254254 ***

Note You need to log in before you can comment on or make changes to this bug.