Bug 1254254 - Compattibilty problems betwen konsole/kwin and clusterssh
Compattibilty problems betwen konsole/kwin and clusterssh
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: clusterssh (Show other bugs)
22
x86_64 Linux
unspecified Severity unspecified
: ---
: ---
Assigned To: Mark Chappell
Fedora Extras Quality Assurance
https://github.com/duncs/clusterssh/i...
: Patch, Triaged
: 1253496 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-08-17 09:59 EDT by fredi
Modified: 2016-01-14 04:50 EST (History)
14 users (show)

See Also:
Fixed In Version: clusterssh-4.05-1.fc23 clusterssh-4.05-1.fc22
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-01-14 03:55:13 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
0001-Remove-time-key-from-the-event-hash.patch (1.16 KB, patch)
2015-11-06 16:29 EST, Brandon Perkins
no flags Details | Diff


External Trackers
Tracker ID Priority Status Summary Last Updated
KDE Software Compilation 348569 None None None Never
KDE Software Compilation 351490 None None None Never
Qt Bug Tracker QTBUG-28398 None None None Never

  None (edit)
Description fredi 2015-08-17 09:59:30 EDT
Description of problem:

Keeping konsole open, launching clusterssh with a cluster (so it opens some xterms) -> here Alt+Tab stops working.

Version-Release number of selected component (if applicable):

I'm using Fedora 22 Workstation with kde, versions:

Fedora release 22 (Twenty Two)

Konsole
Version 15.04.0
Using KDE Frameworks 5.12.0

Clusterssh version:

Name        : clusterssh
Arch        : noarch
Epoch       : 0
Version     : 4.02.03
Release     : 2.fc21
Size        : 229 k
Repo        : @System
Summary     : Secure concurrent multiple server terminal control
URL         : http://clusterssh.sourceforge.net
License     : GPLv2+
Description : Control multiple terminals open on different servers to perform administration
            : tasks, for example multiple hosts requiring the same configuration within a
            : cluster. Not limited to use with clusters, however.


How reproducible:


Steps to Reproduce:

Keeping konsole open, launching clusterssh with a cluster (so it opens some xterms) -> here Alt+Tab stops working.
Copying and pasting from one of the xterms -> here copy and paste in konsole and other kde applications stops working.

Actual results:

Alt+TAB and copy & paste in KDE apps stops working,


Expected results:

Shortcuts and C&P should work

Additional info:

I'm using Fedora 22 Workstation with kde, versions:

Fedora release 22 (Twenty Two)

Konsole
Version 15.04.0
Using KDE Frameworks 5.12.0

Clusterssh version:

Name        : clusterssh
Arch        : noarch
Epoch       : 0
Version     : 4.02.03
Release     : 2.fc21
Size        : 229 k
Repo        : @System
Summary     : Secure concurrent multiple server terminal control
URL         : http://clusterssh.sourceforge.net
License     : GPLv2+
Description : Control multiple terminals open on different servers to perform administration
            : tasks, for example multiple hosts requiring the same configuration within a
            : cluster. Not limited to use with clusters, however.

Steps to reproduce:

Keeping konsole open, launching clusterssh with a cluster (so it opens some xterms) -> here Alt+Tab stops working.
Copying and pasting from one of the xterms -> here copy and paste in konsole and other kde applications stops working.

Alt+Tab starts working after a:

kwin --replace 

but copy and paste do not work till another logout / login.

This happens at randoom even without clusterssh, but that's the easiest way for me to 100% reproduce this bug, keeping konsole open, starting clusterssh, opening a cluster and copying pasting from the cssh launched xterms.


In the xsession-error.log, when C&P does not work i see:

QXcbClipboard::setMimeData: Cannot set X11 selection owner
QXcbClipboard::setMimeData: Cannot set X11 selection owner
QXcbClipboard::setMimeData: Cannot set X11 selection owner

Googling i found around some bug reports with that same report but all seems to point to a bug fixed in QT/KDE, links:

https://bugreports.qt.io/browse/QTBUG-28398
https://bugs.launchpad.net/ubuntu/+source/qt4-x11/+bug/479740
https://bugs.gentoo.org/show_bug.cgi?id=276527
http://comments.gmane.org/gmane.network.vnc.tigervnc.user/631


I have a strace of clusterssh when this happens if it's needed, just ask as it's a bit long.

Related software versions:

$ rpm -qa | egrep '^(qt|kde|clusterssh)' | sort 
clusterssh-4.02.03-2.fc21.noarch
kde-baseapps-15.04.2-1.fc22.x86_64
kde-baseapps-common-15.04.2-1.fc22.noarch
kde-baseapps-libs-15.04.2-1.fc22.x86_64
kde-cli-tools-5.3.2-1.fc22.x86_64
kdecoration-5.3.2-1.fc22.x86_64
kde-filesystem-4-51.fc22.x86_64
kdegames-minimal-4.14.3-1.fc22.noarch
kdegraphics-strigi-analyzer-15.04.0-1.fc22.x86_64
kdegraphics-thumbnailers-15.04.0-1.fc22.x86_64
kde-l10n-14.12.3-7.fc22.noarch
kdelibs3-3.5.10-68.fc22.x86_64
kdelibs-4.14.9-2.fc22.x86_64
kdelibs-common-4.14.9-2.fc22.x86_64
kdelibs-ktexteditor-4.14.9-2.fc22.x86_64
kdelibs-webkit-4.14.9-2.fc22.x86_64
kdenetwork-common-4.14.3-1.fc22.noarch
kdepasswd-15.04.2-1.fc22.x86_64
kdepim-common-4.14.9-1.fc22.x86_64
kdepim-libs-4.14.9-1.fc22.x86_64
kdepimlibs-4.14.9-1.fc22.x86_64
kdepimlibs-akonadi-4.14.9-1.fc22.x86_64
kdepimlibs-gpgme-4.14.9-1.fc22.x86_64
kdepimlibs-kxmlrpcclient-4.14.9-1.fc22.x86_64
kdepim-runtime-4.14.9-1.fc22.x86_64
kdepim-runtime-libs-4.14.9-1.fc22.x86_64
kde-plasma-activitymanager-debuginfo-0.5-6.fc20.x86_64
kdeplasma-addons-5.3.2-1.fc22.x86_64
kdeplasma-addons-debuginfo-4.14.3-3.fc20.x86_64
kde-plasma-akonadi-calendars-debuginfo-0.2.2-3.fc20.x86_64
kde-plasma-akonadi-contacts-debuginfo-0.1.7-5.fc20.x86_64
kde-plasma-akonadi-tasks-debuginfo-0.1.3-3.fc20.x86_64
kde-plasma-daisy-debuginfo-0.0.4.26-3.fc20.x86_64
kde-plasma-ihatethecashew-debuginfo-0.4-7.fc20.x86_64
kde-plasma-nm-debuginfo-0.9.3.6-1.fc20.x86_64
kde-plasma-publictransport-debuginfo-0.10-0.9.20111204git.fc20.x86_64
kde-plasma-quickaccess-debuginfo-0.8.1-9.fc20.x86_64
kde-plasma-runcommand-debuginfo-2.4-4.fc20.x86_64
kde-plasma-smooth-tasks-debuginfo-0.0.1-0.9.20120313hge8a97edfdebc.fc20.x86_64
kde-plasma-translatoid-debuginfo-1.30-10.svn01092011.fc20.x86_64
kde-plasma-yawp-debuginfo-0.4.5-2.fc20.x86_64
kde-print-manager-15.03.95-2.fc22.x86_64
kde-print-manager-libs-15.03.95-2.fc22.x86_64
kde-runtime-15.04.2-1.fc22.x86_64
kde-runtime-drkonqi-15.04.2-1.fc22.x86_64
kde-runtime-flags-15.04.2-1.fc22.noarch
kde-runtime-libs-15.04.2-1.fc22.x86_64
kde-settings-22-11.fc22.noarch
kde-settings-kdm-22-11.fc22.noarch
kde-settings-ksplash-22-11.fc22.noarch
kde-settings-plasma-22-11.fc22.noarch
kde-settings-pulseaudio-22-11.fc22.noarch
kde-style-breeze-5.3.2-1.fc22.x86_64
kdesu-5.3.2-1.fc22.x86_64
kdevelop-4.7.1-1.fc22.x86_64
kdevelop-libs-4.7.1-1.fc22.x86_64
kdevplatform-1.7.1-1.fc22.x86_64
kdevplatform-libs-1.7.1-1.fc22.x86_64
kdewebdev-3.5.10-23.fc22.x86_64
kdewebdev-libs-3.5.10-23.fc22.x86_64
kde-workspace-common-4.11.20-2.fc22.noarch
qt3-3.3.8b-64.fc22.x86_64
qt-4.8.6-30.fc22.i686
qt-4.8.6-30.fc22.x86_64
qt4-style-oxygen-5.3.2-1.fc22.x86_64
qt5-qtbase-5.4.2-2.fc22.x86_64
qt5-qtbase-common-5.4.2-2.fc22.noarch
qt5-qtbase-gui-5.4.2-2.fc22.x86_64
qt5-qtdeclarative-5.4.2-2.fc22.x86_64
qt5-qtgraphicaleffects-5.4.2-1.fc22.x86_64
qt5-qtlocation-5.4.2-1.fc22.x86_64
qt5-qtmultimedia-5.4.2-1.fc22.x86_64
qt5-qtquickcontrols-5.4.2-1.fc22.x86_64
qt5-qtscript-5.4.2-1.fc22.x86_64
qt5-qtsensors-5.4.2-1.fc22.x86_64
qt5-qtsvg-5.4.2-1.fc22.x86_64
qt5-qttools-5.4.2-3.fc22.x86_64
qt5-qttools-common-5.4.2-3.fc22.noarch
qt5-qttools-libs-designer-5.4.2-3.fc22.x86_64
qt5-qtwebkit-5.4.2-1.fc22.x86_64
qt5-qtx11extras-5.4.2-1.fc22.x86_64
qt5-qtxmlpatterns-5.4.2-1.fc22.x86_64
qt-common-4.8.6-30.fc22.noarch
qt-devel-4.8.6-30.fc22.x86_64
qt-gstreamer-1.2.0-3.fc22.x86_64
qtlockedfile-2.4-18.20150629git5a07df5.fc22.x86_64
qt-mobility-1.2.2-0.17.20140317git169da60c.fc22.i686
qt-mobility-1.2.2-0.17.20140317git169da60c.fc22.x86_64
qt-mobility-bearer-1.2.2-0.17.20140317git169da60c.fc22.i686
qt-mobility-bearer-1.2.2-0.17.20140317git169da60c.fc22.x86_64
qt-mobility-common-1.2.2-0.17.20140317git169da60c.fc22.i686
qt-mobility-common-1.2.2-0.17.20140317git169da60c.fc22.x86_64
qt-mobility-connectivity-1.2.2-0.17.20140317git169da60c.fc22.i686
qt-mobility-connectivity-1.2.2-0.17.20140317git169da60c.fc22.x86_64
qt-mobility-feedback-1.2.2-0.17.20140317git169da60c.fc22.i686
qt-mobility-feedback-1.2.2-0.17.20140317git169da60c.fc22.x86_64
qt-mobility-gallery-1.2.2-0.17.20140317git169da60c.fc22.i686
qt-mobility-gallery-1.2.2-0.17.20140317git169da60c.fc22.x86_64
qt-mobility-location-1.2.2-0.17.20140317git169da60c.fc22.i686
qt-mobility-location-1.2.2-0.17.20140317git169da60c.fc22.x86_64
qt-mobility-multimediakit-1.2.2-0.17.20140317git169da60c.fc22.i686
qt-mobility-multimediakit-1.2.2-0.17.20140317git169da60c.fc22.x86_64
qt-mobility-pim-1.2.2-0.17.20140317git169da60c.fc22.i686
qt-mobility-pim-1.2.2-0.17.20140317git169da60c.fc22.x86_64
qt-mobility-publishsubscribe-1.2.2-0.17.20140317git169da60c.fc22.i686
qt-mobility-publishsubscribe-1.2.2-0.17.20140317git169da60c.fc22.x86_64
qt-mobility-sensors-1.2.2-0.17.20140317git169da60c.fc22.i686
qt-mobility-sensors-1.2.2-0.17.20140317git169da60c.fc22.x86_64
qt-mobility-serviceframework-1.2.2-0.17.20140317git169da60c.fc22.i686
qt-mobility-serviceframework-1.2.2-0.17.20140317git169da60c.fc22.x86_64
qt-mobility-systeminfo-1.2.2-0.17.20140317git169da60c.fc22.i686
qt-mobility-systeminfo-1.2.2-0.17.20140317git169da60c.fc22.x86_64
qt-mysql-4.8.6-30.fc22.x86_64
qt-qdbusviewer-4.8.6-30.fc22.x86_64
qtscriptbindings-0.2.0-8.fc22.x86_64
qt-settings-22-11.fc22.noarch
qtsingleapplication-2.6.1-23.fc22.x86_64
qtsoap-2.7-9.fc22.x86_64
qtwebkit-2.3.4-6.fc22.i686
qtwebkit-2.3.4-6.fc22.x86_64
qtwebkit-devel-2.3.4-6.fc22.x86_64
qt-x11-4.8.6-30.fc22.i686
qt-x11-4.8.6-30.fc22.x86_64
$

Any ideas? Is this the right place to report it? Any other debug info i can provide? This is really annoying ... 


Thanks in advance,
Frederik
Comment 1 fredi 2015-09-04 08:14:34 EDT
As of today i got the updates for konsole5 and konsole5-part. The changelog was very interesting to me:

$ rpm -qa konsole5
konsole5-15.04.3-2.fc22.1.x86_64
$ rpm -q --changelog konsole5
* Sun Aug 16 2015 Rex Dieter <rdieter@fedoraproject.org> 15.04.3-2.1
- respin (f22)

* Sat Aug 15 2015 Rex Dieter <rdieter@fedoraproject.org> - 15.04.3-2
- fix 'konsole --version' to match reality
- backport copy-n-paste fixes (#1235024)

Looking at the fixed bug:

https://bugzilla.redhat.com/show_bug.cgi?id=1235024

as it has to do with copy and paste, just checked if this isssue was fixed. Unfortunately not though.
Comment 2 Rex Dieter 2015-10-01 08:28:26 EDT
I suspect this has more to do with kwin than konsole, re-assigning
Comment 3 fredi 2015-10-01 08:37:43 EDT
Seems we were commenting on the same time (I was posting the same info i posted on the KDE bug tracker, so not that important)

First thanks for your comment.

I was about to open a bug to kwin too after updating this bug, for now I'll leave it for not spamming.

Or should I open a bug on kwin anyway?


Thanks!
Comment 4 Rex Dieter 2015-10-01 08:39:04 EDT
We're ok here downstream in fedora, but opening another for kwin @ bugs.kde.org would probably be a good idea, yes.
Comment 5 fredi 2015-10-01 10:37:10 EDT
While searching for kwin bugs before opening a new one, i found the same problem i have reported here:

https://bugs.kde.org/show_bug.cgi?id=348569

So definitely not a konsole bug.
Comment 6 Rex Dieter 2015-10-01 11:32:30 EDT
Per 
https://bugs.kde.org/show_bug.cgi?id=348569#c12

"No.
clusterssh somehow screws event times - i haven't checked whether our grab request is dropped inside xcb or actually rejected by the x11 server, but because of the "patch" to simply use the events arrival queue instead of the current server time, it sounds as if clusterssh passes some future timestamp to some mouse event.

This behavior *also* breaks the selection buffer (unrelated to kwin, which has no play in that system)

Since chromium -> konsole seems unaffected, it'll rather be an optimization drop in xcb ("i know some newer event has been  passed"

=> I bet your right arm on this being a bug in clusterssh, exposed by xcb."


Re-assigning to clusterssh, hopefully between you (reporter, clusterssh maintainer) you can poke clusterssh upstream to make them aware of the issue
Comment 7 fredi 2015-10-01 11:42:34 EDT
Yes, i noticed that, but i'm not convinced the bug is only at clusterssh side.

Even if it's so, kwin (or qt / xcb) IMHO should be more robust, like the other window managers.

But anyway, right now im going to patch kwin as per that bug report and rebuild the rpm. 

Then I'll report on how it goes.

Anywaw, thanks Rex!
Comment 8 Rex Dieter 2015-11-06 14:19:54 EST
*** Bug 1253496 has been marked as a duplicate of this bug. ***
Comment 9 Brandon Perkins 2015-11-06 16:29 EST
Created attachment 1090798 [details]
0001-Remove-time-key-from-the-event-hash.patch

Patch that removes the two time keys that are used in the event hashes.  Functionality does not seem to be impacted, and the behaviour described in the bug seems to no longer occur.
Comment 10 Brandon Perkins 2015-11-06 16:31:08 EST
I should also point out that I tested this both on the upstream release-4.02_03 tag, as well as master.  I did not submit it to upstream at this time.
Comment 11 Brandon Perkins 2015-11-09 14:09:02 EST
Submitted my patch as an upstream issue: https://github.com/duncs/clusterssh/issues/46
Comment 12 Rex Dieter 2015-12-23 10:38:02 EST
Ping, clusterssh maintainer(s), can you please upgrade or include the patch in fedora's packaging?

Consider this ping 1 per
https://fedoraproject.org/wiki/Policy_for_nonresponsive_package_maintainers

I'll check back in no less than 2 weeks (considering the holidays).
Comment 13 fredi 2015-12-23 11:21:05 EST
Just a "me too",
i cant reproduce anymore the problems i had with the latest clusterssh version installed (4.05 but from the changelog the bug is fixed at version 4.04 if it matters).


@Brandon Perkins / @Rex Dieter -  a big thank you!
Comment 14 Mark Chappell 2015-12-28 04:50:04 EST
Looking at an update now.
Comment 15 Mark Chappell 2015-12-28 09:07:02 EST
Brandon/Rex/Fredi

I've updated done some scratch builds :

http://koji.fedoraproject.org/koji/taskinfo?taskID=12330198  (F23)
http://koji.fedoraproject.org/koji/taskinfo?taskID=12330336  (F22)

I don't have a recent Fedora install available to me at the minute (most of my work's done on RHEL) and I'm a Gnome user rather than KDE

If possible could you test this latest version out for me?
Comment 16 fredi 2015-12-31 07:00:23 EST
Hi Mark, seems i cant download the build, maybe i'm missing something?
Comment 18 fredi 2015-12-31 07:27:57 EST
Hi Mark,

i can confirm it works perfectly, thanks!
Comment 19 Fedora Update System 2016-01-02 12:51:12 EST
clusterssh-4.05-1.fc22 has been submitted as an update to Fedora 22. https://bodhi.fedoraproject.org/updates/FEDORA-2016-bcbc472b3b
Comment 20 Mark Chappell 2016-01-02 12:54:00 EST
Hey guys,

Just submitted an update.  Testing under KDE would be appreciated.
Comment 21 Fedora Update System 2016-01-02 22:21:40 EST
clusterssh-4.05-1.fc22 has been pushed to the Fedora 22 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2016-bcbc472b3b
Comment 22 Fedora Update System 2016-01-02 22:22:51 EST
clusterssh-4.05-1.fc23 has been pushed to the Fedora 23 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2016-e2a3defcd9
Comment 23 fredi 2016-01-07 06:47:58 EST
@Mark Chappell, reinstalled the package from updates-testing in my Fedora 23, here are the package details:

Name        : clusterssh
Arch        : noarch
Epoch       : 0
Version     : 4.05
Release     : 1.fc23
Size        : 375 k
Repo        : @System
From repo   : updates-testing
Buildtime   : Thu Dec 31 14:49:36 2015
Install tim : Thu Jan  7 12:44:42 2016
Summary     : Secure concurrent multiple server terminal control
URL         : http://clusterssh.sourceforge.net
License     : GPL+ or Artistic
Description : Control multiple terminals open on different servers to perform administration
            : tasks, for example multiple hosts requiring the same configuration within a
            : cluster. Not limited to use with clusters, however.



It works perfectly, thanks!
Comment 24 Fedora Update System 2016-01-14 03:55:07 EST
clusterssh-4.05-1.fc23 has been pushed to the Fedora 23 stable repository. If problems still persist, please make note of it in this bug report.
Comment 25 Fedora Update System 2016-01-14 04:50:07 EST
clusterssh-4.05-1.fc22 has been pushed to the Fedora 22 stable repository. If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.