Bug 1253616 - Illegal instruction in __floorf_sse41 () at ../sysdeps/x86_64/fpu/multiarch/s_floorf.S:37
Illegal instruction in __floorf_sse41 () at ../sysdeps/x86_64/fpu/multiarch/s...
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: glibc (Show other bugs)
rawhide
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Carlos O'Donell
Fedora Extras Quality Assurance
:
: 1254173 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-08-14 05:20 EDT by Yanko Kaneti
Modified: 2016-11-24 07:19 EST (History)
9 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-08-17 02:42:46 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Yanko Kaneti 2015-08-14 05:20:05 EDT
Description of problem:
$ evince http://www.avalpa.com/assets/freesoft/opencaster/AvalpaBroadcastServerUserManual-v3.0.pdf
Illegal instruction (core dumped)


Program received signal SIGILL, Illegal instruction.
__floorf_sse41 () at ../sysdeps/x86_64/fpu/multiarch/s_floorf.S:37
37		roundss	$1, %xmm0, %xmm0
(gdb) bt
#0  0x00007ffff4529610 in __floorf_sse41 () at ../sysdeps/x86_64/fpu/multiarch/s_floorf.S:37
#1  0x00007ffff65ede1a in get_layout_location (label=label@entry=0x555555a20550 [GtkLabel], xp=xp@entry=0x7fffffffbea8, yp=yp@entry=0x7fffffffbeac) at gtklabel.c:3978
.....


Version-Release number of selected component (if applicable):
glibc-2.22.90-1.fc24.x86_64

How reproducible:
Always

cpuinfo, one of 6 cores

$ cat /proc/cpuinfo 
processor	: 0
vendor_id	: AuthenticAMD
cpu family	: 16
model		: 10
model name	: AMD Phenom(tm) II X6 1045T Processor
stepping	: 0
microcode	: 0x10000dc
cpu MHz		: 800.000
cache size	: 512 KB
physical id	: 0
siblings	: 6
core id		: 0
cpu cores	: 6
apicid		: 0
initial apicid	: 0
fpu		: yes
fpu_exception	: yes
cpuid level	: 6
wp		: yes
flags		: fpu vme de pse tsc msr pae mce cx8 apic sep mtrr pge mca cmov pat pse36 clflush mmx fxsr sse sse2 ht syscall nx mmxext fxsr_opt pdpe1gb rdtscp lm 3dnowext 3dnow constant_tsc rep_good nopl nonstop_tsc extd_apicid aperfmperf pni monitor cx16 popcnt lahf_lm cmp_legacy svm extapic cr8_legacy abm sse4a misalignsse 3dnowprefetch osvw ibs skinit wdt cpb hw_pstate npt lbrv svm_lock nrip_save pausefilter vmmcall
bugs		: tlb_mmatch fxsave_leak sysret_ss_attrs
bogomips	: 5425.12
TLB size	: 1024 4K pages
clflush size	: 64
cache_alignment	: 64
address sizes	: 48 bits physical, 48 bits virtual
power management: ts ttp tm stc 100mhzsteps hwpstate cpb
Comment 1 Siddhesh Poyarekar 2015-08-14 05:33:20 EDT
Can you check if F23 (i.e. glibc-2.22-1.fc23) shows this problem too?  That'll help me bisect the problem.
Comment 2 Yanko Kaneti 2015-08-14 05:41:49 EDT
It works OK with glibc-2.22-1.fc23.x86_64 and glibc-2.21.90-20.fc24.x86_64
Comment 3 Siddhesh Poyarekar 2015-08-14 06:39:29 EDT
OK, I think I know the problem:

https://sourceware.org/ml/libc-alpha/2015-08/msg00554.html

I've got a scratch build in progress:

http://koji.fedoraproject.org/koji/taskinfo?taskID=10702811

I'll push a new build once you confirm that the test build above works.
Comment 4 Yanko Kaneti 2015-08-14 09:18:42 EDT
Yep, the scratch build works.
Thanks.
Comment 5 Yanko Kaneti 2015-08-17 02:42:46 EDT
glibc-2.22.90-3.fc24 works here
Closing.
Comment 6 Siddhesh Poyarekar 2015-08-17 03:09:11 EDT
Thanks.
Comment 7 poma 2015-08-17 10:06:32 EDT
*** Bug 1254173 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.