Bug 1253694 - Fail to edit Host Settings
Fail to edit Host Settings
Status: CLOSED CURRENTRELEASE
Product: oVirt
Classification: Community
Component: ovirt-engine-webadmin (Show other bugs)
3.6
All Linux
high Severity medium
: ---
: 3.6.0
Assigned To: Alexander Wels
Lukas Svaty
infra
: Regression
Depends On:
Blocks: 1155425
  Show dependency treegraph
 
Reported: 2015-08-14 09:15 EDT by Amador Pahim
Modified: 2016-02-10 14:34 EST (History)
10 users (show)

See Also:
Fixed In Version: 3.6.0-10
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-11-04 08:50:22 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: Infra
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Amador Pahim 2015-08-14 09:15:57 EDT
Description of problem:

Not able to edit host settings (i.e. power management settings).

Version-Release number of selected component (if applicable):

ovirt-engine-3.6.0-0.0.master.20150804111546.git122a3a0.el7.centos.noarch


How reproducible:

100%

Steps to Reproduce:
1. Select Host
2. Click "Edit"
3. Click "Ok"

Actual results:

"Use Foreman/Satellite" comes unchecked but expanded as if it was checked, requiring "Host Groups"/"Compute Resources" to be set. Checking and then unchecking "Use Foreman/Satellite" will hide "Host Groups"/"Compute Resources" but also will clean host "Name" (editable) and "Address" (non-editable). So we are not able to click in "Ok".

Expected results:

Edit Host working.
Comment 1 Einav Cohen 2015-08-17 08:51:21 EDT
Alexander, related to / duplicate of bug 1251937?
Comment 2 Alexander Wels 2015-08-17 09:07:05 EDT
I think its a duplicate of 1251937
Comment 3 Amador Pahim 2015-08-17 10:58:51 EDT
Issue not present in ovirt-engine-3.6.0-0.0.master.20150811152525.git5823dda.el7.centos.noarch
Comment 4 Einav Cohen 2015-08-17 11:21:23 EDT
(In reply to Amador Pahim from comment #3)
> Issue not present in
> ovirt-engine-3.6.0-0.0.master.20150811152525.git5823dda.el7.centos.noarch

strange, as the fix for bug 1251937 [1] was merged to 'ovirt-engine-3.6' only after "3.6.0-0.0.master.20150811152525.git5823dda.el7.centos.noarch" [2]. 
maybe was a different issue, that was resolved in a patch earlier than [1]?

[moving BZ to MODIFIED, as issue is not reproducible anymore]

[1] https://gerrit.ovirt.org/#/c/44691/ ['ovirt-engine-3.6' fix merged Aug 12]

[2] "3.6.0-0.0.master.20150811152525.git5823dda.el7.centos.noarch" is based on git hash "5823dda", which is https://gerrit.ovirt.org/#/c/44664/, which was merged Aug 11, before [1] was merged.
Comment 5 Alexander Wels 2015-08-17 11:29:37 EDT
(In reply to Einav Cohen from comment #4)
> (In reply to Amador Pahim from comment #3)
> > Issue not present in
> > ovirt-engine-3.6.0-0.0.master.20150811152525.git5823dda.el7.centos.noarch
> 
> strange, as the fix for bug 1251937 [1] was merged to 'ovirt-engine-3.6'
> only after "3.6.0-0.0.master.20150811152525.git5823dda.el7.centos.noarch"
> [2]. 
> maybe was a different issue, that was resolved in a patch earlier than [1]?
> 
> [moving BZ to MODIFIED, as issue is not reproducible anymore]
> 
> [1] https://gerrit.ovirt.org/#/c/44691/ ['ovirt-engine-3.6' fix merged Aug
> 12]
> 
> [2] "3.6.0-0.0.master.20150811152525.git5823dda.el7.centos.noarch" is based
> on git hash "5823dda", which is https://gerrit.ovirt.org/#/c/44664/, which
> was merged Aug 11, before [1] was merged.

I think its because [3] was in that build. That fixed most issues with the dropdown, but apparently I missed something that was fixed in [1].

[3] https://gerrit.ovirt.org/#/c/44498/
Comment 6 Einav Cohen 2015-08-18 10:30:45 EDT
thanks for the clarification, Alexander.
Comment 7 Lukas Svaty 2015-09-16 08:18:55 EDT
verified in rhevm-webadmin-portal-3.6.0-0.15.master.el6.noarch
Comment 8 Sandro Bonazzola 2015-11-04 08:50:22 EST
oVirt 3.6.0 has been released on November 4th, 2015 and should fix this issue.
If problems still persist, please open a new BZ and reference this one.

Note You need to log in before you can comment on or make changes to this bug.