Bug 1253709 - Bad Status Line on the api response when running tempest tests CertificatesV2TestJSON
Bad Status Line on the api response when running tempest tests CertificatesV...
Status: CLOSED NOTABUG
Product: Red Hat OpenStack
Classification: Red Hat
Component: openstack-keystone (Show other bugs)
Director
Unspecified Unspecified
medium Severity medium
: z5
: 7.0 (Kilo)
Assigned To: Nathan Kinder
yeylon@redhat.com
: AutomationBlocker, Triaged, ZStream
: 1293871 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-08-14 09:34 EDT by mathieu bultel
Modified: 2016-04-26 10:36 EDT (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-01-31 08:38:41 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description mathieu bultel 2015-08-14 09:34:38 EDT
Description of problem:

When running tempest on OSP-D tests CertificatesV2TestJSON failed with the following stack trace:


tempest.api.compute.certificates.test_certificates.CertificatesV2TestJSON.test_get_root_certificate[id-3ac273d0-92d2-4632-bdfc-afbc21d4606c]
--------------------------------------------------------------------------------------------------------------------------------------------

Captured traceback:
~~~~~~~~~~~~~~~~~~~
    Traceback (most recent call last):
      File "/home/stack/tempest/tempest/api/compute/certificates/test_certificates.py", line 34, in test_get_root_certificate
        body = self.certificates_client.show_certificate('root')
      File "/home/stack/tempest/tempest/services/compute/json/certificates_client.py", line 26, in show_certificate
        resp, body = self.get(url)
      File "/usr/lib/python2.7/site-packages/tempest_lib/common/rest_client.py", line 267, in get
        return self.request('GET', url, extra_headers, headers)
      File "/usr/lib/python2.7/site-packages/tempest_lib/common/rest_client.py", line 616, in request
        headers=headers, body=body)
      File "/usr/lib/python2.7/site-packages/tempest_lib/common/rest_client.py", line 516, in _request
        req_url, method, headers=req_headers, body=req_body)
      File "/usr/lib/python2.7/site-packages/tempest_lib/common/rest_client.py", line 547, in raw_request
        headers=headers, body=body)
      File "/usr/lib/python2.7/site-packages/tempest_lib/common/http.py", line 25, in request
        return super(ClosingHttp, self).request(*args, **new_kwargs)
      File "/usr/lib/python2.7/site-packages/httplib2/__init__.py", line 1605, in request
        (response, content) = self._request(conn, authority, uri, request_uri, method, body, headers, redirections, cachekey)
      File "/usr/lib/python2.7/site-packages/httplib2/__init__.py", line 1353, in _request
        (response, content) = self._conn_request(conn, request_uri, method, body, headers)
      File "/usr/lib/python2.7/site-packages/httplib2/__init__.py", line 1323, in _conn_request
        response = conn.getresponse()
      File "/usr/lib64/python2.7/httplib.py", line 1045, in getresponse
        response.begin()
      File "/usr/lib64/python2.7/httplib.py", line 409, in begin
        version, status, reason = self._read_status()
      File "/usr/lib64/python2.7/httplib.py", line 373, in _read_status
        raise BadStatusLine(line)
    BadStatusLine: ''
    Traceback (most recent call last):
    _StringException: Empty attachments:
      pythonlogging:''
      stderr
      stdout
    
    Traceback (most recent call last):
      File "/home/stack/tempest/tempest/api/compute/certificates/test_certificates.py", line 34, in test_get_root_certificate
        body = self.certificates_client.show_certificate('root')
      File "/home/stack/tempest/tempest/services/compute/json/certificates_client.py", line 26, in show_certificate
        resp, body = self.get(url)
      File "/usr/lib/python2.7/site-packages/tempest_lib/common/rest_client.py", line 267, in get
        return self.request('GET', url, extra_headers, headers)
      File "/usr/lib/python2.7/site-packages/tempest_lib/common/rest_client.py", line 616, in request
        headers=headers, body=body)
      File "/usr/lib/python2.7/site-packages/tempest_lib/common/rest_client.py", line 516, in _request
        req_url, method, headers=req_headers, body=req_body)
      File "/usr/lib/python2.7/site-packages/tempest_lib/common/rest_client.py", line 547, in raw_request
        headers=headers, body=body)
      File "/usr/lib/python2.7/site-packages/tempest_lib/common/http.py", line 25, in request
        return super(ClosingHttp, self).request(*args, **new_kwargs)
      File "/usr/lib/python2.7/site-packages/httplib2/__init__.py", line 1605, in request
        (response, content) = self._request(conn, authority, uri, request_uri, method, body, headers, redirections, cachekey)
      File "/usr/lib/python2.7/site-packages/httplib2/__init__.py", line 1353, in _request
        (response, content) = self._conn_request(conn, request_uri, method, body, headers)
      File "/usr/lib/python2.7/site-packages/httplib2/__init__.py", line 1323, in _conn_request
        response = conn.getresponse()
      File "/usr/lib64/python2.7/httplib.py", line 1045, in getresponse
        response.begin()
      File "/usr/lib64/python2.7/httplib.py", line 409, in begin
        version, status, reason = self._read_status()
      File "/usr/lib64/python2.7/httplib.py", line 373, in _read_status
        raise BadStatusLine(line)
    BadStatusLine: ''
    
    Traceback (most recent call last):
    _StringException: Empty attachments:
      pythonlogging:''
      stderr
      stdout
    
    Traceback (most recent call last):
      File "/home/stack/tempest/tempest/api/compute/certificates/test_certificates.py", line 34, in test_get_root_certificate
        body = self.certificates_client.show_certificate('root')
      File "/home/stack/tempest/tempest/services/compute/json/certificates_client.py", line 26, in show_certificate
        resp, body = self.get(url)
      File "/usr/lib/python2.7/site-packages/tempest_lib/common/rest_client.py", line 267, in get
        return self.request('GET', url, extra_headers, headers)
      File "/usr/lib/python2.7/site-packages/tempest_lib/common/rest_client.py", line 616, in request
        headers=headers, body=body)
      File "/usr/lib/python2.7/site-packages/tempest_lib/common/rest_client.py", line 516, in _request
        req_url, method, headers=req_headers, body=req_body)
      File "/usr/lib/python2.7/site-packages/tempest_lib/common/rest_client.py", line 547, in raw_request
        headers=headers, body=body)
      File "/usr/lib/python2.7/site-packages/tempest_lib/common/http.py", line 25, in request
        return super(ClosingHttp, self).request(*args, **new_kwargs)
      File "/usr/lib/python2.7/site-packages/httplib2/__init__.py", line 1605, in request
        (response, content) = self._request(conn, authority, uri, request_uri, method, body, headers, redirections, cachekey)
      File "/usr/lib/python2.7/site-packages/httplib2/__init__.py", line 1353, in _request
        (response, content) = self._conn_request(conn, request_uri, method, body, headers)
      File "/usr/lib/python2.7/site-packages/httplib2/__init__.py", line 1323, in _conn_request
        response = conn.getresponse()
      File "/usr/lib64/python2.7/httplib.py", line 1045, in getresponse
        response.begin()
      File "/usr/lib64/python2.7/httplib.py", line 409, in begin
        version, status, reason = self._read_status()
      File "/usr/lib64/python2.7/httplib.py", line 373, in _read_status
        raise BadStatusLine(line)
    BadStatusLine: ''
    
    


======
Totals
======
Ran: 2 tests in 189.0000 sec.
 - Passed: 0
 - Skipped: 0
 - Expected Fail: 0
 - Unexpected Success: 0
 - Failed: 2
Sum of execute time for each test: 180.1784 sec.

==============
Worker Balance
==============
 - Worker 0 (2 tests) => 0:03:00.178989s
Comment 6 David Kranz 2015-12-23 09:01:10 EST
*** Bug 1293871 has been marked as a duplicate of this bug. ***
Comment 7 wes hayutin 2016-01-31 08:38:41 EST
This is not reproducing in the latest builds

Note You need to log in before you can comment on or make changes to this bug.