Bug 1293871 - test_create_root_certificate fails with BadErrorLine
test_create_root_certificate fails with BadErrorLine
Status: CLOSED DUPLICATE of bug 1253709
Product: Red Hat OpenStack
Classification: Red Hat
Component: openstack-tempest (Show other bugs)
7.0 (Kilo)
Unspecified Unspecified
unspecified Severity unspecified
: ---
: 8.0 (Liberty)
Assigned To: David Kranz
tkammer
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-12-23 05:27 EST by Evgeny
Modified: 2015-12-23 09:01 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-12-23 09:01:10 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Evgeny 2015-12-23 05:27:25 EST
Description of problem:


tempest.api.compute.certificates.test_certificates.CertificatesV2TestJSON.test_create_root_certificate fails with :


Traceback (most recent call last):
  File "tempest/api/compute/certificates/test_certificates.py", line 34, in test_create_root_certificate
    body = self.certificates_client.create_certificate()['certificate']
  File "/opt/ws/tempest/.tox/full/lib/python2.7/site-packages/tempest_lib/services/compute/certificates_client.py", line 34, in create_certificate
    resp, body = self.post(url, None)
  File "/opt/ws/tempest/.tox/full/lib/python2.7/site-packages/tempest_lib/common/rest_client.py", line 259, in post
    return self.request('POST', url, extra_headers, headers, body)
  File "/opt/ws/tempest/.tox/full/lib/python2.7/site-packages/tempest_lib/common/rest_client.py", line 627, in request
    headers=headers, body=body)
  File "/opt/ws/tempest/.tox/full/lib/python2.7/site-packages/tempest_lib/common/rest_client.py", line 526, in _request
    req_url, method, headers=req_headers, body=req_body)
  File "/opt/ws/tempest/.tox/full/lib/python2.7/site-packages/tempest_lib/common/rest_client.py", line 557, in raw_request
    headers=headers, body=body)
  File "/opt/ws/tempest/.tox/full/lib/python2.7/site-packages/tempest_lib/common/http.py", line 25, in request
    return super(ClosingHttp, self).request(*args, **new_kwargs)
  File "/opt/ws/tempest/.tox/full/lib/python2.7/site-packages/httplib2/__init__.py", line 1609, in request
    (response, content) = self._request(conn, authority, uri, request_uri, method, body, headers, redirections, cachekey)
  File "/opt/ws/tempest/.tox/full/lib/python2.7/site-packages/httplib2/__init__.py", line 1351, in _request
    (response, content) = self._conn_request(conn, request_uri, method, body, headers)
  File "/opt/ws/tempest/.tox/full/lib/python2.7/site-packages/httplib2/__init__.py", line 1307, in _conn_request
    response = conn.getresponse()
  File "/usr/lib64/python2.7/httplib.py", line 1051, in getresponse
    response.begin()
  File "/usr/lib64/python2.7/httplib.py", line 415, in begin
    version, status, reason = self._read_status()
  File "/usr/lib64/python2.7/httplib.py", line 379, in _read_status
    raise BadStatusLine(line)
httplib.BadStatusLine: ''

Version-Release number of selected component (if applicable):
y2
multi-nic HA topology. Running tests from the director node

How reproducible:

Execute test tempest.api.compute.certificates.test_certificates.CertificatesV2TestJSON.test_create_root_certificate


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:
Comment 2 David Kranz 2015-12-23 09:00:23 EST
This is not a tempest bug.
Comment 3 David Kranz 2015-12-23 09:01:10 EST

*** This bug has been marked as a duplicate of bug 1253709 ***

Note You need to log in before you can comment on or make changes to this bug.