Bug 1253930 - Please include package for static libraries
Please include package for static libraries
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: SDL2 (Show other bugs)
rawhide
Unspecified Unspecified
low Severity low
: ---
: ---
Assigned To: Igor Gnatenko
Fedora Extras Quality Assurance
:
Depends On:
Blocks: 1307300
  Show dependency treegraph
 
Reported: 2015-08-15 14:47 EDT by Mark Harfouche
Modified: 2016-04-01 10:35 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-02-20 04:06:50 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Patch to enable SDL2-static package (1.47 KB, patch)
2015-08-15 14:47 EDT, Mark Harfouche
no flags Details | Diff
static now requires devel (1.66 KB, patch)
2015-08-15 15:04 EDT, Mark Harfouche
no flags Details | Diff

  None (edit)
Description Mark Harfouche 2015-08-15 14:47:15 EDT
Created attachment 1063301 [details]
Patch to enable SDL2-static package

Static libraries are useful in some cases (embedded development).

The static libraries are already built. They just need to be packaged.

I've attached a patch that does this.

In the meantime, if anybody wants SDL2-static, here is a copr repo with it:

https://copr.fedoraproject.org/coprs/hmaarrfk/fedora-static/
Comment 1 Mark Harfouche 2015-08-15 15:04:07 EDT
Created attachment 1063302 [details]
static now requires devel

Made the static libraries require the headers in the devel package
Comment 2 Igor Gnatenko 2015-08-16 17:00:42 EDT
I don't think this is useful. Is there some project which really wants static lib of SDL2?
Comment 3 Mark Harfouche 2015-08-17 13:17:22 EDT
I'm currently working on a project where a statically linked version of qemu would be very helpful.

The reason for this is that I require to chroot and run a qemu executable.
If qemu is not statically linked, I will need to copy in a large (unknown) amount of libraries into the new chroot.

Thanks for your help.


Side note:
I understand the desire to not have static libraries in the -devel packages, but having a seprate -static package is not a big deal. Developers can decide if statically linking is useful for their applications.

As a Fedora user, I find the lack of availability of -static libraries to be a barrier when moving from a Debian based distro.

Is there somewhere I can more formally make this point?
Comment 4 Mark Harfouche 2015-08-17 13:23:00 EDT
An other note, I'm not sure of the necessity of this specific statically linked library for what I need from qemu-arm-static.

You can target this bug against F22. In the case that I don't get back to you with the necessity of this -static package, this bug will be squashed.
Comment 5 Yaakov Selkowitz 2016-02-19 16:59:42 EST
(In reply to Igor Gnatenko from comment #2)
> I don't think this is useful. Is there some project which really wants
> static lib of SDL2?

libSDL2_test is a static-only library, and is required for SDL2_gfx's testsuite.  At a minimum, that should somehow be made available.
Comment 6 Igor Gnatenko 2016-02-20 04:06:50 EST
I'm not going to add -static package. Sorry.
Comment 7 Tom "spot" Callaway 2016-02-25 14:41:30 EST
I disagree with Igor, and have enabled a -static subpackage for this. It is building for F24 and F25 now.
Comment 8 Yaakov Selkowitz 2016-02-25 17:43:43 EST
(In reply to Tom "spot" Callaway from comment #7)
> I disagree with Igor, and have enabled a -static subpackage for this. It is
> building for F24 and F25 now.

Thank you for doing this.  In order to make SDL2_test more useful in %check (non-interactive), the common.* parts of the following patch would need to be ported:

http://pkgs.fedoraproject.org/cgit/rpms/SDL2_gfx.git/tree/0001-test-Add-batch-switch.patch?id=e9523a4

Would that be accepted?
Comment 9 Mark Harfouche 2016-02-25 19:45:16 EST
Thank you for working on this Spot.
Comment 10 Tom "spot" Callaway 2016-04-01 10:35:23 EDT
(In reply to Yaakov Selkowitz from comment #8)
> (In reply to Tom "spot" Callaway from comment #7)
> > I disagree with Igor, and have enabled a -static subpackage for this. It is
> > building for F24 and F25 now.
> 
> Thank you for doing this.  In order to make SDL2_test more useful in %check
> (non-interactive), the common.* parts of the following patch would need to
> be ported:
> 
> http://pkgs.fedoraproject.org/cgit/rpms/SDL2_gfx.git/tree/0001-test-Add-
> batch-switch.patch?id=e9523a4
> 
> Would that be accepted?

I think that's something you should submit directly to the SDL2 upstream, and we'll inherit if/when they apply it.

Note You need to log in before you can comment on or make changes to this bug.