Bug 1307300 - SDL2_gfx: FTBFS in rawhide
SDL2_gfx: FTBFS in rawhide
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: SDL2_gfx (Show other bugs)
24
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Lubomir Rintel
Fedora Extras Quality Assurance
: Patch
Depends On: 1253930
Blocks: F24FTBFS
  Show dependency treegraph
 
Reported: 2016-02-13 15:58 EST by Fedora Release Engineering
Modified: 2016-03-07 14:02 EST (History)
3 users (show)

See Also:
Fixed In Version: SDL2_gfx-1.0.1-4.fc24
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-03-07 14:02:11 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
build.log (42.64 KB, text/plain)
2016-02-13 15:58 EST, Fedora Release Engineering
no flags Details
root.log (92.30 KB, text/plain)
2016-02-13 15:59 EST, Fedora Release Engineering
no flags Details
state.log (625 bytes, text/plain)
2016-02-13 15:59 EST, Fedora Release Engineering
no flags Details
Patch for rawhide and f24 (2.21 KB, patch)
2016-02-25 17:15 EST, Yaakov Selkowitz
no flags Details | Diff

  None (edit)
Description Fedora Release Engineering 2016-02-13 15:58:57 EST
Your package SDL2_gfx failed to build from source in current rawhide.

http://koji.fedoraproject.org/koji/taskinfo?taskID=12805150

For details on mass rebuild see https://fedoraproject.org/wiki/Fedora_24_Mass_Rebuild
Comment 1 Fedora Release Engineering 2016-02-13 15:58:59 EST
Created attachment 1123970 [details]
build.log
Comment 2 Fedora Release Engineering 2016-02-13 15:59:01 EST
Created attachment 1123971 [details]
root.log
Comment 3 Fedora Release Engineering 2016-02-13 15:59:02 EST
Created attachment 1123972 [details]
state.log
Comment 4 Igor Gnatenko 2016-02-18 04:35:21 EST
it is completely ignores LDFLAGS in test.

Conclusion - rewrite that fuckin buildsystem.
Comment 5 Yaakov Selkowitz 2016-02-19 16:59:56 EST
(In reply to Igor Gnatenko from comment #4)
> it is completely ignores LDFLAGS in test.

Actually, the issue is SDL2_gfx 1.0.1 added a dependency on libSDL2_test, a static library which should be shipped in SDL2-devel but is mistakenly removed.
Comment 6 Igor Gnatenko 2016-02-20 04:05:05 EST
*** Unable to find SDL2_gfx library

this is different issue. and I am able to pass all tests without any static libraries. problem in their fuckin autocrap. If Lubomir will not fix it in next week - I will just replace autotools with something better.
Comment 7 Yaakov Selkowitz 2016-02-20 21:39:20 EST
(In reply to Igor Gnatenko from comment #6)
> *** Unable to find SDL2_gfx library
> 
> this is different issue. and I am able to pass all tests without any static
> libraries.

I ran a mock build, and the *cause* of that error is the -lSDL2_test link flag which causes the link to fail.  This was added as a requirement of the testsuite prior to 1.0.1:

https://sourceforge.net/p/sdl2gfx/code/17/

> If Lubomir will not fix it in next week - I will just replace autotools with 
> something better.

That won't be necessary.  The proper fix is to include libSDL2_test.a in SDL2-devel.
Comment 8 Jan Kurik 2016-02-24 09:32:38 EST
This bug appears to have been reported against 'rawhide' during the Fedora 24 development cycle.
Changing version to '24'.

More information and reason for this action is here:
https://fedoraproject.org/wiki/Fedora_Program_Management/HouseKeeping/Fedora24#Rawhide_Rebase
Comment 9 Yaakov Selkowitz 2016-02-25 17:15 EST
Created attachment 1130672 [details]
Patch for rawhide and f24

- Fix build of testsuite (#1307300)
- Disable tests which require --batch support not in SDL2_test
Comment 10 Yaakov Selkowitz 2016-02-25 17:16:09 EST
Scratch build: http://koji.fedoraproject.org/koji/taskinfo?taskID=13131147
Comment 11 Upstream Release Monitoring 2016-03-07 13:09:35 EST
yselkowitz's SDL2_gfx-1.0.1-4.fc25 completed http://koji.fedoraproject.org/koji/buildinfo?buildID=742668

Note You need to log in before you can comment on or make changes to this bug.