This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 1253972 - Upon removal of assumed connection, crashes with «g_type_instance_get_private: assertion 'instance != NULL && instance->g_class != NULL' failed»
Upon removal of assumed connection, crashes with «g_type_instance_get_privat...
Status: CLOSED DUPLICATE of bug 1253949
Product: Fedora
Classification: Fedora
Component: NetworkManager (Show other bugs)
22
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Thomas Haller
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-08-16 05:07 EDT by Tore Anderson
Modified: 2015-08-18 04:39 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-08-18 04:39:52 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Debug-level NetworkManager journal. (12.00 KB, application/x-gzip)
2015-08-16 05:07 EDT, Tore Anderson
no flags Details

  None (edit)
Description Tore Anderson 2015-08-16 05:07:18 EDT
Created attachment 1063471 [details]
Debug-level NetworkManager journal.

Description of problem:

When an assumed connection (not initially created/set up by NM) is removed, NM throws an assertion failure and subsequently crashes/segfaults.

Version-Release number of selected component (if applicable):

NetworkManager-1.0.6-0.1.20150813git7e2caa2.fc22.x86_64

How reproducible:

100%

Steps to Reproduce:
1. Connect to a network
2. Install clatd (http://github.com/toreanderson/clatd)
3. As root, start clatd (using bogus config if necessary), so it creates a virtual interface, e.g., "/usr/sbin/clatd clat-v6-addr=2001:db8::abcd plat-prefix=2001:db8:64::/96 v4-conncheck-enable=0"
4. Send clatd SIGINT (i.e., press ^C) to cause it to shut down and remove the virtual interface.

Actual results:

NetworkManager crashes. The following relevant error messages are logged:

aug. 16 10:54:29 envy.fud.no NetworkManager[5844]: (NetworkManager:5844): GLib-GObject-CRITICAL **: g_type_instance_get_private: assertion 'instance != NULL && instance->g_class != NULL' failed
aug. 16 10:54:29 envy.fud.no systemd[1]: NetworkManager.service: main process exited, code=dumped, status=11/SEGV

Expected results:

No crash.

Additional info:

I believe this did not happen with NetworkManager version 1.0.4-2.
Comment 1 Thomas Haller 2015-08-16 05:26:15 EDT
Could be duplicate of rh 1253949 ...
Comment 2 Thomas Haller 2015-08-18 04:38:03 EDT
Reproduced, here is a backtrace:

(gdb) bt
#0  0x00007fa43542bd3b in g_logv (breakpoint=1) at gmessages.c:315
#1  0x00007fa43542bd3b in g_logv (log_domain=0x7fa43574fb84 "GLib-GObject", log_level=G_LOG_LEVEL_CRITICAL, format=<optimized out>, args=args@entry=0x7ffdd2588fd0) at gmessages.c:1041
#2  0x00007fa43542beaf in g_log (log_domain=log_domain@entry=0x7fa43574fb84 "GLib-GObject", log_level=log_level@entry=G_LOG_LEVEL_CRITICAL, format=format@entry=0x7fa43549b95d "%s: assertion '%s' failed") at gmessages.c:1079
#3  0x00007fa43542bee9 in g_return_if_fail_warning (log_domain=log_domain@entry=0x7fa43574fb84 "GLib-GObject", pretty_function=pretty_function@entry=0x7fa435757750 <__func__.13966> "g_type_instance_get_private", expression=expression@entry=0x7fa435756a18 "instance != NULL && instance->g_class != NULL") at gmessages.c:1088
#4  0x00007fa435749eaa in g_type_instance_get_private (instance=<optimized out>, private_type=<optimized out>) at gtype.c:4680
#5  0x00005631ea653205 in nm_ip4_config_get_num_addresses (config=0x0) at nm-ip4-config.c:1339
#6  0x00005631ea59f51d in _update_ip4_address (self=0x5631ebf7c4a0 [NMDeviceTun]) at devices/nm-device.c:5949
#7  0x00005631ea5a881d in nm_device_set_ip4_config (self=0x5631ebf7c4a0 [NMDeviceTun], new_config=0x0, default_route_metric=0, commit=1, routes_full_sync=1, reason=0x7ffdd25893d4) at devices/nm-device.c:6430
#8  0x00005631ea5a7c50 in _cleanup_generic_post (self=0x5631ebf7c4a0 [NMDeviceTun], cleanup_type=CLEANUP_TYPE_REMOVED) at devices/nm-device.c:7954
#9  0x00005631ea5a4c6d in nm_device_cleanup (self=0x5631ebf7c4a0 [NMDeviceTun], reason=NM_DEVICE_STATE_REASON_REMOVED, cleanup_type=CLEANUP_TYPE_REMOVED) at devices/nm-device.c:8042
#10 0x00005631ea5a0c00 in _set_state_full (self=0x5631ebf7c4a0 [NMDeviceTun], state=NM_DEVICE_STATE_UNMANAGED, reason=NM_DEVICE_STATE_REASON_REMOVED, quitting=0) at devices/nm-device.c:8371
#11 0x00005631ea598356 in nm_device_state_changed (self=0x5631ebf7c4a0 [NMDeviceTun], state=NM_DEVICE_STATE_UNMANAGED, reason=NM_DEVICE_STATE_REASON_REMOVED) at devices/nm-device.c:8596
#12 0x00005631ea5a06b9 in nm_device_set_unmanaged (self=0x5631ebf7c4a0 [NMDeviceTun], flag=NM_UNMANAGED_INTERNAL, unmanaged=1, reason=NM_DEVICE_STATE_REASON_REMOVED) at devices/nm-device.c:7458
#13 0x00005631ea669d2d in remove_device (manager=0x5631ebf49150 [NMManager], device=0x5631ebf7c4a0 [NMDeviceTun], quitting=0, allow_unmanage=1) at nm-manager.c:824
#14 0x00005631ea670dc6 in _platform_link_cb_idle (data=0x5631ebf9b8b0) at nm-manager.c:1986
#15 0x00007fa435424a8a in g_main_context_dispatch (context=0x5631ebea2360) at gmain.c:3122
#16 0x00007fa435424a8a in g_main_context_dispatch (context=context@entry=0x5631ebea2360) at gmain.c:3737
#17 0x00007fa435424e20 in g_main_context_iterate (context=0x5631ebea2360, block=block@entry=1, dispatch=dispatch@entry=1, self=<optimized out>) at gmain.c:3808
#18 0x00007fa435425142 in g_main_loop_run (loop=0x5631ebea2420) at gmain.c:4002
#19 0x00005631ea59057b in main (argc=1, argv=0x7ffdd2589e08) at main.c:513
Comment 3 Thomas Haller 2015-08-18 04:39:52 EDT

*** This bug has been marked as a duplicate of bug 1253949 ***

Note You need to log in before you can comment on or make changes to this bug.