Bug 1253949 - [abrt] NetworkManager: nm_ip4_config_get_num_addresses(): NetworkManager killed by SIGSEGV
[abrt] NetworkManager: nm_ip4_config_get_num_addresses(): NetworkManager kill...
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: NetworkManager (Show other bugs)
22
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Lubomir Rintel
Fedora Extras Quality Assurance
https://retrace.fedoraproject.org/faf...
abrt_hash:a9d13e434c387de88c945a978de...
:
: 1253972 1254750 1255092 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-08-15 18:58 EDT by Bojan Smojver
Modified: 2015-10-04 18:52 EDT (History)
10 users (show)

See Also:
Fixed In Version: NetworkManager-1.0.6-0.2.20150813git7e2caa2.fc22 NetworkManager-1.0.6-6.fc22
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-10-04 18:52:46 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: backtrace (20.65 KB, text/plain)
2015-08-15 18:58 EDT, Bojan Smojver
no flags Details
File: cgroup (208 bytes, text/plain)
2015-08-15 18:58 EDT, Bojan Smojver
no flags Details
File: core_backtrace (11.41 KB, text/plain)
2015-08-15 18:58 EDT, Bojan Smojver
no flags Details
File: dso_list (5.58 KB, text/plain)
2015-08-15 18:58 EDT, Bojan Smojver
no flags Details
File: environ (72 bytes, text/plain)
2015-08-15 18:58 EDT, Bojan Smojver
no flags Details
File: limits (1.29 KB, text/plain)
2015-08-15 18:58 EDT, Bojan Smojver
no flags Details
File: maps (25.89 KB, text/plain)
2015-08-15 18:58 EDT, Bojan Smojver
no flags Details
File: mountinfo (3.93 KB, text/plain)
2015-08-15 18:58 EDT, Bojan Smojver
no flags Details
File: namespaces (85 bytes, text/plain)
2015-08-15 18:58 EDT, Bojan Smojver
no flags Details
File: open_fds (2.78 KB, text/plain)
2015-08-15 18:58 EDT, Bojan Smojver
no flags Details
File: proc_pid_status (974 bytes, text/plain)
2015-08-15 18:58 EDT, Bojan Smojver
no flags Details
File: var_log_messages (8.09 KB, text/plain)
2015-08-15 18:58 EDT, Bojan Smojver
no flags Details

  None (edit)
Description Bojan Smojver 2015-08-15 18:58:21 EDT
Description of problem:
Resumed from suspend.

Version-Release number of selected component:
NetworkManager-1.0.6-0.1.20150813git7e2caa2.fc22

Additional info:
reporter:       libreport-2.6.2
backtrace_rating: 4
cmdline:        /usr/sbin/NetworkManager --no-daemon
crash_function: nm_ip4_config_get_num_addresses
executable:     /usr/sbin/NetworkManager
global_pid:     935
kernel:         4.1.5-200.fc22.x86_64
runlevel:       N 5
type:           CCpp
uid:            0

Truncated backtrace:
Thread no. 1 (10 frames)
 #0 nm_ip4_config_get_num_addresses at nm-ip4-config.c:1341
 #1 _update_ip4_address at devices/nm-device.c:5949
 #2 nm_device_set_ip4_config at devices/nm-device.c:6430
 #3 _cleanup_generic_post at devices/nm-device.c:7954
 #4 nm_device_cleanup at devices/nm-device.c:8042
 #5 _set_state_full at devices/nm-device.c:8375
 #6 nm_device_state_changed at devices/nm-device.c:8596
 #7 nm_device_set_unmanaged at devices/nm-device.c:7460
 #8 do_sleep_wake at nm-manager.c:3638
 #9 _internal_sleep at nm-manager.c:3696
Comment 1 Bojan Smojver 2015-08-15 18:58:24 EDT
Created attachment 1063340 [details]
File: backtrace
Comment 2 Bojan Smojver 2015-08-15 18:58:26 EDT
Created attachment 1063341 [details]
File: cgroup
Comment 3 Bojan Smojver 2015-08-15 18:58:27 EDT
Created attachment 1063342 [details]
File: core_backtrace
Comment 4 Bojan Smojver 2015-08-15 18:58:29 EDT
Created attachment 1063343 [details]
File: dso_list
Comment 5 Bojan Smojver 2015-08-15 18:58:30 EDT
Created attachment 1063344 [details]
File: environ
Comment 6 Bojan Smojver 2015-08-15 18:58:31 EDT
Created attachment 1063345 [details]
File: limits
Comment 7 Bojan Smojver 2015-08-15 18:58:33 EDT
Created attachment 1063346 [details]
File: maps
Comment 8 Bojan Smojver 2015-08-15 18:58:35 EDT
Created attachment 1063347 [details]
File: mountinfo
Comment 9 Bojan Smojver 2015-08-15 18:58:36 EDT
Created attachment 1063348 [details]
File: namespaces
Comment 10 Bojan Smojver 2015-08-15 18:58:37 EDT
Created attachment 1063349 [details]
File: open_fds
Comment 11 Bojan Smojver 2015-08-15 18:58:38 EDT
Created attachment 1063350 [details]
File: proc_pid_status
Comment 12 Bojan Smojver 2015-08-15 18:58:40 EDT
Created attachment 1063351 [details]
File: var_log_messages
Comment 14 Thomas Haller 2015-08-18 04:39:52 EDT
*** Bug 1253972 has been marked as a duplicate of this bug. ***
Comment 15 Fedora Admin XMLRPC Client 2015-08-18 11:00:34 EDT
This package has changed ownership in the Fedora Package Database.  Reassigning to the new owner of this component.
Comment 16 Dan Williams 2015-08-18 16:39:17 EDT
*** Bug 1254750 has been marked as a duplicate of this bug. ***
Comment 17 Dan Williams 2015-08-20 10:21:06 EDT
*** Bug 1255092 has been marked as a duplicate of this bug. ***
Comment 18 Robert P. J. Day 2015-08-20 15:01:07 EDT
Any ETA for the updated version showing up in "updates-testing"?
Comment 19 Thomas Haller 2015-08-20 15:50:04 EDT
(In reply to Robert P. J. Day from comment #18)
> Any ETA for the updated version showing up in "updates-testing"?

-1 day:

https://bodhi.fedoraproject.org/updates/FEDORA-2015-10143
Comment 20 Tore Anderson 2015-08-21 00:06:48 EDT
(In reply to Thomas Haller from comment #19)
> (In reply to Robert P. J. Day from comment #18)
> > Any ETA for the updated version showing up in "updates-testing"?
> 
> -1 day:
> 
> https://bodhi.fedoraproject.org/updates/FEDORA-2015-10143

There's no mention of this bug being fixed on that page, as far as I can tell? The version shown is 1.0.6-0.2.20150813git7e2caa2, which is the one I have installed, and this bug is most definitively present.
Comment 21 Thomas Haller 2015-08-21 05:11:16 EDT
(In reply to Tore Anderson from comment #20)
> (In reply to Thomas Haller from comment #19)
> > (In reply to Robert P. J. Day from comment #18)
> > > Any ETA for the updated version showing up in "updates-testing"?
> > 
> > -1 day:
> > 
> > https://bodhi.fedoraproject.org/updates/FEDORA-2015-10143
> 
> There's no mention of this bug being fixed on that page, as far as I can
> tell?

Yes, that was an oversight.

> The version shown is 1.0.6-0.2.20150813git7e2caa2, which is the one I
> have installed, and this bug is most definitively present.

Hm, 1:1.0.6-0.2.20150813git7e2caa2 should fix this bug. Could you provide a stacktrace of the crash with the latest package?
Comment 22 Tore Anderson 2015-08-21 05:22:28 EDT
(In reply to Thomas Haller from comment #21)

> Hm, 1:1.0.6-0.2.20150813git7e2caa2 should fix this bug. Could you provide a
> stacktrace of the crash with the latest package?

This bug *first appeared* in 1.0.6-0.2.20150813git7e2caa2, and the stack trace you want is already attached as this bug was filed against that version:

(In reply to Bojan Smojver from comment #0)
> Version-Release number of selected component:
> NetworkManager-1.0.6-0.1.20150813git7e2caa2.fc22
Comment 23 Bojan Smojver 2015-08-21 05:38:25 EDT
Hmm, no. It was reported against 0.1. The current version in testing is 0.2.
Comment 24 Tore Anderson 2015-08-21 05:47:29 EDT
(In reply to Bojan Smojver from comment #23)
> Hmm, no. It was reported against 0.1. The current version in testing is 0.2.

Bah. Right you are. Sorry about the noise - I only looked at the git commit-sha. (I would have expected that if there was a change made on top of that, the new minor/patchlevel "dot" revision would have come *after* the git commit-sha in the version string.)
Comment 25 Fedora Update System 2015-08-21 22:52:18 EDT
NetworkManager-1.0.6-0.2.20150813git7e2caa2.fc22, network-manager-applet-1.0.4-2.fc22 has been pushed to the Fedora 22 testing repository. If problems still persist, please make note of it in this bug report.\nIf you want to test the update, you can install it with \n su -c 'yum --enablerepo=updates-testing update NetworkManager network-manager-applet'. You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2015-10143
Comment 26 Fedora Update System 2015-08-22 21:49:18 EDT
NetworkManager-1.0.6-0.2.20150813git7e2caa2.fc22, network-manager-applet-1.0.4-2.fc22 has been pushed to the Fedora 22 testing repository. If problems still persist, please make note of it in this bug report.\nIf you want to test the update, you can install it with \n su -c 'yum --enablerepo=updates-testing update network-manager-applet NetworkManager'. You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2015-10143
Comment 27 Fedora Update System 2015-09-02 12:22:02 EDT
NetworkManager-1.0.6-2.fc22, NetworkManager-openswan-1.0.6-2.fc22, NetworkManager-openvpn-1.0.6-3.fc22, NetworkManager-vpnc-1.0.6-3.fc22, network-manager-applet-1.0.6-2.fc22 has been pushed to the Fedora 22 testing repository. If problems still persist, please make note of it in this bug report.\nIf you want to test the update, you can install it with \n su -c 'yum --enablerepo=updates-testing update network-manager-applet NetworkManager-openvpn NetworkManager-vpnc NetworkManager NetworkManager-openswan'. You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2015-10143
Comment 28 Fedora Update System 2015-09-08 07:14:43 EDT
NetworkManager-1.0.6-3.fc22 NetworkManager-openswan-1.0.6-2.fc22 NetworkManager-openvpn-1.0.6-3.fc22 NetworkManager-vpnc-1.0.6-3.fc22 network-manager-applet-1.0.6-2.fc22 has been submitted as an update to Fedora 22. https://bodhi.fedoraproject.org/updates/FEDORA-2015-10143
Comment 29 Fedora Update System 2015-09-08 17:26:32 EDT
NetworkManager-1.0.6-4.fc22, NetworkManager-openswan-1.0.6-2.fc22, NetworkManager-openvpn-1.0.6-3.fc22, NetworkManager-vpnc-1.0.6-3.fc22, network-manager-applet-1.0.6-2.fc22 has been pushed to the Fedora 22 testing repository. If problems still persist, please make note of it in this bug report.\nIf you want to test the update, you can install it with \n su -c 'yum --enablerepo=updates-testing update network-manager-applet NetworkManager NetworkManager-openvpn NetworkManager-openswan NetworkManager-vpnc'. You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2015-10143
Comment 30 Fedora Update System 2015-09-28 17:00:56 EDT
NetworkManager-1.0.6-6.fc22 NetworkManager-openswan-1.0.6-2.fc22 NetworkManager-openvpn-1.0.6-3.fc22 NetworkManager-vpnc-1.0.6-3.fc22 network-manager-applet-1.0.6-2.fc22 has been submitted as an update to Fedora 22. https://bodhi.fedoraproject.org/updates/FEDORA-2015-10143
Comment 31 Fedora Update System 2015-10-01 23:49:29 EDT
NetworkManager-1.0.6-6.fc22, NetworkManager-openswan-1.0.6-2.fc22, NetworkManager-openvpn-1.0.6-3.fc22, NetworkManager-vpnc-1.0.6-3.fc22, network-manager-applet-1.0.6-2.fc22 has been pushed to the Fedora 22 testing repository. If problems still persist, please make note of it in this bug report.
If you want to test the update, you can install it with
$ su -c 'dnf --enablerepo=updates-testing update NetworkManager-openswan network-manager-applet NetworkManager NetworkManager-openvpn NetworkManager-vpnc'
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2015-10143
Comment 32 Fedora Update System 2015-10-04 18:52:14 EDT
NetworkManager-1.0.6-6.fc22, NetworkManager-openswan-1.0.6-2.fc22, NetworkManager-openvpn-1.0.6-3.fc22, NetworkManager-vpnc-1.0.6-3.fc22, network-manager-applet-1.0.6-2.fc22 has been pushed to the Fedora 22 stable repository. If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.