This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 1254005 - dnf exclude doesn't work
dnf exclude doesn't work
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: dnf (Show other bugs)
26
Unspecified Unspecified
low Severity unspecified
: ---
: ---
Assigned To: rpm-software-management
Fedora Extras Quality Assurance
: Reopened, Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-08-16 10:42 EDT by Tom Horsley
Modified: 2017-03-20 12:37 EDT (History)
10 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-03-20 12:08:18 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Tom Horsley 2015-08-16 10:42:03 EDT
Description of problem:
Over in bug 1249309 (in comment 15) there is a pointer to a koji build
of xorg-x11-drv-libinput I need to use to fix my drag lock problems.

In the repos there is a xorg-x11-drv-libinput-0.13.0-1.fc22.x86_64.rpm
which looks "newer" to dnf.

I don't want the repo version though because it doesn't have the drag lock
bug fix yet, so I tried adding this line to /etc/dnf/dnf.conf

exclude=xorg-x11-drv-libinput-0.13.0-1.*

It has no effect though, it keeps on downloading and trying to install the libinput driver from the repos. I just want it to exclude that version because a newer version is likely to contain the drag lock fix, so I'm willing to try the next version, just not that version, but I can't seem to get exclude to do that.

Version-Release number of selected component (if applicable):
dnf-1.1.0-2.fc22.noarch


How reproducible:
100%

Steps to Reproduce:
1.add the exclude line above in the [main] section
2.dnf clean packages
3.dnf clean metadata
4.dnf update

Actual results:
The dnf update still wants to:
Upgrading:
 xorg-x11-drv-libinput      x86_64      0.13.0-1.fc22        updates       30 k


Expected results:
No new xorg-x11-drv-libinput till a version newer than 0.13.0-1 comes along.

Additional info:
Comment 1 Honza Silhan 2015-08-31 07:50:32 EDT
As a temp workround use: `exclude=xorg-x11-drv-libinput-0.13.0-1.fc22.*1, please
Comment 2 Tom Horsley 2015-08-31 08:23:53 EDT
This particular example doesn't really matter any longer since the libinput driver with the bugfix has now been released (and is on my system), now I'm just having trouble imagining how the .*1 on the end of the work around ever matches anything :-).
Comment 3 Alexander Todorov 2015-09-14 10:19:17 EDT
Pleas see bug #1262878. Possible duplicate or related.
Comment 4 Paul Howarth 2016-02-12 09:35:18 EST
There's an inconsistency between the config file parser and the command-line option parser. Specifying epoch/version/release for an exclude in the config file does not work, but does with --exclude=n-e:v-r on the command-line.
Comment 5 Fedora Admin XMLRPC Client 2016-07-08 05:29:19 EDT
This package has changed ownership in the Fedora Package Database.  Reassigning to the new owner of this component.
Comment 6 Fedora End Of Life 2016-07-19 13:31:32 EDT
Fedora 22 changed to end-of-life (EOL) status on 2016-07-19. Fedora 22 is
no longer maintained, which means that it will not receive any further
security or bug fix updates. As a result we are closing this bug.

If you can reproduce this bug against a currently maintained version of
Fedora please feel free to reopen this bug against that version. If you
are unable to reopen this bug, please file a new report against the
current release. If you experience problems, please add a comment to this
bug.

Thank you for reporting this bug and we are sorry it could not be fixed.
Comment 7 Paul Howarth 2016-07-20 04:36:43 EDT
Inconsistency between the config file parser and the command-line option parser still present in F-23.
Comment 8 Fedora End Of Life 2016-11-24 07:19:25 EST
This message is a reminder that Fedora 23 is nearing its end of life.
Approximately 4 (four) weeks from now Fedora will stop maintaining
and issuing updates for Fedora 23. It is Fedora's policy to close all
bug reports from releases that are no longer maintained. At that time
this bug will be closed as EOL if it remains open with a Fedora  'version'
of '23'.

Package Maintainer: If you wish for this bug to remain open because you
plan to fix it in a currently maintained version, simply change the 'version' 
to a later Fedora version.

Thank you for reporting this issue and we are sorry that we were not 
able to fix it before Fedora 23 is end of life. If you would still like 
to see this bug fixed and are able to reproduce it against a later version 
of Fedora, you are encouraged  change the 'version' to a later Fedora 
version prior this bug is closed as described in the policy above.

Although we aim to fix as many bugs as possible during every release's 
lifetime, sometimes those efforts are overtaken by events. Often a 
more recent Fedora release includes newer upstream software that fixes 
bugs or makes them obsolete.
Comment 9 Michael Mráka 2016-11-25 04:22:03 EST
Bug is still valid

dnf-2.0.0-0.rc1.1.git.0.e6df665

# dnf install --assumeno libidn2 -x libidn2-0.11-1.*
Last metadata expiration check: 1:07:16 ago on Fri Nov 25 09:12:29 2016 CET.
Dependencies resolved.
==========================================================================================================
 Package                 Arch                   Version                     Repository               Size
==========================================================================================================
Installing:
 libidn2                 x86_64                 0.11-1.fc24                 updates                 102 k

Transaction Summary
==========================================================================================================
Install  1 Package

Total download size: 102 k
Installed size: 335 k
Operation aborted.

while specifying full EVR works

# dnf install --assumeno libidn2 -x libidn2-0.11-1.fc24 
Last metadata expiration check: 1:06:59 ago on Fri Nov 25 09:12:29 2016 CET.
Dependencies resolved.
==========================================================================================================
 Package                 Arch                   Version                      Repository              Size
==========================================================================================================
Installing:
 libidn2                 x86_64                 0.10-4.fc24                  fedora                 101 k

Transaction Summary
==========================================================================================================
Install  1 Package

Total download size: 101 k
Installed size: 300 k
Operation aborted.
Comment 10 Fedora End Of Life 2017-02-28 04:48:21 EST
This bug appears to have been reported against 'rawhide' during the Fedora 26 development cycle.
Changing version to '26'.
Comment 11 Jaroslav Mracek 2017-03-20 12:08:18 EDT
The problem was, that glob usage was not implemented in libdnf for release. I implement it and it was released in libdnf-0.7.2 into rawhide (Fedora26).
Comment 12 Paul Howarth 2017-03-20 12:15:51 EDT
That doesn't sound like it addresses the inconsistency between the command-line and config-file parsers (Comment#4), which manifests without globs. Or does it?
Comment 13 Jaroslav Mracek 2017-03-20 12:37:03 EDT
Ok, the original issue was solved with new conf parser in dnf-2.1. Dnf-2.1 was released into rawhide and will be part of Fedora26. We also provide testing repository for Fedora24+ ("dnf copr enable rpmsoftwaremanagement/dnf-nightly").
Hope that you can try and see improvements in dnf-2.1. 

Have a fun with it.

Note You need to log in before you can comment on or make changes to this bug.