Bug 1262878 - dnf --exclude doesn't work for local installed package
dnf --exclude doesn't work for local installed package
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: dnf (Show other bugs)
24
Unspecified Unspecified
high Severity high
: ---
: ---
Assigned To: Jaroslav Mracek
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-09-14 10:17 EDT by Alexander Todorov
Modified: 2016-10-04 14:07 EDT (History)
9 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-07-21 04:53:26 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Alexander Todorov 2015-09-14 10:17:16 EDT
Description of problem:

# dnf install --allowerasing ./b/BEDTools-2.24.0-5.fc23.x86_64.rpm  -y --exclude="BEDTools"
Last metadata expiration check performed 2:06:59 ago on Mon Sep 14 08:07:37 2015.
Dependencies resolved.
============================================================================================================================================================================
 Package                                Arch                                 Version                                       Repository                                  Size
============================================================================================================================================================================
Installing:
 BEDTools                               x86_64                               2.24.0-5.fc23                                 @commandline                               5.8 M

Transaction Summary
============================================================================================================================================================================
Install  1 Package

Total size: 5.8 M
Installed size: 11 M
Downloading Packages:
Running transaction check
Transaction check succeeded.
Running transaction test
Error: Transaction check error:
  file /usr/bin from install of BEDTools-2.24.0-5.fc23.x86_64 conflicts with file from package filesystem-3.2-34.fc23.x86_64

Error Summary
-------------

dnf-1.1.0-2.fc23.noarch



Related or possible duplicate of bug #1254005.
Comment 1 Radek Holy 2015-09-15 05:07:30 EDT
Just out of curiosity. What is the use case of such command?
Comment 2 Alexander Todorov 2015-09-16 06:20:37 EDT
OK, my intial command was a bit different, something like 

# dnf install --allowerasing ./b/*.x86_64.rpm  -y --exclude="BEDTools"


but BEDTools was still getting pulled in. So to figure out if something else is pulling it as a dependency or dnf is misbehaving I've devised the above command. My expectation was it will abort b/c no packages were specified as yum does.
Comment 3 Jan Kurik 2016-02-24 10:46:12 EST
This bug appears to have been reported against 'rawhide' during the Fedora 24 development cycle.
Changing version to '24'.

More information and reason for this action is here:
https://fedoraproject.org/wiki/Fedora_Program_Management/HouseKeeping/Fedora24#Rawhide_Rebase
Comment 4 Jaroslav Mracek 2016-04-14 09:39:32 EDT
I have created a pull-request: https://github.com/rpm-software-management/dnf/pull/469
Comment 5 Igor Gnatenko 2016-07-21 04:53:26 EDT
PR has been merged, so will be part of DNF 2.0

Note You need to log in before you can comment on or make changes to this bug.