Bug 1254073 - [RFE] Allow creation of gluster volume with arbiter brick
Summary: [RFE] Allow creation of gluster volume with arbiter brick
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: ovirt-engine
Classification: oVirt
Component: RFEs
Version: ---
Hardware: Unspecified
OS: Unspecified
medium
medium vote
Target Milestone: ovirt-4.1.0-beta
: ---
Assignee: Ramesh N
QA Contact: RamaKasturi
URL:
Whiteboard:
Depends On:
Blocks: Gluster-HC-2
TreeView+ depends on / blocked
 
Reported: 2015-08-17 06:27 UTC by Sahina Bose
Modified: 2017-02-15 14:57 UTC (History)
12 users (show)

Fixed In Version: ovirt-4.1.0-beta
Doc Type: Enhancement
Doc Text:
With this update, support for Gluster arbiter volume creation has been added to Red Hat Virtualization. Arbiter volumes are recommended in place of regular three way replicated volumes to save storage space.
Clone Of:
Environment:
Last Closed: 2017-02-15 14:57:05 UTC
oVirt Team: Gluster
sabose: ovirt-4.1?
ylavi: planning_ack?
rnachimu: devel_ack+
rule-engine: testing_ack+


Attachments (Terms of Use)
Attaching screenshot for the arbiter (156.97 KB, image/png)
2017-01-27 13:41 UTC, RamaKasturi
no flags Details


Links
System ID Priority Status Summary Last Updated
oVirt gerrit 52540 None None None 2016-12-19 09:25:10 UTC

Description Sahina Bose 2015-08-17 06:27:50 UTC
Description of problem:

Glusterfs allows the creation of replica volumes with one brick as an arbiter, to solve the possibility of split brain without the need for three times storage capacity.

Allow creation/management of such volumes from oVirt

Version-Release number of selected component (if applicable):
NA

How reproducible:
NA

Comment 1 Yaniv Lavi 2015-12-14 08:47:27 UTC
This can't be on 3.6.z since it's a RFE. Why did this move to this target?

Comment 2 Sahina Bose 2016-04-05 14:53:19 UTC
Retargeting to 4.1

Comment 3 RamaKasturi 2016-10-03 07:43:36 UTC
When user creates a arbiter volume from CLI it should be synced into UI with out any issues.

Number of bricks field in the general sub tab should be modified to show as "1 x (2 + 1) = 3"

Replica count filed can be removed from the General sub tab of the volume.

Comment 4 Ramesh N 2017-01-02 09:51:36 UTC
Fix is already merged in ovirt-engine-4.1 branch and ovirt-4.1.0-beta build should have the fix.

Comment 5 RamaKasturi 2017-01-27 13:38:51 UTC
Verified and works fine with build ovirt-engine-4.1.0.2-0.1.el7.noarch.

With this build user can  create a arbiter volume from UI. There is a checkbox called 'Arbiter Volume' in the "New Volume" dialog box and once user checks that and provide all the required details it creates an arbiter volume. 

When arbiter volume is created using UI, brick path does not contain arbiter flag and logged a separate BZ for that.

https://bugzilla.redhat.com/show_bug.cgi?id=1417101

Comment 6 RamaKasturi 2017-01-27 13:41:19 UTC
Created attachment 1245153 [details]
Attaching screenshot for the arbiter


Note You need to log in before you can comment on or make changes to this bug.