Bug 125412 - 3ware 7500-8 controller not detected
3ware 7500-8 controller not detected
Status: CLOSED DUPLICATE of bug 124572
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
2
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Arjan van de Ven
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-06-06 12:30 EDT by Eric Karlson
Modified: 2007-11-30 17:10 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 14:03:58 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Eric Karlson 2004-06-06 12:30:17 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.6) Gecko/20040510

Description of problem:
I took a system that was running a 2.4 kernel and tried to install
Fedora Core 2 over it (straight install, not an upgrade).  The 3ware
card was not detected during the installation process, and even once
the system was running Fedora Core 2, any attempt to manually install
the 3w-xxxx driver would fail with a message that there was no such
hardware present.  After a while, I gave up on Fedora Core 2 and
re-installed RedHat 9 over Fedora Core 2.  After the re-install or
RedHat 9 over Fedora, the 3ware card is once again detected and
functions perfectly.

System Details:

Tyan S2707G2N M/B (with latest BIOS v1.07) [all jumpers in their
default position]
512MB DDR266 ECC, Registered RAM (Corsair)
3ware 7500-8 (last firmeware from v7.7.0 release)
Maxtor 40GB UDMA133 IDE drive
3.5" Floppy
52X IDE CD-ROM (Memorex)

The 3ware card is installed in the first PCI-X slot (the one that does
*not* share a PCI bus with the embedded NIC).

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Install Fedora Core 2 on the system described above

Actual Results:  Fedora Core 2 installs, but 3ware card is not
detected and any attempt to run "modprobe 3w-xxxx" to manually install
the driver fails with a no such hardware error.

Expected Results:  Expected to have the 3w-xxxx module loaded and a
functioning 3ware adapter.

Additional info:
Comment 1 Eric Karlson 2004-06-06 12:45:39 EDT
One thought just occured to me here.  The 3ware card is plugged into a
PCI-X slot.  If you look at my other bug (#125416), the NIC that is
not being detected is also on a PCI-X bus.  Maybe something changed
with the 2.6 kernel such that the PCI-X buses are not being detected
anymore?
Comment 2 Eric Karlson 2004-06-08 15:11:01 EDT
See comments on BZ# 125412 as the suggested work-around for that bug 
also seems to fix this issue (i.e. turning off ACPI support).
Comment 3 Len Brown 2004-06-08 20:30:39 EDT

*** This bug has been marked as a duplicate of 124572 ***
Comment 4 Red Hat Bugzilla 2006-02-21 14:03:58 EST
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.

Note You need to log in before you can comment on or make changes to this bug.