This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 124572 - (ACPI) PCI bus #1 not detected in install - ServerWorks
(ACPI) PCI bus #1 not detected in install - ServerWorks
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
2
i386 Linux
medium Severity high
: ---
: ---
Assigned To: Dave Jones
Brian Brock
:
: 125412 125416 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-05-27 12:25 EDT by Elías Halldór Ágústsson
Modified: 2015-01-04 17:06 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-10-29 18:16:33 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Elías Halldór Ágústsson 2004-05-27 12:25:22 EDT
Description of problem:
While trying to install FC2 on an IBM x330, neither ServeRaid nor
Adaptec SCSI are detected. Modules can't be inserted into the kernel.
The output of lspci is similar to this:

00:00.0 Host bridge: ServerWorks CMIC-LE (rev 0a)
00:00.1 Host bridge: ServerWorks CMIC-LE (rev 0a)
00:00.2 Host bridge: ServerWorks CNB20HE Host Bridge (rev 01)
00:00.3 Host bridge: ServerWorks CNB20HE Host Bridge (rev 01)
00:01.0 VGA compatible controller: S3 Inc. Savage 4 (rev 06)
00:02.0 Ethernet controller: Intel Corp. 82557/8/9 [Ethernet Pro 100]
(rev 08)
00:0a.0 Ethernet controller: Intel Corp. 82557/8/9 [Ethernet Pro 100]
(rev 08)
00:0f.0 ISA bridge: ServerWorks OSB4 South Bridge (rev 51)
00:0f.1 IDE interface: ServerWorks OSB4 IDE Controller
00:0f.2 USB Controller: ServerWorks OSB4/CSB5 OHCI USB Controller (rev 04)

while on kernel 2.4, it looks like this:

00:00.0 Host bridge: ServerWorks CMIC-LE (rev 0a)
00:00.1 Host bridge: ServerWorks CMIC-LE (rev 0a)
00:00.2 Host bridge: ServerWorks CNB20HE Host Bridge (rev 01)
00:00.3 Host bridge: ServerWorks CNB20HE Host Bridge (rev 01)
00:01.0 VGA compatible controller: S3 Inc. Savage 4 (rev 06)
00:02.0 Ethernet controller: Intel Corp. 82557/8/9 [Ethernet Pro 100]
(rev 08)
00:0a.0 Ethernet controller: Intel Corp. 82557/8/9 [Ethernet Pro 100]
(rev 08)
00:0f.0 ISA bridge: ServerWorks OSB4 South Bridge (rev 51)
00:0f.1 IDE interface: ServerWorks OSB4 IDE Controller
00:0f.2 USB Controller: ServerWorks OSB4/CSB5 OHCI USB Controller (rev 04)
01:03.0 SCSI storage controller: Adaptec AIC-7892P U160/m (rev 02)
01:06.0 RAID bus controller: IBM ServeRAID Controller

anything on PCI 01 can't be seen under the 2.6 kernel that ships with
the FC2 installer.

How reproducible:

Always

Steps to Reproduce:
1. Boot up from either FC2-i386-disc1.iso or boot.iso
2. Choose install

  
Actual results:

No hard drives are detected. Further investigation shows that the SCSI
hardware is not detected.

Expected results:

Adaptec AIC-7892P U160/m and IBM ServeRAID Controller should be
visible in lspci output.

Additional info:

While browsing for this bug in bugzilla, I found none which matches my
description; however, it seemed to me that there are multiple bugs
which have already been reported which might have the same etiology,
but the reporters hadn't realized that it was a problem with the
kernel PCI drivers.
Comment 1 Dave Jones 2004-05-27 12:41:10 EDT
does it work if you boot with pci=noacpi ?
This sounds like http://bugzilla.kernel.org/show_bug.cgi?id=1662
Comment 2 Len Brown 2004-05-27 18:33:44 EDT
There are two independent proposed fixes for this problem at 
OSDL bug 1662 at the link above.  Perhaps you can let us know if 
they work on this system. 
 
Comment 3 Len Brown 2004-05-27 18:35:27 EDT
woops, bugzilla parsed my text.  just to be extra clear... 
http://bugzilla.kernel.org/show_bug.cgi?id=1662 
 
Comment 4 Len Brown 2004-06-04 00:45:45 EDT
did the fix work? 
Comment 5 Elías Halldór Ágústsson 2004-06-04 06:17:59 EDT
Sorry about the delay, yes it did work. It seems quite smooth now.
Comment 6 Len Brown 2004-06-08 20:29:09 EDT
*** Bug 125416 has been marked as a duplicate of this bug. ***
Comment 7 Len Brown 2004-06-08 20:30:42 EDT
*** Bug 125412 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.