Bug 1254171 - joe fails to build in rawhide
joe fails to build in rawhide
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: joe (Show other bugs)
rawhide
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Nikola Forró
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-08-17 06:50 EDT by Nikola Forró
Modified: 2015-08-17 07:33 EDT (History)
2 users (show)

See Also:
Fixed In Version: joe-3.8-3.fc24
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-08-17 07:33:57 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Nikola Forró 2015-08-17 06:50:12 EDT
Description of problem:
joe fails to build in current rawhide, because rpm now checks for unpackaged files even if they are in %{_pkgdocdir} (see https://bugzilla.redhat.com/show_bug.cgi?id=728959)

Version-Release number of selected component (if applicable):
3.8-2

How reproducible:
always

Steps to Reproduce:
1. fedpkg clone --anonymous joe
2. cd joe
3. fedpkg mockbuild --root fedora-rawhide-x86_64 

Actual results:
Checking for unpackaged file(s): /usr/lib/rpm/check-files /builddir/build/BUILDROOT/joe-3.8-2.fc24.x86_64

RPM build errors:
error: Installed (but unpackaged) file(s) found:
   /usr/share/doc/joe/ChangeLog
   /usr/share/doc/joe/README.old
   /usr/share/doc/joe/hacking.md

Expected results:
package builds successfully

Note You need to log in before you can comment on or make changes to this bug.