Bug 1254197 - Inconsistent directory naming and alternatives handling between Java 6/7 and 8
Inconsistent directory naming and alternatives handling between Java 6/7 and 8
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: java-1.8.0-openjdk (Show other bugs)
6.6
Unspecified Linux
urgent Severity high
: rc
: ---
Assigned To: jiri vanek
Lukas Zachar
: Reopened, ZStream
Depends On: 1217177 1259241
Blocks:
  Show dependency treegraph
 
Reported: 2015-08-17 08:17 EDT by Jan Kurik
Modified: 2016-05-16 11:24 EDT (History)
12 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Previously, the automatically generated name for the installation directory for java-1.8.0-openjdk was not consistent with installation directory names for java-1.6.0-openjdk and java-1.7.0-openjdk. As a consequence, applications and automated tools that expected a consistent Java naming pattern failed when interacting with java-1.8.0-openjdk. With this update, java-1.8.0-openjdk installation directory follows the same pattern as the previous versions, which prevents the described problem. Note that due to the changes in the path structure, it is now impossible to revert to a version of java-1.8.0-openjdk prior to this update.
Story Points: ---
Clone Of: 1217177
Environment:
Last Closed: 2015-09-22 10:03:24 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jan Kurik 2015-08-17 08:17:26 EDT
This bug has been copied from bug #1217177 and has been proposed
to be backported to 6.7 z-stream (EUS).
Comment 7 errata-xmlrpc 2015-09-22 10:03:24 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2015-1828.html
Comment 8 Bryan Totty 2015-10-24 13:10:47 EDT
The errata: https://rhn.redhat.com/errata/RHBA-2015-1828.html does not make mention of alternatives anywhere in the "Details" section. Can we modify or clarify this because it is not entirely clear based on the write up.



Reference notes:

1. openjdk 1.8.0 alternative is changed to 1.7.0 when a 1.8.0 update is applied:

	https://bugzilla.redhat.com/show_bug.cgi?id=1251560 is for RHEL 6.8, when released

2. openjdk 1.8.0 alternative is changed to 1.7.0 when a 1.8.0 update is applied:
	
	https://bugzilla.redhat.com/show_bug.cgi?id=1254198 was the z-stream tracker that we used for RHEL 6.7 (z-stream).

3. https://bugzilla.redhat.com/show_bug.cgi?id=1254198 was closed per comment https://bugzilla.redhat.com/show_bug.cgi?id=1254198#c5

	"I think we can close this z stream clone as it appears the fix will already be included in https://bugzilla.redhat.com/show_bug.cgi?id=1254197"

4. Inconsistent directory naming and alternatives handling between Java 6/7 and 8: 

	https://bugzilla.redhat.com/show_bug.cgi?id=1254197 is "CLOSED ERRATA" 

	https://rhn.redhat.com/errata/RHBA-2015-1828.html


There is no mention of alternatives in the "Details" section of RHBA-2015-1828.

Although, 1254197 - Inconsistent directory naming and alternatives handling between Java 6/7 and 8 is linked to the errata, so it should be addressed here.
Comment 10 jiri vanek 2015-10-26 06:22:47 EDT
(In reply to Bryan Totty from comment #8)
> The errata: https://rhn.redhat.com/errata/RHBA-2015-1828.html does not make
> mention of alternatives anywhere in the "Details" section. Can we modify or
> clarify this because it is not entirely clear based on the write up.
> 

Yes, because they are not there. Side effect of the renaming of links is, that the issue with alternatives will disappear. However not during the update of  this erratum, but during  of any  second update. I'm still not getting what I'm explaining so wrong or what yo would like to make better.

Note You need to log in before you can comment on or make changes to this bug.